summaryrefslogtreecommitdiffstats
path: root/kiosktool/kcms/autostart/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kiosktool/kcms/autostart/CMakeLists.txt')
-rw-r--r--kiosktool/kcms/autostart/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/kiosktool/kcms/autostart/CMakeLists.txt b/kiosktool/kcms/autostart/CMakeLists.txt
new file mode 100644
index 0000000..722a583
--- /dev/null
+++ b/kiosktool/kcms/autostart/CMakeLists.txt
@@ -0,0 +1,34 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kcm_autostart (kpart)
+
+tde_add_kpart( kcm_autostart AUTOMOC
+ SOURCES kcmautostart.cpp
+ LINK tdeio-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### icons
+
+tde_install_icons( autostart )
+
+
+##### other data
+
+install(
+ FILES kcmautostart.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)