summaryrefslogtreecommitdiffstats
path: root/kiosktool/kcms/autostart/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kiosktool/kcms/autostart/Makefile.am')
-rw-r--r--kiosktool/kcms/autostart/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kiosktool/kcms/autostart/Makefile.am b/kiosktool/kcms/autostart/Makefile.am
new file mode 100644
index 0000000..993941a
--- /dev/null
+++ b/kiosktool/kcms/autostart/Makefile.am
@@ -0,0 +1,17 @@
+kde_module_LTLIBRARIES = kcm_autostart.la
+
+kcm_autostart_la_SOURCES = kcmautostart.cpp
+
+kcm_autostart_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+kcm_autostart_la_LIBADD = $(LIB_KIO)
+
+INCLUDES= $(all_includes)
+
+kcm_autostart_la_METASOURCES = AUTO
+
+KDE_ICON = autostart
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kcmautostart.pot
+
+xdg_apps_DATA = kcmautostart.desktop