summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2019-10-17 14:22:44 +0200
committergregory guy <gregory-tde@laposte.net>2019-10-17 14:22:44 +0200
commit9d191894a587d67cacceb69b868160250820cfa7 (patch)
tree3111db0ed259e295a586bf845a0a2e2f151eec03 /CMakeLists.txt
parent8a53bde7e8e5ca828f1908ff4228ee58c34f4177 (diff)
downloadkkbswitch-9d191894a587d67cacceb69b868160250820cfa7.tar.gz
kkbswitch-9d191894a587d67cacceb69b868160250820cfa7.zip
Drop automake build support.
Add basic cmake build instructions in the INSTALL file. Deleted empty file: NEWS. Deleted obsolete file: kkbswitch.spec . Some cleanup in the README, the "man" page and the "help" page files. The man page as well as the icons have moved in their own folder. Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 6 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cedb50d..549b957 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,16 +41,16 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
-option( WITH_RU_UA_LAYOUT "Add Russian and Ukrainian keyboard" ${WITH_ALL_OPTIONS} )
+option( WITH_RU_UA_LAYOUT "Add Russian and Ukrainian keyboard" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -69,26 +69,13 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
+add_subdirectory( icons )
add_subdirectory( ${PROJECT_NAME} )
add_subdirectory( ${PROJECT_NAME}.upd )
tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
-##### man page
-
-INSTALL(
- FILES ${PROJECT_NAME}.1
- DESTINATION ${MAN_INSTALL_DIR}/man1
- COMPONENT doc
-)
-
-
-##### icons
-
-tde_install_icons( ${PROJECT_NAME} )
-
-
##### write configure files
configure_file( config.h.cmake config.h @ONLY )