summaryrefslogtreecommitdiffstats
path: root/kkbswitch/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kkbswitch/Makefile.am')
-rw-r--r--kkbswitch/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/kkbswitch/Makefile.am b/kkbswitch/Makefile.am
new file mode 100644
index 0000000..e3e3779
--- /dev/null
+++ b/kkbswitch/Makefile.am
@@ -0,0 +1,29 @@
+
+METASOURCES = AUTO
+
+bin_PROGRAMS = kkbswitch
+kkbswitch_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+kkbswitch_SOURCES = boldlistboxitem.cpp boldmenuitem.cpp kbconfig.cpp kbconfigdlg.cpp kbgroup.cpp kbpickicondlg.cpp kbswitchapp.cpp kbswitchintf.cpp kbswitchtrayicon.cpp main.cpp pathlistboxitem.cpp xkeyboard.cpp kbswitchintf.skel boldlistboxitem.h boldmenuitem.h kbconfigdlg.h kbconfig.h kbgroup.h kbpickicondlg.h kbswitchapp.h kbswitchintf.h kbswitchtrayicon.h pathlistboxitem.h xkeyboard.h windowwatcher.cpp singlewindowwatcher.cpp windowclasswatcher.cpp
+
+INCLUDES = $(all_includes)
+
+kkbswitch_LDADD = $(LIB_KIO) $(LIB_KDEUI)
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kkbswitch.pot
+
+noinst_HEADERS = windowwatcher.h singlewindowwatcher.h windowclasswatcher.h
+
+kkbswitchdatadir = $(kde_datadir)/kkbswitch
+kkbswitchdata_DATA = group_names
+
+applnkUtilities_DATA = kkbswitch.desktop
+applnkUtilitiesdir = $(kde_appsdir)/Utilities
+
+if ENABLE_RU_UA_LAYOUT
+xkbsymbolsdir = $(x_libraries)/X11/xkb/symbols
+xkbsymbols_DATA = ru_ua
+endif
+
+autostartdir = $(prefix)/share/autostart
+autostart_DATA = kkbswitch.desktop