summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-09-30 16:23:35 +0200
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-10-11 22:23:27 +0800
commit7165adca8c4bf847be42ecb8fc320619e12b8ed9 (patch)
treed503f744e757749b34c66a8918729869bfe2ded6 /CMakeLists.txt
parente1173b7ae2cdf35c3e31d6ffc69fb31e4cd88f7a (diff)
downloadklcddimmer-7165adca8c4bf847be42ecb8fc320619e12b8ed9.tar.gz
klcddimmer-7165adca8c4bf847be42ecb8fc320619e12b8ed9.zip
Drop automake build support.
Add basic cmake build instructions. Deleted empty files ChangeLog and TODO. Rework of the README and NEWS files. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit cf1333ecb3899315c395f307ac66c6f12ce82de6)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dba0efc..aaef19b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks