summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-11 17:58:11 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-11 17:58:29 +0100
commite9607f43a4f3242bd9fc4576eca9f35b586749af (patch)
treecf571fc8945ab019c8de34486b197cf8e9cb4377 /CMakeLists.txt
parent2f270e334bf232c93e13c453450a9f2018b5f096 (diff)
downloadklcddimmer-e9607f43a4f3242bd9fc4576eca9f35b586749af.tar.gz
klcddimmer-e9607f43a4f3242bd9fc4576eca9f35b586749af.zip
Add CMakeL10n rules.
Create translation template. Add CMake rules to build translations. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit f3600bef760f4d15a4838d613da53771f8c0e435)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 55340cf..de2f490 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,7 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
option( BUILD_ALL "Build all" ON )
option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -68,6 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
add_subdirectory( src )
tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files