summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2018-02-17 10:57:56 (GMT)
committer Michele Calgaro <michele.calgaro@yahoo.it>2018-02-17 10:57:56 (GMT)
commitb455dba03644e190ae9ef9038d88dd2b4f30ad0b (patch)
treeab5d9c8706514bc4485bab67eb1a6586f7c59a64
parentd7d668598a39eece1a6cd6076799b111e693d828 (diff)
downloadkmplayer-b455dba0.zip
kmplayer-b455dba0.tar.gz
Fix FTBFS caused by xine >= 1.2.8 (xine-config no longer available from
this version). Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
-rw-r--r--configure.in.in30
1 files changed, 21 insertions, 9 deletions
diff --git a/configure.in.in b/configure.in.in
index 5fe5704..fe247fe 100644
--- a/configure.in.in
+++ b/configure.in.in
@@ -101,18 +101,30 @@ AC_ARG_WITH(xine,
if test "$build_xine" != "no"; then
if test "$have_xine" = "yes"; then
- vers=`xine-config --version 2>/dev/null | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
- if test -n "$vers" && test "$vers" -ge 1000000
- then
+ dnl In xine >= 1.2.8 xine-config is no longer available
+ vers=`pkg-config --modversion libxine 2>/dev/null | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+ if test -n "$vers" && test "$vers" -ge 1000000
+ then
AC_DEFINE(HAVE_XINE, 1, [If we have libxine installed])
- LIB_XINE="`xine-config --libs`"
+ LIB_XINE="`pkg-config --libs libxine`"
AC_SUBST(LIB_XINE)
- CFLAGS_XINE="`xine-config --cflags`"
+ CFLAGS_XINE="`pkg-config --cflags libxine`"
AC_SUBST(CFLAGS_XINE)
- else
- have_xine="no"
- AC_MSG_WARN([Your xine installation is too old (1.0.0 or later required)])
- fi
+ else
+ dnl Use xine-config if an older version of xine is installed
+ vers=`xine-config --version 2>/dev/null | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+ if test -n "$vers" && test "$vers" -ge 1000000
+ then
+ AC_DEFINE(HAVE_XINE, 1, [If we have libxine installed])
+ LIB_XINE="`xine-config --libs`"
+ AC_SUBST(LIB_XINE)
+ CFLAGS_XINE="`xine-config --cflags`"
+ AC_SUBST(CFLAGS_XINE)
+ else
+ have_xine="no"
+ AC_MSG_WARN([Your xine installation is too old (1.0.0 or later required)])
+ fi
+ fi
fi
else
have_xine="no"