summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-17 01:06:58 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-02-17 01:06:58 +0000
commitccceabd36ed168eefd785fb4fb720a577482fec1 (patch)
tree643927e0ff83170395fa3be8f50c69dae48be1ca /configure.in
downloadknemo-ccceabd36ed168eefd785fb4fb720a577482fec1.tar.gz
knemo-ccceabd36ed168eefd785fb4fb720a577482fec1.zip
Added KDE3 version of knemo
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/knemo@1091560 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in270
1 files changed, 270 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..4c43c0b
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,270 @@
+dnl =======================================================
+dnl FILE: ./admin/configure.in.min
+dnl =======================================================
+
+dnl This file is part of the KDE libraries/packages
+dnl Copyright (C) 2001 Stephan Kulow (coolo@kde.org)
+
+dnl This file is free software; you can redistribute it and/or
+dnl modify it under the terms of the GNU Library General Public
+dnl License as published by the Free Software Foundation; either
+dnl version 2 of the License, or (at your option) any later version.
+
+dnl This library is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+dnl Library General Public License for more details.
+
+dnl You should have received a copy of the GNU Library General Public License
+dnl along with this library; see the file COPYING.LIB. If not, write to
+dnl the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+dnl Boston, MA 02110-1301, USA.
+
+# Original Author was Kalle@kde.org
+# I lifted it in some mater. (Stephan Kulow)
+# I used much code from Janos Farkas
+
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(acinclude.m4) dnl a source file from your sub dir
+
+dnl This is so we can use kde-common
+AC_CONFIG_AUX_DIR(admin)
+
+dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
+unset CDPATH
+
+dnl Checking host/target/build systems, for make, install etc.
+AC_CANONICAL_SYSTEM
+dnl Perform program name transformation
+AC_ARG_PROGRAM
+
+dnl Automake doc recommends to do this only here. (Janos)
+AM_INIT_AUTOMAKE(knemo-0.4.8, "3.5.7") dnl searches for some needed programs
+
+KDE_SET_PREFIX
+
+dnl generate the config header
+AM_CONFIG_HEADER(config.h) dnl at the distribution this done
+
+dnl Checks for programs.
+AC_CHECK_COMPILERS
+AC_ENABLE_SHARED(yes)
+AC_ENABLE_STATIC(no)
+KDE_PROG_LIBTOOL
+
+dnl for NLS support. Call them in this order!
+dnl WITH_NLS is for the po files
+AM_KDE_WITH_NLS
+
+KDE_USE_QT(3.2)
+AC_PATH_KDE
+dnl =======================================================
+dnl FILE: configure.in.in
+dnl =======================================================
+
+#MIN_CONFIG(3.2)
+CXXFLAGS="$CXXFLAGS $KDE_DEFAULT_CXXFLAGS"
+
+if test "$build_arts" = "yes"; then
+ AC_DEFINE(USE_ARTS, 1, [If we use arts volume])
+ LIB_ARTS="-lartskde"
+ AC_SUBST(LIB_ARTS)
+fi
+
+KDE_INIT_DOXYGEN([KEG Network API Reference], [Version $VERSION])
+
+dnl =======================================================
+dnl FILE: ./src/configure.in.in
+dnl =======================================================
+
+
+dnl PACKAGE set before
+
+dnl These are common macros that you might or might not want to use
+
+dnl Image readers/writers
+dnl If you want to use this test, you have to define it somewhere
+dnl KDE_CHECK_KIMGIO
+
+dnl Checks for header files.
+AC_HEADER_DIRENT
+AC_HEADER_STDC
+AC_HEADER_TIME
+AC_CHECK_HEADERS(fcntl.h sys/time.h unistd.h stdlib.h paths.h)
+AC_CHECK_FUNCS(usleep)
+AC_CHECK_LIB(iw,iw_sockets_open)
+
+dnl Check path to ifconfig, iwconfig and route.
+
+AC_PATH_PROG([PATH_IFCONFIG],[ifconfig],,
+ [$PATH:/sbin:/usr/sbin:/usr/local/sbin])
+AC_PATH_PROG([PATH_IWCONFIG],[iwconfig],,
+ [$PATH:/sbin:/usr/sbin:/usr/local/sbin])
+AC_PATH_PROG([PATH_ROUTE],[route],,
+ [$PATH:/sbin:/usr/sbin:/usr/local/sbin])
+if test -n "${PATH_IFCONFIG}"; then
+ AC_SUBST([PATH_IFCONFIG])
+ AC_DEFINE_UNQUOTED(PATH_IFCONFIG, "${PATH_IFCONFIG}", [Path of ifconfig program])
+fi
+if test -n "${PATH_IWCONFIG}"; then
+ AC_SUBST([PATH_IWCONFIG])
+ AC_DEFINE_UNQUOTED(PATH_IWCONFIG, "${PATH_IWCONFIG}", [Path of iwconfig program])
+fi
+if test -n "${PATH_ROUTE}"; then
+ AC_SUBST([PATH_ROUTE])
+ AC_DEFINE_UNQUOTED(PATH_ROUTE, "${PATH_ROUTE}", [Path of route program])
+fi
+KDE_CREATE_SUBDIRSLIST
+AM_CONDITIONAL(src_SUBDIR_included, test "x$src_SUBDIR_included" = xyes)
+AM_CONDITIONAL(translations_SUBDIR_included, test "x$translations_SUBDIR_included" = xyes)
+AC_CONFIG_FILES([ Makefile ])
+AC_CONFIG_FILES([ src/Makefile ])
+AC_CONFIG_FILES([ src/kcm/Makefile ])
+AC_CONFIG_FILES([ src/knemod/Makefile ])
+AC_CONFIG_FILES([ src/knemod/backends/Makefile ])
+AC_CONFIG_FILES([ src/knemod/pics/Makefile ])
+AC_CONFIG_FILES([ translations/Makefile ])
+AC_CONFIG_FILES([ translations/ar/Makefile ])
+AC_CONFIG_FILES([ translations/ar/messages/Makefile ])
+AC_CONFIG_FILES([ translations/bg/Makefile ])
+AC_CONFIG_FILES([ translations/bg/messages/Makefile ])
+AC_CONFIG_FILES([ translations/br/Makefile ])
+AC_CONFIG_FILES([ translations/br/messages/Makefile ])
+AC_CONFIG_FILES([ translations/cs/Makefile ])
+AC_CONFIG_FILES([ translations/cs/messages/Makefile ])
+AC_CONFIG_FILES([ translations/cy/Makefile ])
+AC_CONFIG_FILES([ translations/cy/messages/Makefile ])
+AC_CONFIG_FILES([ translations/da/Makefile ])
+AC_CONFIG_FILES([ translations/da/messages/Makefile ])
+AC_CONFIG_FILES([ translations/de/Makefile ])
+AC_CONFIG_FILES([ translations/de/messages/Makefile ])
+AC_CONFIG_FILES([ translations/el/Makefile ])
+AC_CONFIG_FILES([ translations/el/messages/Makefile ])
+AC_CONFIG_FILES([ translations/en_GB/Makefile ])
+AC_CONFIG_FILES([ translations/en_GB/messages/Makefile ])
+AC_CONFIG_FILES([ translations/es/Makefile ])
+AC_CONFIG_FILES([ translations/es/messages/Makefile ])
+AC_CONFIG_FILES([ translations/et/Makefile ])
+AC_CONFIG_FILES([ translations/et/messages/Makefile ])
+AC_CONFIG_FILES([ translations/fr/Makefile ])
+AC_CONFIG_FILES([ translations/fr/messages/Makefile ])
+AC_CONFIG_FILES([ translations/ga/Makefile ])
+AC_CONFIG_FILES([ translations/ga/messages/Makefile ])
+AC_CONFIG_FILES([ translations/gl/Makefile ])
+AC_CONFIG_FILES([ translations/gl/messages/Makefile ])
+AC_CONFIG_FILES([ translations/hu/Makefile ])
+AC_CONFIG_FILES([ translations/hu/messages/Makefile ])
+AC_CONFIG_FILES([ translations/it/Makefile ])
+AC_CONFIG_FILES([ translations/it/messages/Makefile ])
+AC_CONFIG_FILES([ translations/ja/Makefile ])
+AC_CONFIG_FILES([ translations/ja/messages/Makefile ])
+AC_CONFIG_FILES([ translations/ka/Makefile ])
+AC_CONFIG_FILES([ translations/ka/messages/Makefile ])
+AC_CONFIG_FILES([ translations/lt/Makefile ])
+AC_CONFIG_FILES([ translations/lt/messages/Makefile ])
+AC_CONFIG_FILES([ translations/nl/Makefile ])
+AC_CONFIG_FILES([ translations/nl/messages/Makefile ])
+AC_CONFIG_FILES([ translations/pl/Makefile ])
+AC_CONFIG_FILES([ translations/pl/messages/Makefile ])
+AC_CONFIG_FILES([ translations/pt/Makefile ])
+AC_CONFIG_FILES([ translations/pt/messages/Makefile ])
+AC_CONFIG_FILES([ translations/pt_BR/Makefile ])
+AC_CONFIG_FILES([ translations/pt_BR/messages/Makefile ])
+AC_CONFIG_FILES([ translations/ru/Makefile ])
+AC_CONFIG_FILES([ translations/ru/messages/Makefile ])
+AC_CONFIG_FILES([ translations/rw/Makefile ])
+AC_CONFIG_FILES([ translations/rw/messages/Makefile ])
+AC_CONFIG_FILES([ translations/sk/Makefile ])
+AC_CONFIG_FILES([ translations/sk/messages/Makefile ])
+AC_CONFIG_FILES([ translations/sr/Makefile ])
+AC_CONFIG_FILES([ translations/sr/messages/Makefile ])
+AC_CONFIG_FILES([ translations/sr@Latn/Makefile ])
+AC_CONFIG_FILES([ translations/sr@Latn/messages/Makefile ])
+AC_CONFIG_FILES([ translations/sv/Makefile ])
+AC_CONFIG_FILES([ translations/sv/messages/Makefile ])
+AC_CONFIG_FILES([ translations/tr/Makefile ])
+AC_CONFIG_FILES([ translations/tr/messages/Makefile ])
+AC_OUTPUT
+dnl put here things which have to be done as very last part of configure
+
+if test -z "$PATH_IFCONFIG"; then
+ echo ""
+ echo "You're missing the program 'ifconfig'."
+ echo "KNemo won't be able to run without it so please install 'ifconfig'"
+ echo "which is normally part of a package called 'net-tools' or similar"
+ echo "and run configure again."
+ echo ""
+ all_tests=bad
+fi
+
+if test -z "$PATH_IWCONFIG"; then
+ echo ""
+ echo "You're missing the program 'iwconfig'."
+ echo "KNemo works without 'iwconfig' being installed but you won't be able"
+ echo "to monitor the wireless extensions of wireless interfaces."
+ echo "If you would like to have these additional features install"
+ echo "'iwconfig' which can be found in a package called 'wireless-tools'"
+ echo "or similar and run configure again."
+ echo ""
+fi
+
+if test -z "$PATH_ROUTE"; then
+ echo ""
+ echo "You're missing the program 'route'."
+ echo "KNemo works without 'route' being installed but KNemo won't be able"
+ echo "to display the default gateway of an interface."
+ echo "If you would like to have this additional feature install"
+ echo "'route' which can be found in a package called 'net-tools'"
+ echo "or similar and run configure again."
+ echo ""
+fi
+dnl Put here things to be done at the very end - telling users
+dnl about additional packages to install. Better yet is giving
+dnl each project / subdr its own configure.in.bot.
+
+# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
+if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
+ # And if so, warn when they don't match
+ if test "$kde_libs_prefix" != "$given_prefix"; then
+ # And if kde doesn't know about the prefix yet
+ echo ":"`kde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
+ if test $? -ne 0; then
+ echo ""
+ echo "Warning: you chose to install this package in $given_prefix,"
+ echo "but KDE was found in $kde_libs_prefix."
+ echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
+ echo "that KDEDIRS contains it, e.g. export KDEDIRS=$given_prefix:$kde_libs_prefix"
+ echo "Then restart KDE."
+ echo ""
+ fi
+ fi
+fi
+
+if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
+ echo ""
+ echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
+ echo "was not included. Therefore, GCC symbol visibility support remains disabled."
+ echo ""
+ echo "For better performance, consider including the Qt visibility supporting patch"
+ echo "located at:"
+ echo ""
+ echo "http://bugs.kde.org/show_bug.cgi?id=109386"
+ echo ""
+ echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
+ echo "everything will continue to work just fine without it."
+ echo ""
+fi
+
+if test "$all_tests" = "bad"; then
+ if test ! "$cache_file" = "/dev/null"; then
+ echo ""
+ echo "Please remove the file $cache_file after changing your setup"
+ echo "so that configure will find the changes next time."
+ echo ""
+ fi
+else
+ echo ""
+ echo "Good - your configure finished. Start make now"
+ echo ""
+fi