summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am62
1 files changed, 5 insertions, 57 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 411115c..23a795e 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,58 +1,6 @@
-####### tdevelop will overwrite this part!!! (begin)##########
+# the SUBDIRS is filled automatically by am_edit. If files are
+# in this directory they are installed into the english dir
-
-EXTRA_DIST = help_en.docbook help_fr.docbook
-
-####### tdevelop will overwrite this part!!! (end)############
-
-MAINTAINERCLEANFILES = ./*.html
-CLEANFILES = core *~ .deps/* doc/*~ *.orig changes.docbook
-DISTCLEANFILES = Makefile.in Makefile
-
-LANGUAGES = en fr
-SUFFIXES = .docbook .po .pot
-SGMLDIR=$(kde_datadir)/ksgmltools2
-DOCDIR = $(DESTDIR)${kde_htmldir}
-XML2POT = xml2pot
-PO2XML = po2xml
-MSGMERGE = msgmerge
-
-
-help_en.pot: help_en.docbook
- $(XML2POT) help_en.docbook > help_en.pot
-
-# --- translated docbook online help ---
-
-help_fr.po: help_en.pot
- $(MSGMERGE) -o help_fr.po help_fr.po help_en.pot
-
-help_fr.docbook: help_en.docbook help_en.pot
- ${MAKE} help_fr.po
- @echo "converting french help"
- @ $(PO2XML) help_en.docbook help_fr.po | \
- sed s/^\ \ \<\!ENTITY\ %\ English\ /\ \ \<\!ENTITY\ %\ French\ /g \
- > help_fr.docbook
-
-# --- ---
-
-install-data-local:
- echo installing docs in $(DOCDIR)
- for lang in ${LANGUAGES}; do \
- { \
- $(mkinstalldirs) ${DOCDIR}/$${lang}/$(PACKAGE); \
- $(INSTALL_DATA) help_$${lang}.docbook ${DOCDIR}/$${lang}/$(PACKAGE)/index.docbook; \
- if test ! -e ${DOCDIR}/$${lang}/$(PACKAGE)/common ; then \
- rm -f ${DOCDIR}/$${lang}/$(PACKAGE)/common ; fi ; \
- ( cd ${DOCDIR}/$${lang}/${PACKAGE} ; ln -sf ../common . ) ; \
- }; done
- cd ${DOCDIR} ; \
- if test ! -e default/$(PACKAGE) -a -e default ; then ln -sf ../en/$(PACKAGE) default; fi;
-
-uninstall-local:
- for lang in ${LANGUAGES}; do { \
- rm -R -f ${DOCDIR}/$${lang}/${PACKAGE} ; \
- rmdir -p --ignore-fail-on-non-empty $(DOCDIR)/$$lang >/dev/null 2>&1; \
- if test -L ${DOCDIR}/default/$(PACKAGE); then rm -f ${DOCDIR}/default/$(PACKAGE); fi; \
- }; done
-
-all:
+KDE_LANG = en
+KDE_DOCS = knights
+SUBDIRS = $(AUTODIRS)