summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-06-15 13:43:01 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-06-15 16:51:23 +0200
commit70365ebedff4fe76b58533d3c476eaea56ee52b1 (patch)
tree34561343c42e2f883e13f504d6afed15bf7aaf2a /CMakeLists.txt
parentaf8a0ccf990903b851895980bc5d02aad46353db (diff)
downloadkpowersave-70365ebedff4fe76b58533d3c476eaea56ee52b1.tar.gz
kpowersave-70365ebedff4fe76b58533d3c476eaea56ee52b1.zip
add doc and translations to cmake
Signed-off-by: gregory guy <g-gregory@gmx.fr> (cherry picked from commit 1fec079159ddcc9e9358ea9765f9079c892bfbeb)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6f9bcf2..78ae6fd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,13 @@ include( TDESetupPaths )
tde_setup_paths( )
+##### user requested modules ####################
+
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_DOC "Build doc" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### configure checks ##########################
include( ConfigureChecks.cmake )
@@ -55,6 +62,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### source directories ########################
add_subdirectory( src )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files #####################