summaryrefslogtreecommitdiffstats
path: root/po/modules/torrent/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'po/modules/torrent/Makefile.am')
-rw-r--r--po/modules/torrent/Makefile.am68
1 files changed, 68 insertions, 0 deletions
diff --git a/po/modules/torrent/Makefile.am b/po/modules/torrent/Makefile.am
new file mode 100644
index 0000000..df03387
--- /dev/null
+++ b/po/modules/torrent/Makefile.am
@@ -0,0 +1,68 @@
+################################################################################
+# KVirc IRC client Makefile - 18.09.99 Szymon Stefanek <pragma at kvirc dot net>
+################################################################################
+
+# The name of this module
+THISMODULE = torrent
+
+# Don't touch this
+tmpdir = $(localedir)
+
+# The *.mo files to generate
+tmp_DATA = torrent_de.mo \
+ torrent_it.mo \
+ torrent_hu.mo \
+ torrent_pt.mo \
+ torrent_fi.mo \
+ torrent_ru.mo \
+ torrent_cs.mo \
+ torrent_hr.mo \
+ torrent_uk.mo
+
+# The *.po files to generate
+POFILES = torrent_de.po \
+ torrent_it.po \
+ torrent_hu.po \
+ torrent_pt.po \
+ torrent_fi.po \
+ torrent_ru.po \
+ torrent_cs.po \
+ torrent_hr.po \
+ torrent_uk.po
+
+
+###############################################################################
+# STOP EDITING HERE
+###############################################################################
+
+# Killed the fuzzy entries: don't use them , they may SEGV
+# - touch $@ && $(SS_MSGFMT) -fvo $@ $<
+
+CLEANFILES = $(tmp_DATA)
+EXTRA_DIST = $(POFILES)
+
+%.mo: %.po
+ -touch $@ && $(SS_MSGFMT) -vo $@ $<
+
+messages-extract:
+ @find $(topdir)/src/modules/$(THISMODULE)/ -maxdepth 10 -name *.cpp > files; \
+ find $(topdir)/src/modules/$(THISMODULE)/ -maxdepth 10 -name *.h >> files; \
+ xgettext -o $(topdir)/po/modules/$(THISMODULE)/$(THISMODULE).pot -k__tr_ctx -k__tr_no_lookup_ctx -k__tr2qs_ctx -k__tr2wc_ctx -k__tr2ws_ctx -f files; \
+ rm files; \
+ echo "Messages extracted to $(THISMODULE).pot";
+
+messages-update:
+ @old=_old; \
+ if test -f "$(topdir)/po/modules/$(THISMODULE)/$(THISMODULE).pot"; then \
+ for lang in $(POFILES); do \
+ echo "Updating file $$lang"; \
+ mv -f $$lang $$lang$$old; \
+ msgmerge -o $$lang $$lang$$old $(topdir)/po/modules/$(THISMODULE)/$(THISMODULE).pot && rm -f $$lang$$old; \
+ done; \
+ else \
+ echo "----------------------------------------------------"; \
+ echo "- WARNING: ./$(THISMODULE).pot does not exist"; \
+ echo "- WARNING: You must run make messages-extract first"; \
+ echo "----------------------------------------------------"; \
+ fi
+messages: messages-extract messages-update