summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-05-13 14:51:06 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-05-13 14:51:06 +0900
commitdf378ddc984750f135569c9ce292699d2e2120d6 (patch)
tree879492c247d72b71a25d1590a858d5f27884f703 /CMakeLists.txt
parent11cb023db2dafccf30bec902fc7c8fad64d9ede8 (diff)
downloadlibart-lgpl-df378ddc984750f135569c9ce292699d2e2120d6.tar.gz
libart-lgpl-df378ddc984750f135569c9ce292699d2e2120d6.zip
Removed unused files and changed file names to conform to .cmake convention for configuration files.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2772339..e6571c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,8 +73,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### write configure files
configure_file( config.h.cmake config.h @ONLY )
-configure_file( art_config.h.in art_config.h @ONLY )
-configure_file( libart-features.h.in libart-features.h @ONLY )
+configure_file( art_config.h.cmake art_config.h @ONLY )
+configure_file( libart-features.h.cmake libart-features.h @ONLY )
include_directories(
@@ -222,7 +222,7 @@ string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" exec_prefix ${EXEC
string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" includedir ${INCLUDE_INSTALL_DIR} )
string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" libdir ${LIB_INSTALL_DIR} )
-configure_file( libart-2.0.pc.in libart-2.0.pc @ONLY )
+configure_file( libart-2.0.pc.cmake libart-2.0.pc @ONLY )
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/libart-2.0.pc