summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-08-29 23:17:03 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-08-30 22:46:50 +0900
commitf96ef641127d218af91f389f5b63a6a1485a5431 (patch)
treef19a904c01a568dcefba1a638e21fc9e621be49f /configure.in
parenta34a50c944a5c7bb37d2c41a6c33322feb80a595 (diff)
downloadlibkipi-f96ef641127d218af91f389f5b63a6a1485a5431.tar.gz
libkipi-f96ef641127d218af91f389f5b63a6a1485a5431.zip
Removed autotools files and dependency from admin submodule.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in196
1 files changed, 0 insertions, 196 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 15e0f86..0000000
--- a/configure.in
+++ /dev/null
@@ -1,196 +0,0 @@
-dnl =======================================================
-dnl FILE: ./admin/configure.in.min
-dnl =======================================================
-
-dnl This file is part of the KDE libraries/packages
-dnl Copyright (C) 2001 Stephan Kulow (coolo@kde.org)
-
-dnl This file is free software; you can redistribute it and/or
-dnl modify it under the terms of the GNU Library General Public
-dnl License as published by the Free Software Foundation; either
-dnl version 2 of the License, or (at your option) any later version.
-
-dnl This library is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl Library General Public License for more details.
-
-dnl You should have received a copy of the GNU Library General Public License
-dnl along with this library; see the file COPYING.LIB. If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
-dnl Boston, MA 02110-1301, USA.
-
-# Original Author was Kalle@kde.org
-# I lifted it in some mater. (Stephan Kulow)
-# I used much code from Janos Farkas
-
-dnl Process this file with autoconf to produce a configure script.
-
-AC_INIT(acinclude.m4) dnl a source file from your sub dir
-
-dnl This is so we can use kde-common
-AC_CONFIG_AUX_DIR(admin)
-
-dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
-unset CDPATH
-
-dnl Checking host/target/build systems, for make, install etc.
-AC_CANONICAL_SYSTEM
-dnl Perform program name transformation
-AC_ARG_PROGRAM
-
-dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(libkipi-0.1.5, "3.5.5") dnl searches for some needed programs
-
-AM_MAINTAINER_MODE
-
-KDE_SET_PREFIX
-
-dnl generate the config header
-AM_CONFIG_HEADER(config.h) dnl at the distribution this done
-
-dnl Checks for programs.
-AC_CHECK_COMPILERS
-AC_ENABLE_SHARED(yes)
-AC_ENABLE_STATIC(no)
-KDE_PROG_LIBTOOL
-
-dnl for NLS support. Call them in this order!
-dnl WITH_NLS is for the po files
-AM_KDE_WITH_NLS
-
-KDE_USE_TQT(3.2)
-AC_PATH_KDE
-dnl =======================================================
-dnl FILE: configure.in.in
-dnl =======================================================
-
-#MIN_CONFIG(3.2)
-CXXFLAGS="$CXXFLAGS $KDE_DEFAULT_CXXFLAGS"
-
-KDE_ENABLE_HIDDEN_VISIBILITY
-
-KDE_INIT_DOXYGEN([KEG Libraries API Reference], [Version $VERSION])
-
-dnl =======================================================
-dnl FILE: ./libkipi/configure.in.in
-dnl =======================================================
-
-AC_OUTPUT([ libkipi/libkipi.pc ])
-KDE_ENABLE_HIDDEN_VISIBILITY
-
-
-AC_LANG_PUSH(C++)
-libkipi_kdemacros_cppflags=$CPPFLAGS
-CPPFLAGS="$CPPFLAGS $all_includes"
-AC_MSG_CHECKING([if kdemacros.h is usable])
-AC_COMPILE_IFELSE(
- [
- #include <kdemacros.h>
- #include <string>
- int other_func( void ) KDE_EXPORT;
- int other_func( void )
- {
- std::string s("KDE_EXPORT");
- return 0;
- }
- ],
- [ AC_MSG_RESULT([yes])
- AC_DEFINE(KDEMACROS_USABLE, 1, [kdemacros.h usable]) ],
- [ AC_MSG_RESULT([no]) ]
-)
-CPPFLAGS=$libkipi_kdemacros_cppflags
-AC_LANG_POP(C++)
-AM_CONFIG_HEADER([ libkipi/libkipi/libkipi_export.h ])
-KDE_CREATE_SUBDIRSLIST
-AM_CONDITIONAL(libkexif_SUBDIR_included, test "x$libkexif_SUBDIR_included" = xyes)
-AM_CONDITIONAL(libkipi_SUBDIR_included, test "x$libkipi_SUBDIR_included" = xyes)
-AM_CONDITIONAL(doc_SUBDIR_included, test "x$doc_SUBDIR_included" = xyes)
-AM_CONDITIONAL(po_SUBDIR_included, test "x$po_SUBDIR_included" = xyes)
-AC_CONFIG_FILES([ Makefile ])
-AC_CONFIG_FILES([ doc/Makefile ])
-AC_CONFIG_FILES([ libkipi/Makefile ])
-AC_CONFIG_FILES([ libkipi/libkipi/Makefile ])
-AC_CONFIG_FILES([ po/Makefile ])
-AC_CONFIG_FILES([ po/ar/Makefile ])
-AC_CONFIG_FILES([ po/br/Makefile ])
-AC_CONFIG_FILES([ po/ca/Makefile ])
-AC_CONFIG_FILES([ po/cs/Makefile ])
-AC_CONFIG_FILES([ po/cy/Makefile ])
-AC_CONFIG_FILES([ po/da/Makefile ])
-AC_CONFIG_FILES([ po/de/Makefile ])
-AC_CONFIG_FILES([ po/el/Makefile ])
-AC_CONFIG_FILES([ po/en_GB/Makefile ])
-AC_CONFIG_FILES([ po/es/Makefile ])
-AC_CONFIG_FILES([ po/et/Makefile ])
-AC_CONFIG_FILES([ po/fi/Makefile ])
-AC_CONFIG_FILES([ po/fr/Makefile ])
-AC_CONFIG_FILES([ po/ga/Makefile ])
-AC_CONFIG_FILES([ po/gl/Makefile ])
-AC_CONFIG_FILES([ po/is/Makefile ])
-AC_CONFIG_FILES([ po/it/Makefile ])
-AC_CONFIG_FILES([ po/ja/Makefile ])
-AC_CONFIG_FILES([ po/lt/Makefile ])
-AC_CONFIG_FILES([ po/mt/Makefile ])
-AC_CONFIG_FILES([ po/nb/Makefile ])
-AC_CONFIG_FILES([ po/nl/Makefile ])
-AC_CONFIG_FILES([ po/pa/Makefile ])
-AC_CONFIG_FILES([ po/pl/Makefile ])
-AC_CONFIG_FILES([ po/pt/Makefile ])
-AC_CONFIG_FILES([ po/pt_BR/Makefile ])
-AC_CONFIG_FILES([ po/ru/Makefile ])
-AC_CONFIG_FILES([ po/rw/Makefile ])
-AC_CONFIG_FILES([ po/sk/Makefile ])
-AC_CONFIG_FILES([ po/sl/Makefile ])
-AC_CONFIG_FILES([ po/sr/Makefile ])
-AC_CONFIG_FILES([ po/sr@Latn/Makefile ])
-AC_CONFIG_FILES([ po/ta/Makefile ])
-AC_CONFIG_FILES([ po/tr/Makefile ])
-AC_CONFIG_FILES([ po/uk/Makefile ])
-AC_CONFIG_FILES([ po/zh_CN/Makefile ])
-AC_OUTPUT
-# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
-if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
- # And if so, warn when they don't match
- if test "$kde_libs_prefix" != "$given_prefix"; then
- # And if kde doesn't know about the prefix yet
- echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
- if test $? -ne 0; then
- echo ""
- echo "Warning: you chose to install this package in $given_prefix,"
- echo "but KDE was found in $kde_libs_prefix."
- echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
- echo "Then restart KDE."
- echo ""
- fi
- fi
-fi
-
-if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
- echo ""
- echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
- echo "was not included. Therefore, GCC symbol visibility support remains disabled."
- echo ""
- echo "For better performance, consider including the Qt visibility supporting patch"
- echo "located at:"
- echo ""
- echo "http://bugs.kde.org/show_bug.cgi?id=109386"
- echo ""
- echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
- echo "everything will continue to work just fine without it."
- echo ""
-fi
-
-if test "$all_tests" = "bad"; then
- if test ! "$cache_file" = "/dev/null"; then
- echo ""
- echo "Please remove the file $cache_file after changing your setup"
- echo "so that configure will find the changes next time."
- echo ""
- fi
-else
- echo ""
- echo "Good - your configure finished. Start make now"
- echo ""
-fi