summaryrefslogtreecommitdiffstats
path: root/kernel/kls_pict/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kernel/kls_pict/Makefile.am')
-rw-r--r--kernel/kls_pict/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kernel/kls_pict/Makefile.am b/kernel/kls_pict/Makefile.am
new file mode 100644
index 0000000..a5732e7
--- /dev/null
+++ b/kernel/kls_pict/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = -I../include
+
+bin_SCRIPTS = ksquirrel-libs-pict2ppm
+
+pkglib_LTLIBRARIES = libkls_pict.la
+
+libkls_pict_la_SOURCES = fmt_codec_pnm.cpp fmt_codec_pnm_defs.h
+
+libkls_pict_la_LDFLAGS = ${SQ_RELEASE}
+
+libkls_pict_la_LIBADD = ${SQ_LOCAL_RPATH}
+
+AM_CXXFLAGS = -DCODEC_NETPBM -DCODEC_PICT -DNETPBM_S=\"${bindir}/ksquirrel-libs-pict2ppm\"
+
+EXTRA_DIST = ksquirrel-libs-pict2ppm.in \ No newline at end of file