summaryrefslogtreecommitdiffstats
path: root/kernel/kls_xcf/xcf2pnm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kernel/kls_xcf/xcf2pnm/CMakeLists.txt')
-rw-r--r--kernel/kls_xcf/xcf2pnm/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/kernel/kls_xcf/xcf2pnm/CMakeLists.txt b/kernel/kls_xcf/xcf2pnm/CMakeLists.txt
new file mode 100644
index 0000000..5edc991
--- /dev/null
+++ b/kernel/kls_xcf/xcf2pnm/CMakeLists.txt
@@ -0,0 +1,14 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/kernel/include
+ ${CMAKE_BINARY_DIR}
+)
+
+
+##### executable
+
+file( GLOB _bin_c_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_SOURCE_DIR}/*.c )
+tde_add_executable( ksquirrel-libs-xcf2pnm
+ SOURCES ${_bin_c_files}
+ DESTINATION ${BIN_INSTALL_DIR}
+)