summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa3be15..95c8119 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,8 @@ cmake_minimum_required( VERSION 2.6 )
project( libr )
set( PACKAGE libr )
-set( VERSION R14.0.7 )
+set( VERSION R14.0.8 )
+set( PACKAGE_VERSION 0.6.0 )
##### include essential cmake modules ###########
@@ -25,6 +26,7 @@ include( FindPkgConfig )
include( CheckIncludeFile )
include( CheckFunctionExists )
include( CheckLibraryExists )
+include( CheckSymbolExists )
##### include our cmake modules #################
@@ -53,6 +55,9 @@ if( WITH_BACKEND_LIBBFD )
if( NOT HAVE_BFD_H )
tde_message_fatal( "Could not find libbfd header file (bfd.h)!\nThis file is usually included in the package binutils-dev." )
endif( NOT HAVE_BFD_H )
+ tde_save_and_set( CMAKE_REQUIRED_LIBRARIES "bfd" )
+ check_symbol_exists( bfd_asymbol_section bfd.h HAVE_BFD_2_34 )
+ tde_restore( CMAKE_REQUIRED_LIBRARIES )
set( BACKEND_LIBRARIES "-lbfd" )
set( LIBR_BACKEND "bfd" )
set( BACKEND_NAME "libbfd" )
@@ -124,3 +129,7 @@ install( FILES ${CMAKE_CURRENT_BINARY_DIR}/libr.pc
tde_auto_add_subdirectories()
+
+##### write configure files #####################
+
+configure_file( src/config.h.cmake config.h @ONLY )