summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt69
1 files changed, 69 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..7d54add
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,69 @@
+#################################################
+#
+# (C) 2014 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+
+include_directories(
+ ${CMAKE_INSTALL_INCLUDEDIR}/libr
+ ${BACKEND_INCLUDE_DIRS}
+ ${LIBGLADE_INCLUDE_DIRS}
+)
+
+add_definitions(
+ -D__LIBR_BACKEND_${BACKEND_NAME}__
+ -D__LIBR_BUILD__
+)
+
+set( target r )
+
+
+##### library ###################################
+
+set( ${target}_SRCS
+ libr-${LIBR_BACKEND}.c
+ tempfiles.c
+ onecanvas.c
+ libr-icons.c
+ libr-i18n.c
+ libr-gtk.c
+ libr.c
+)
+
+tde_add_library(
+ ${target} SHARED
+ VERSION 0.0.0
+ SOURCES ${${target}_SRCS}
+ LINK ${BACKEND_LIBS}
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+tde_add_library(
+ ${target} STATIC
+ VERSION 0.0.0
+ SOURCES ${${target}_SRCS}
+ LINK ${BACKEND_LIBS}
+ DESTINATION ${LIB_INSTALL_DIR}
+)
+
+
+##### headers ###################################
+
+set( ${target}_INCLUDES
+ gettext.h
+ libr-icons.h
+ libr-i18n.h
+ libr-gtk.h
+ libr.h
+)
+
+install(
+ FILES ${${target}_INCLUDES}
+ DESTINATION ${INCLUDE_INSTALL_DIR}/libr
+)