summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-05-02 15:27:18 +0200
committergregory guy <gregory-tde@laposte.net>2020-05-02 15:27:18 +0200
commitedec9f9049b58e8b3cd0ca2c4560857404fdcc5a (patch)
tree87d4ca0cd2bfd20daf220df123be6ba70ddc15c0 /CMakeLists.txt
parentea50e7d0a298cc36dc0a160ac85cbf77e92d563e (diff)
downloadlibtdeldap-edec9f9049b58e8b3cd0ca2c4560857404fdcc5a.tar.gz
libtdeldap-edec9f9049b58e8b3cd0ca2c4560857404fdcc5a.zip
Drop automake build support.
Add basic cmake build instructions. Add basic README file. Delete empty folders doc and po. Delete empty files ChangeLog, NEWS and TODO. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92c2f33..5cceac2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+#option( BUILD_ALL "Build all" ON )
+#option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+#option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### user defined options
@@ -78,6 +78,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
+
#tde_conditional_add_subdirectory( BUILD_DOC doc )
#tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )