summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Beier <dontmind@freeshell.org>2018-05-12 00:07:10 +0200
committerChristian Beier <dontmind@freeshell.org>2018-07-30 19:15:01 +0200
commit4d3c7dfc044ead78e1ea99d05034451c6c125eb2 (patch)
tree1394c5cec4855a1a664723868992393aa2bb828b /CMakeLists.txt
parent436a047f56cf5f5c92d946faa6b08e3ed7aa2309 (diff)
downloadlibtdevnc-4d3c7dfc044ead78e1ea99d05034451c6c125eb2.tar.gz
libtdevnc-4d3c7dfc044ead78e1ea99d05034451c6c125eb2.zip
CMake: look for SDL2 instead of SDL
FindSDL2.cmake was downloaded from https://github.com/tcbrindle/sdl2-cmake-scripts/blob/master/FindSDL2.cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 995cbc7..c831ee9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,7 +101,7 @@ endif(WITH_PNG)
if(WITH_SDL)
- find_package(SDL)
+ find_package(SDL2)
endif(WITH_SDL)
@@ -500,14 +500,14 @@ set(LIBVNCCLIENT_EXAMPLES
ppmtest
)
-if(SDL_FOUND)
- include_directories(${SDL_INCLUDE_DIR})
+if(SDL2_FOUND)
+ include_directories(${SDL2_INCLUDE_DIR})
set(LIBVNCCLIENT_EXAMPLES
${LIBVNCCLIENT_EXAMPLES}
SDLvncviewer
)
set(SDLvncviewer_EXTRA_SOURCES scrap.c)
-endif(SDL_FOUND)
+endif(SDL2_FOUND)
if(FFMPEG_FOUND)
set(LIBVNCCLIENT_EXAMPLES
@@ -530,7 +530,7 @@ foreach(e ${LIBVNCCLIENT_EXAMPLES})
add_executable(client_examples_${e} ${LIBVNCCLIEXAMPLE_DIR}/${e}.c ${LIBVNCCLIEXAMPLE_DIR}/${${e}_EXTRA_SOURCES} )
set_target_properties(client_examples_${e} PROPERTIES OUTPUT_NAME ${e})
set_target_properties(client_examples_${e} PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/client_examples)
- target_link_libraries(client_examples_${e} vncclient ${CMAKE_THREAD_LIBS_INIT} ${SDL_LIBRARY} ${X11_LIBRARIES} ${FFMPEG_LIBRARIES})
+ target_link_libraries(client_examples_${e} vncclient ${CMAKE_THREAD_LIBS_INIT} ${SDL2_LIBRARY} ${X11_LIBRARIES} ${FFMPEG_LIBRARIES})
endforeach(e ${LIBVNCCLIENT_EXAMPLES})