summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Beier <dontmind@freeshell.org>2017-04-18 22:18:08 +0200
committerChristian Beier <dontmind@freeshell.org>2017-04-18 22:18:08 +0200
commit6d4bb07ea6abf82231ccd3699357b13ae113bb18 (patch)
treef0c8700d8043c4a044d1a453df8fe1dae66cffbb /CMakeLists.txt
parent32301cb73f12d4f7fa78c0ad9a8592aff8c18252 (diff)
downloadlibtdevnc-6d4bb07ea6abf82231ccd3699357b13ae113bb18.tar.gz
libtdevnc-6d4bb07ea6abf82231ccd3699357b13ae113bb18.zip
CMake: detect mmap() and write result to rfbconfig.h
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d39672e..1d00d5c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -151,6 +151,7 @@ check_include_file("sys/types.h" HAVE_SYS_TYPES_H)
check_function_exists(gettimeofday LIBVNCSERVER_HAVE_GETTIMEOFDAY)
check_function_exists(vfork LIBVNCSERVER_HAVE_VFORK)
check_function_exists(vprintf LIBVNCSERVER_HAVE_VPRINTF)
+check_function_exists(mmap LIBVNCSERVER_HAVE_MMAP)
# On systems such as GNU/Linux with glibc, __b64_ntop is defined in a