summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Beier <dontmind@freeshell.org>2017-04-18 23:12:09 +0200
committerChristian Beier <dontmind@freeshell.org>2017-04-18 23:12:09 +0200
commitfc2899af7a3b402d5c689b0cc8527f965875b9e0 (patch)
tree077cfb43b86c07d4d197f47f33e205cf558cfb77 /CMakeLists.txt
parent2197b415f264aa3acfcd70bee1bbac510e560270 (diff)
downloadlibtdevnc-fc2899af7a3b402d5c689b0cc8527f965875b9e0.tar.gz
libtdevnc-fc2899af7a3b402d5c689b0cc8527f965875b9e0.zip
CMake: set LIBVNCSERVER_HAVE_FORK in rfbconfig.h if fork() found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 410f059..a218222 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -152,6 +152,7 @@ check_function_exists(gettimeofday LIBVNCSERVER_HAVE_GETTIMEOFDAY)
check_function_exists(vfork LIBVNCSERVER_HAVE_VFORK)
check_function_exists(vprintf LIBVNCSERVER_HAVE_VPRINTF)
check_function_exists(mmap LIBVNCSERVER_HAVE_MMAP)
+check_function_exists(fork LIBVNCSERVER_HAVE_FORK)
# On systems such as GNU/Linux with glibc, __b64_ntop is defined in a