summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am28
1 files changed, 0 insertions, 28 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
deleted file mode 100644
index f07fc82..0000000
--- a/test/Makefile.am
+++ /dev/null
@@ -1,28 +0,0 @@
-check_PROGRAMS =
-
-if HAVE_LIBJPEG
-# TurboJPEG wrapper tests
-check_PROGRAMS += tjunittest tjbench
-tjunittest_SOURCES=tjunittest.c ../common/turbojpeg.c ../common/turbojpeg.h \
- tjutil.c tjutil.h
-tjbench_SOURCES=tjbench.c ../common/turbojpeg.c ../common/turbojpeg.h \
- tjutil.c tjutil.h bmp.c bmp.h
-tjbench_LDADD=$(LDADD) -lm
-endif
-
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/common
-LDADD = ../libvncserver/libvncserver.la ../libvncclient/libvncclient.la @WSOCKLIB@
-
-if HAVE_LIBPTHREAD
-BACKGROUND_TEST=blooptest
-ENCODINGS_TEST=encodingstest
-endif
-
-copyrecttest_LDADD=$(LDADD) -lm
-
-check_PROGRAMS += $(ENCODINGS_TEST) cargstest copyrecttest $(BACKGROUND_TEST) \
- cursortest
-
-test: encodingstest$(EXEEXT) cargstest$(EXEEXT) copyrecttest$(EXEEXT)
- ./encodingstest && ./cargstest
-