summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-03-20 13:27:39 +0100
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-03-21 23:42:23 +0900
commit7ae90b80a347267de6f30cd6cf5f956f67e2092e (patch)
tree68c831223d40a812a6978019eaeccc280ac58390 /CMakeLists.txt
parente6ffc7b5335d681a5baf88e69f3318be5b1d7924 (diff)
downloadpotracegui-7ae90b80a347267de6f30cd6cf5f956f67e2092e.tar.gz
potracegui-7ae90b80a347267de6f30cd6cf5f956f67e2092e.zip
Drop automake build support.
Add basic cmake build instructions. Delete templates folder. Delete empty files NEWS and TODO. Rework of the README file. Move the desktop file into the XDG_APPS_INSTALL_DIR directory, see TDE/tde#26. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit 52aa25b6f791a82b048d818a61a283e57fdcc9ca)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc3e1dc..03d569e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -69,8 +69,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files