summaryrefslogtreecommitdiffstats
path: root/tde-i18n-cy/configure.in
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-21 02:23:03 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-21 02:23:03 -0600
commit9b58d35185905f8334142bf4988cb784e993aea7 (patch)
treef83ec30722464f6e4d23d6e7a40201d7ef5b6bf4 /tde-i18n-cy/configure.in
downloadtde-i18n-9b58d35185905f8334142bf4988cb784e993aea7.tar.gz
tde-i18n-9b58d35185905f8334142bf4988cb784e993aea7.zip
Initial import of extracted KDE i18n tarballs
Diffstat (limited to 'tde-i18n-cy/configure.in')
-rw-r--r--tde-i18n-cy/configure.in80
1 files changed, 80 insertions, 0 deletions
diff --git a/tde-i18n-cy/configure.in b/tde-i18n-cy/configure.in
new file mode 100644
index 00000000000..95a6b6d31b0
--- /dev/null
+++ b/tde-i18n-cy/configure.in
@@ -0,0 +1,80 @@
+dnl =======================================================
+dnl FILE: configure.in.in
+dnl =======================================================
+
+AC_INIT(messages/Makefile.am)
+AM_INIT_AUTOMAKE(kde-i18n-cy, "3.5.10")
+AM_CONFIG_HEADER(config.h)
+AC_SUBST(AUTODIRS)
+AM_KDE_WITH_NLS
+AC_CREATE_KFSSTND(default)
+KDE_SET_PREFIX
+AC_SUBST_KFSSTND
+AC_PROG_INSTALL
+AC_PROG_LN_S
+KDE_CREATE_SUBDIRSLIST
+AC_CONFIG_FILES([ Makefile ])
+AC_CONFIG_FILES([ messages/Makefile ])
+AC_CONFIG_FILES([ messages/kdeaccessibility/Makefile ])
+AC_CONFIG_FILES([ messages/kdeaddons/Makefile ])
+AC_CONFIG_FILES([ messages/kdeadmin/Makefile ])
+AC_CONFIG_FILES([ messages/kdeartwork/Makefile ])
+AC_CONFIG_FILES([ messages/kdebase/Makefile ])
+AC_CONFIG_FILES([ messages/kdeedu/Makefile ])
+AC_CONFIG_FILES([ messages/kdegames/Makefile ])
+AC_CONFIG_FILES([ messages/kdegraphics/Makefile ])
+AC_CONFIG_FILES([ messages/kdelibs/Makefile ])
+AC_CONFIG_FILES([ messages/kdemultimedia/Makefile ])
+AC_CONFIG_FILES([ messages/kdenetwork/Makefile ])
+AC_CONFIG_FILES([ messages/kdepim/Makefile ])
+AC_CONFIG_FILES([ messages/kdesdk/Makefile ])
+AC_CONFIG_FILES([ messages/kdetoys/Makefile ])
+AC_CONFIG_FILES([ messages/kdeutils/Makefile ])
+AC_CONFIG_FILES([ messages/kdevelop/Makefile ])
+AC_CONFIG_FILES([ messages/kdewebdev/Makefile ])
+AC_OUTPUT
+# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
+if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
+ # And if so, warn when they don't match
+ if test "$kde_libs_prefix" != "$given_prefix"; then
+ # And if kde doesn't know about the prefix yet
+ echo ":"`kde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
+ if test $? -ne 0; then
+ echo ""
+ echo "Warning: you chose to install this package in $given_prefix,"
+ echo "but KDE was found in $kde_libs_prefix."
+ echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
+ echo "that KDEDIRS contains it, e.g. export KDEDIRS=$given_prefix:$kde_libs_prefix"
+ echo "Then restart KDE."
+ echo ""
+ fi
+ fi
+fi
+
+if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
+ echo ""
+ echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
+ echo "was not included. Therefore, GCC symbol visibility support remains disabled."
+ echo ""
+ echo "For better performance, consider including the Qt visibility supporting patch"
+ echo "located at:"
+ echo ""
+ echo "http://bugs.kde.org/show_bug.cgi?id=109386"
+ echo ""
+ echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
+ echo "everything will continue to work just fine without it."
+ echo ""
+fi
+
+if test "$all_tests" = "bad"; then
+ if test ! "$cache_file" = "/dev/null"; then
+ echo ""
+ echo "Please remove the file $cache_file after changing your setup"
+ echo "so that configure will find the changes next time."
+ echo ""
+ fi
+else
+ echo ""
+ echo "Good - your configure finished. Start make now"
+ echo ""
+fi