summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-25 02:27:20 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-25 23:39:39 +0000
commit2fc8b7cd5587edeb411dde24fd0e0e821b2ee399 (patch)
treec4692597d3e3611a07b6be154f327bd2cc910d4d
parentd30296c89551028bf2da84aa4072894c6d7b0608 (diff)
downloadtde-packaging-gentoo-2fc8b7cd5587edeb411dde24fd0e0e821b2ee399.tar.gz
tde-packaging-gentoo-2fc8b7cd5587edeb411dde24fd0e0e821b2ee399.zip
Live ebuilds: Add preliminary KShutDown ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--trinity-apps/kshutdown/kshutdown-9999.ebuild38
-rw-r--r--trinity-apps/kshutdown/metadata.xml7
2 files changed, 45 insertions, 0 deletions
diff --git a/trinity-apps/kshutdown/kshutdown-9999.ebuild b/trinity-apps/kshutdown/kshutdown-9999.ebuild
new file mode 100644
index 00000000..52499b98
--- /dev/null
+++ b/trinity-apps/kshutdown/kshutdown-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs de es fr hu it nl
+ pl pt_BR ru sk sv tr zh_CN"
+
+TRINITY_DOC_LANGS="de"
+
+inherit trinity-base-2
+
+DESCRIPTION="A graphical shutdown utility for TDE"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity 14.1.0
+
+SLOT="${TRINITY_VER}"
+
+IUSE="extras"
+
+RDEPEND="
+ =trinity-base/tdesu-${PV}
+ =trinity-base/kcontrol-${PV}
+ =trinity-base/kdialog-${PV}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_EXTRAS="$(usex extras)"
+ )
+
+ trinity-base-2_src_configure
+} \ No newline at end of file
diff --git a/trinity-apps/kshutdown/metadata.xml b/trinity-apps/kshutdown/metadata.xml
new file mode 100644
index 00000000..61b4108b
--- /dev/null
+++ b/trinity-apps/kshutdown/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Chris</name>
+ </maintainer>
+</pkgmetadata>