summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-09 03:42:17 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 16:33:33 +0000
commit42dffbf8d67de8a9b0ff4f312cfc4f0b85ad8083 (patch)
tree8399b125f010029c9271f77d7af26a6f83f2d482
parent13f3b6432f125802f4fee3827d2b0e882a0a8dfe (diff)
downloadtde-packaging-gentoo-42dffbf8d67de8a9b0ff4f312cfc4f0b85ad8083.tar.gz
tde-packaging-gentoo-42dffbf8d67de8a9b0ff4f312cfc4f0b85ad8083.zip
Live ebuilds: Port to EAPI7 and cleanup - Round 4.
This time: amor, eyesapplet, fifteenapplet, kdict, kget, kmoon, knewsticker, kodo, kopete, kpf, kppp, krdc, krfb, ksirc, ktalkd, kteatime, ktux, kweather, kwifimanager, kworldclock, lisa, tdednssd, tdenetwork-doc, tdenetwork-filesharing, tdenetwork-meta, tdenetwork-tdefile-plugins, tdetoys-doc, and tdetoys-meta Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--trinity-base/amor/amor-9999.ebuild7
-rw-r--r--trinity-base/eyesapplet/eyesapplet-9999.ebuild7
-rw-r--r--trinity-base/fifteenapplet/fifteenapplet-9999.ebuild9
-rw-r--r--trinity-base/kdict/kdict-9999.ebuild7
-rw-r--r--trinity-base/kget/kget-9999.ebuild7
-rw-r--r--trinity-base/kmoon/kmoon-9999.ebuild7
-rw-r--r--trinity-base/knewsticker/knewsticker-9999.ebuild9
-rw-r--r--trinity-base/kodo/kodo-9999.ebuild7
-rw-r--r--trinity-base/kopete/kopete-9999.ebuild76
-rw-r--r--trinity-base/kpf/kpf-9999.ebuild7
-rw-r--r--trinity-base/kppp/kppp-9999.ebuild7
-rw-r--r--trinity-base/krdc/krdc-9999.ebuild12
-rw-r--r--trinity-base/krfb/krfb-9999.ebuild11
-rw-r--r--trinity-base/ksirc/ksirc-9999.ebuild6
-rw-r--r--trinity-base/ktalkd/ktalkd-9999.ebuild13
-rw-r--r--trinity-base/kteatime/kteatime-9999.ebuild7
-rw-r--r--trinity-base/ktux/ktux-9999.ebuild7
-rw-r--r--trinity-base/kweather/kweather-9999.ebuild7
-rw-r--r--trinity-base/kwifimanager/kwifimanager-9999.ebuild13
-rw-r--r--trinity-base/kworldclock/kworldclock-9999.ebuild7
-rw-r--r--trinity-base/lisa/lisa-9999.ebuild10
-rw-r--r--trinity-base/tdednssd/tdednssd-9999.ebuild7
-rw-r--r--trinity-base/tdenetwork-doc/tdenetwork-doc-9999.ebuild19
-rw-r--r--trinity-base/tdenetwork-filesharing/tdenetwork-filesharing-9999.ebuild7
-rw-r--r--trinity-base/tdenetwork-meta/tdenetwork-meta-9999.ebuild45
-rw-r--r--trinity-base/tdenetwork-tdefile-plugins/tdenetwork-tdefile-plugins-9999.ebuild9
-rw-r--r--trinity-base/tdetoys-doc/tdetoys-doc-9999.ebuild17
-rw-r--r--trinity-base/tdetoys-meta/tdetoys-meta-9999.ebuild31
28 files changed, 179 insertions, 199 deletions
diff --git a/trinity-base/amor/amor-9999.ebuild b/trinity-base/amor/amor-9999.ebuild
index 298c6ede..1f8f4a1c 100644
--- a/trinity-base/amor/amor-9999.ebuild
+++ b/trinity-base/amor/amor-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdetoys"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity: Amusing Misuse Of Resources - desktop-dwelling creature"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/eyesapplet/eyesapplet-9999.ebuild b/trinity-base/eyesapplet/eyesapplet-9999.ebuild
index 3f78cc3a..e960ddfb 100644
--- a/trinity-base/eyesapplet/eyesapplet-9999.ebuild
+++ b/trinity-base/eyesapplet/eyesapplet-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdetoys"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="kicker applet: eyes following the movement of the mouse pointer"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/fifteenapplet/fifteenapplet-9999.ebuild b/trinity-base/fifteenapplet/fifteenapplet-9999.ebuild
index 68355a9c..5ddb9b62 100644
--- a/trinity-base/fifteenapplet/fifteenapplet-9999.ebuild
+++ b/trinity-base/fifteenapplet/fifteenapplet-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdetoys"
-inherit trinity-meta
+inherit trinity-meta-2
-DESCRIPTION="kicker plugin for the 15-game"
-KEYWORDS=
-IUSE=""
+DESCRIPTION="Kicker plugin for the 15-game"
diff --git a/trinity-base/kdict/kdict-9999.ebuild b/trinity-base/kdict/kdict-9999.ebuild
index 1f5ad04d..713a410f 100644
--- a/trinity-base/kdict/kdict-9999.ebuild
+++ b/trinity-base/kdict/kdict-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity dict client (for dict.org-like servers)"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/kget/kget-9999.ebuild b/trinity-base/kget/kget-9999.ebuild
index 509f2e38..accb13a7 100644
--- a/trinity-base/kget/kget-9999.ebuild
+++ b/trinity-base/kget/kget-9999.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="An advanced download manager for Trinity"
-KEYWORDS=
-IUSE=""
DEPEND="x11-libs/libXext"
RDEPEND="${DEPEND}"
diff --git a/trinity-base/kmoon/kmoon-9999.ebuild b/trinity-base/kmoon/kmoon-9999.ebuild
index 839933c2..3b8fc0f0 100644
--- a/trinity-base/kmoon/kmoon-9999.ebuild
+++ b/trinity-base/kmoon/kmoon-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdetoys"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity moon phase display"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/knewsticker/knewsticker-9999.ebuild b/trinity-base/knewsticker/knewsticker-9999.ebuild
index f170f6c4..4608da00 100644
--- a/trinity-base/knewsticker/knewsticker-9999.ebuild
+++ b/trinity-base/knewsticker/knewsticker-9999.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="kicker plugin: rss news ticker"
-KEYWORDS=
-IUSE=""
-DEPEND=">=trinity-base/librss-${PV}:${SLOT}"
+DEPEND="=trinity-base/librss-${PV}"
RDEPEND="${DEPEND}"
diff --git a/trinity-base/kodo/kodo-9999.ebuild b/trinity-base/kodo/kodo-9999.ebuild
index da896118..b9e88d35 100644
--- a/trinity-base/kodo/kodo-9999.ebuild
+++ b/trinity-base/kodo/kodo-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdetoys"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity: measure the desktop mileage of your mouse pointer"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/kopete/kopete-9999.ebuild b/trinity-base/kopete/kopete-9999.ebuild
index a938dcc9..eeb7b5cf 100644
--- a/trinity-base/kopete/kopete-9999.ebuild
+++ b/trinity-base/kopete/kopete-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity multi-protocol IM client"
-KEYWORDS=
IUSE="jingle gsmlib netmeeting speex kernel_linux"
PLUGINS="latex autoreplace history contactnotes crypt connectionstatus
@@ -31,14 +31,14 @@ REQUIRED_USE="
# xscreensaver? ( x11-libs/libXScrnSaver )
# xmpp|groupwice? =app-crypt/qca-1.0*
BOTH_DEPEND="
- jingle? ( dev-libs/glib:2 )
- netmeeting? ( dev-libs/glib:2 )
+ jingle? ( dev-libs/glib )
+ netmeeting? ( dev-libs/glib )
webpresence? (
dev-libs/libxml2
dev-libs/libxslt )
jingle? (
dev-libs/expat
- speex? ( >=media-libs/speex-1.1.6 )
+ speex? ( media-libs/speex )
)
gsmlib? ( app-mobilephone/gsmlib )
gadu? ( net-libs/libgadu )
@@ -73,40 +73,40 @@ RDEPEND="${BOTH_DEPEND}
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_with jingle JINGLE)
- $(cmake-utils_use_with gsmlib GSM)
- $(cmake-utils_use_with netmeeting WEBCAM)
- $(cmake-utils_use_with speex SPEEX)
+ -DWITH_JINGLE="$(usex jingle)"
+ -DWITH_GSM="$(usex gsmlib)"
+ -DWITH_WEBCAM="$(usex netmeeting)"
+ -DWITH_SPEEX="$(usex speex)"
- $(cmake-utils_use_build latex KOPETE_PLUGIN_LATEX)
- $(cmake-utils_use_build autoreplace KOPETE_PLUGIN_AUTOREPLACE)
- $(cmake-utils_use_build history KOPETE_PLUGIN_HISTORY)
- $(cmake-utils_use_build contactnotes KOPETE_PLUGIN_CONTACTNOTES)
- $(cmake-utils_use_build crypt KOPETE_PLUGIN_CRYPTOGRAPHY)
- $(cmake-utils_use_build connectionstatus KOPETE_PLUGIN_CONNECTIONSTATUS)
- $(cmake-utils_use_build translator KOPETE_PLUGIN_TRANSLATOR)
- $(cmake-utils_use_build nowlistening KOPETE_PLUGIN_NOWLISTENING)
- $(cmake-utils_use_build webpresence KOPETE_PLUGIN_WEBPRESENCE)
- $(cmake-utils_use_build texteffect KOPETE_PLUGIN_TEXTEFFECT)
- $(cmake-utils_use_build highlight KOPETE_PLUGIN_HIGHLIGHT)
- $(cmake-utils_use_build alias KOPETE_PLUGIN_ALIAS)
- $(cmake-utils_use_build motionautoaway KOPETE_PLUGIN_MOTIONAUTOAWAY)
- $(cmake-utils_use_build netmeeting KOPETE_PLUGIN_NETMEETING)
- $(cmake-utils_use_build addbookmarks KOPETE_PLUGIN_ADDBOOKMARKS)
- $(cmake-utils_use_build statistics KOPETE_PLUGIN_STATISTICS)
- $(cmake-utils_use_build smpppdcs KOPETE_PLUGIN_SMPPPDCS)
+ -DWITH_KOPETE_PLUGIN_LATEX="$(usex latex)"
+ -DWITH_KOPETE_PLUGIN_AUTOREPLACE="$(usex autoreplace)"
+ -DWITH_KOPETE_PLUGIN_HISTORY="$(usex history)"
+ -DWITH_KOPETE_PLUGIN_CONTACTNOTES="$(usex contactnotes)"
+ -DWITH_KOPETE_PLUGIN_CRYPTOGRAPHY="$(usex crypt)"
+ -DWITH_KOPETE_PLUGIN_CONNECTIONSTATUS="$(usex connectionstatus)"
+ -DWITH_KOPETE_PLUGIN_TRANSLATOR="$(usex translator)"
+ -DWITH_KOPETE_PLUGIN_NOWLISTENING="$(usex nowlistening)"
+ -DWITH_KOPETE_PLUGIN_WEBPRESENCE="$(usex webpresence)"
+ -DWITH_KOPETE_PLUGIN_TEXTEFFECT="$(usex texteffect)"
+ -DWITH_KOPETE_PLUGIN_HIGHLIGHT="$(usex highlight)"
+ -DWITH_KOPETE_PLUGIN_ALIAS="$(usex alias)"
+ -DWITH_KOPETE_PLUGIN_MOTIONAUTOAWAY="$(usex motionautoaway)"
+ -DWITH_KOPETE_PLUGIN_NETMEETING="$(usex netmeeting)"
+ -DWITH_KOPETE_PLUGIN_ADDBOOKMARKS="$(usex addbookmarks)"
+ -DWITH_KOPETE_PLUGIN_STATISTICS="$(usex statistics)"
+ -DWITH_KOPETE_PLUGIN_SMPPPDCS="$(usex smpppdcs)"
- $(cmake-utils_use_build gadu KOPETE_PROTOCOL_GADU)
- $(cmake-utils_use_build groupwise KOPETE_PROTOCOL_GROUPWISE)
- $(cmake-utils_use_build irc KOPETE_PROTOCOL_IRC)
- $(cmake-utils_use_build xmpp KOPETE_PROTOCOL_JABBER)
- $(cmake-utils_use_build oscar KOPETE_PROTOCOL_OSCAR)
- $(cmake-utils_use_build msn KOPETE_PROTOCOL_MSN)
- $(cmake-utils_use_build sms KOPETE_PROTOCOL_SMS)
- $(cmake-utils_use_build sametime KOPETE_PROTOCOL_MEANWHILE)
- $(cmake-utils_use_build winpopup KOPETE_PROTOCOL_WINPOPUP)
- $(cmake-utils_use_build yahoo KOPETE_PROTOCOL_YAHOO)
+ -DWITH_KOPETE_PROTOCOL_GADU="$(usex gadu)"
+ -DWITH_KOPETE_PROTOCOL_GROUPWISE="$(usex groupwise)"
+ -DWITH_KOPETE_PROTOCOL_IRC="$(usex irc)"
+ -DWITH_KOPETE_PROTOCOL_JABBER="$(usex xmpp)"
+ -DWITH_KOPETE_PROTOCOL_OSCAR="$(usex oscar)"
+ -DWITH_KOPETE_PROTOCOL_MSN="$(usex msn)"
+ -DWITH_KOPETE_PROTOCOL_SMS="$(usex sms)"
+ -DWITH_KOPETE_PROTOCOL_MEANWHILE="$(usex sametime)"
+ -DWITH_KOPETE_PROTOCOL_WINPOPUP="$(usex winpopup)"
+ -DWITH_KOPETE_PROTOCOL_YAHOO="$(usex yahoo)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}
diff --git a/trinity-base/kpf/kpf-9999.ebuild b/trinity-base/kpf/kpf-9999.ebuild
index 8badb425..4645d3a9 100644
--- a/trinity-base/kpf/kpf-9999.ebuild
+++ b/trinity-base/kpf/kpf-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Kicker file server (http) applet"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/kppp/kppp-9999.ebuild b/trinity-base/kppp/kppp-9999.ebuild
index 3787062a..a718d733 100644
--- a/trinity-base/kppp/kppp-9999.ebuild
+++ b/trinity-base/kppp/kppp-9999.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity: A dialer and front-end to pppd."
-KEYWORDS=
-IUSE=""
RDEPEND="net-dialup/ppp"
diff --git a/trinity-base/krdc/krdc-9999.ebuild b/trinity-base/krdc/krdc-9999.ebuild
index 9e01fa81..33f847d2 100644
--- a/trinity-base/krdc/krdc-9999.ebuild
+++ b/trinity-base/krdc/krdc-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity remote desktop connection (RDP and VNC) client"
-KEYWORDS=
IUSE="rdp slp"
DEPEND="
@@ -15,12 +15,12 @@ DEPEND="
slp? ( net-libs/openslp )
x11-libs/libXext"
RDEPEND="${DEPEND}
- rdp? ( >=net-misc/rdesktop-1.4.1 )"
+ rdp? ( net-misc/rdesktop )"
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_with slp SLP)
+ -DWITH_SLP="$(usex slp)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}
diff --git a/trinity-base/krfb/krfb-9999.ebuild b/trinity-base/krfb/krfb-9999.ebuild
index 48a971bf..6baf431b 100644
--- a/trinity-base/krfb/krfb-9999.ebuild
+++ b/trinity-base/krfb/krfb-9999.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="VNC-compatible server to share Trinity desktops"
-KEYWORDS=
+
IUSE="slp"
DEPEND="
@@ -18,8 +19,8 @@ RDEPEND="${DEPEND}"
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_with slp SLP)
+ -DWITH_SLP="$(usex slp)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}
diff --git a/trinity-base/ksirc/ksirc-9999.ebuild b/trinity-base/ksirc/ksirc-9999.ebuild
index d4d2a258..abed7173 100644
--- a/trinity-base/ksirc/ksirc-9999.ebuild
+++ b/trinity-base/ksirc/ksirc-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity irc client"
-KEYWORDS=
IUSE="ssl"
RDEPEND="dev-lang/perl
diff --git a/trinity-base/ktalkd/ktalkd-9999.ebuild b/trinity-base/ktalkd/ktalkd-9999.ebuild
index a48876ac..5bb3dda2 100644
--- a/trinity-base/ktalkd/ktalkd-9999.ebuild
+++ b/trinity-base/ktalkd/ktalkd-9999.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity talk daemon"
-KEYWORDS=
-IUSE=""
RDEPEND="|| ( net-misc/netkit-talk net-misc/ytalk sys-freebsd/freebsd-ubin )"
pkg_postinst() {
- trinity-meta_pkg_postinst
+ trinity-meta-2_pkg_postinst
if has_version net-misc/ytalk ; then
elog "To use net-misc/ytalk as your local network chat program, please"
- elog "configure your system accordingly, either via the KDE control center"
- elog "or by calling \"kcmshell kcmktalkd\" on the command line."
+ elog "configure your system accordingly, either via the TDE control center"
+ elog "or by calling \"tdecmshell kcmktalkd\" on the command line."
fi
}
diff --git a/trinity-base/kteatime/kteatime-9999.ebuild b/trinity-base/kteatime/kteatime-9999.ebuild
index 7aa0273c..0098839f 100644
--- a/trinity-base/kteatime/kteatime-9999.ebuild
+++ b/trinity-base/kteatime/kteatime-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdetoys"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity utility for making a fine cup of tea"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/ktux/ktux-9999.ebuild b/trinity-base/ktux/ktux-9999.ebuild
index 02999a39..6d0757e8 100644
--- a/trinity-base/ktux/ktux-9999.ebuild
+++ b/trinity-base/ktux/ktux-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdetoys"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity: screensaver featuring the Space-Faring Tux"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/kweather/kweather-9999.ebuild b/trinity-base/kweather/kweather-9999.ebuild
index 3d61a5ad..c3f3d3e6 100644
--- a/trinity-base/kweather/kweather-9999.ebuild
+++ b/trinity-base/kweather/kweather-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdetoys"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity weather status display"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/kwifimanager/kwifimanager-9999.ebuild b/trinity-base/kwifimanager/kwifimanager-9999.ebuild
index 20cb066e..434acc6a 100644
--- a/trinity-base/kwifimanager/kwifimanager-9999.ebuild
+++ b/trinity-base/kwifimanager/kwifimanager-9999.ebuild
@@ -1,24 +1,25 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
TRINITY_SUBMODULE="wifi"
-inherit trinity-meta
+
+inherit trinity-meta-2
DESCRIPTION="Trinity wifi (wireless network) gui"
-KEYWORDS=
IUSE="arts"
DEPEND="
net-wireless/wireless-tools
- arts? ( trinity-base/arts )"
+ arts? ( =trinity-base/arts-${PV} )"
RDEPEND="${DEPEND}"
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_with arts ARTS)
+ -DWITH_ARTS="$(usex arts)"
)
- trinity-meta_src_configure
+ trinity-meta-2_src_configure
}
diff --git a/trinity-base/kworldclock/kworldclock-9999.ebuild b/trinity-base/kworldclock/kworldclock-9999.ebuild
index 8c9e57af..da5d5a89 100644
--- a/trinity-base/kworldclock/kworldclock-9999.ebuild
+++ b/trinity-base/kworldclock/kworldclock-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdetoys"
TRINITY_SUBMODULE="kworldwatch"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Trinity program that displays the part of the Earth lit up by the Sun"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/lisa/lisa-9999.ebuild b/trinity-base/lisa/lisa-9999.ebuild
index 4b01ce18..2b5cb254 100644
--- a/trinity-base/lisa/lisa-9999.ebuild
+++ b/trinity-base/lisa/lisa-9999.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
TRINITY_SUBMODULE="lanbrowsing"
-inherit trinity-meta
+
+inherit trinity-meta-2
DESCRIPTION="Trinity Lan Information Server - allows to share information over a network."
-KEYWORDS=
-IUSE=""
src_install() {
- trinity-meta_src_install
+ trinity-meta-2_src_install
chmod u+s "${D}/${KDEDIR}/bin/reslisa"
diff --git a/trinity-base/tdednssd/tdednssd-9999.ebuild b/trinity-base/tdednssd/tdednssd-9999.ebuild
index 1ee37a50..57cb7bda 100644
--- a/trinity-base/tdednssd/tdednssd-9999.ebuild
+++ b/trinity-base/tdednssd/tdednssd-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="A DNSSD (DNS Service Discovery - part of Rendezvous) ioslave and kded module"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/tdenetwork-doc/tdenetwork-doc-9999.ebuild b/trinity-base/tdenetwork-doc/tdenetwork-doc-9999.ebuild
index bb0e4a14..c49d3ef5 100644
--- a/trinity-base/tdenetwork-doc/tdenetwork-doc-9999.ebuild
+++ b/trinity-base/tdenetwork-doc/tdenetwork-doc-9999.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
+
+DESCRIPTION="Documentaion for tdenetwork-derived packages"
-DESCRIPTION="Documentaion for kdegraphics-derived packages"
-KEYWORDS=
-IUSE=""
RDEPEND="
- >=trinity-base/khelpcenter-${PV}:${SLOT}"
+ =trinity-base/khelpcenter-${PV}"
pkg_setup() {
- # we should reduce MAKEOPTS -j parametr to no more than 4
+ # Issue some warning if MAKEOPTS -j parameter is higher than 4
local makeopts_j
makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
- export MAKEOPTS="${MAKEOPTS//"${makeopts_j}"/-j4}"
ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
- ewarn "mode so it can chew it all. MAKEOPTS are reduced to \"$MAKEOPTS\"."
+ ewarn "mode so it can chew it all. Please change your MAKEOPTS if building fails."
fi
- trinity-meta_pkg_setup
+ trinity-meta-2_pkg_setup
}
diff --git a/trinity-base/tdenetwork-filesharing/tdenetwork-filesharing-9999.ebuild b/trinity-base/tdenetwork-filesharing/tdenetwork-filesharing-9999.ebuild
index 7a6651b7..5b24fe19 100644
--- a/trinity-base/tdenetwork-filesharing/tdenetwork-filesharing-9999.ebuild
+++ b/trinity-base/tdenetwork-filesharing/tdenetwork-filesharing-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="kcontrol filesharing config module for NFS, SMB etc"
-KEYWORDS=
-IUSE=""
diff --git a/trinity-base/tdenetwork-meta/tdenetwork-meta-9999.ebuild b/trinity-base/tdenetwork-meta/tdenetwork-meta-9999.ebuild
index 75409784..7cf8a105 100644
--- a/trinity-base/tdenetwork-meta/tdenetwork-meta-9999.ebuild
+++ b/trinity-base/tdenetwork-meta/tdenetwork-meta-9999.ebuild
@@ -1,36 +1,35 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
-inherit trinity-functions
+inherit trinity-functions-2
set-trinityver
DESCRIPTION="tdenetwork metapackage - merge this to pull in all tdenetwork-derived packages"
HOMEPAGE="http://www.trinitydesktop.org/"
-LICENSE="GPL-2 LGPL-2"
+LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="$TRINITY_VER"
-KEYWORDS=
-IUSE=""
RDEPEND="
- >=trinity-base/dcoprss-${PV}:${SLOT}
- >=trinity-base/kdict-${PV}:${SLOT}
- >=trinity-base/tdednssd-${PV}:${SLOT}
- >=trinity-base/kget-${PV}:${SLOT}
- >=trinity-base/knewsticker-${PV}:${SLOT}
- >=trinity-base/kopete-${PV}:${SLOT}
- >=trinity-base/kpf-${PV}:${SLOT}
- >=trinity-base/kppp-${PV}:${SLOT}
- >=trinity-base/krdc-${PV}:${SLOT}
- >=trinity-base/krfb-${PV}:${SLOT}
- >=trinity-base/ksirc-${PV}:${SLOT}
- >=trinity-base/ktalkd-${PV}:${SLOT}
- >=trinity-base/kwifimanager-${PV}:${SLOT}
- >=trinity-base/librss-${PV}:${SLOT}
- >=trinity-base/lisa-${PV}:${SLOT}
- >=trinity-base/tdenetwork-doc-${PV}:${SLOT}
- >=trinity-base/tdenetwork-filesharing-${PV}:${SLOT}
- >=trinity-base/tdenetwork-tdefile-plugins-${PV}:${SLOT}"
+ =trinity-base/dcoprss-${PV}
+ =trinity-base/kdict-${PV}
+ =trinity-base/tdednssd-${PV}
+ =trinity-base/kget-${PV}
+ =trinity-base/knewsticker-${PV}
+ =trinity-base/kopete-${PV}
+ =trinity-base/kpf-${PV}
+ =trinity-base/kppp-${PV}
+ =trinity-base/krdc-${PV}
+ =trinity-base/krfb-${PV}
+ =trinity-base/ksirc-${PV}
+ =trinity-base/ktalkd-${PV}
+ =trinity-base/kwifimanager-${PV}
+ =trinity-base/librss-${PV}
+ =trinity-base/lisa-${PV}
+ =trinity-base/tdenetwork-doc-${PV}
+ =trinity-base/tdenetwork-filesharing-${PV}
+ =trinity-base/tdenetwork-tdefile-plugins-${PV}"
diff --git a/trinity-base/tdenetwork-tdefile-plugins/tdenetwork-tdefile-plugins-9999.ebuild b/trinity-base/tdenetwork-tdefile-plugins/tdenetwork-tdefile-plugins-9999.ebuild
index d1ed1e2f..b69bb1e7 100644
--- a/trinity-base/tdenetwork-tdefile-plugins/tdenetwork-tdefile-plugins-9999.ebuild
+++ b/trinity-base/tdenetwork-tdefile-plugins/tdenetwork-tdefile-plugins-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdenetwork"
-inherit trinity-meta
+inherit trinity-meta-2
-DESCRIPTION="kfile plugins from the kdenetwork provides a torrent file support."
-KEYWORDS=
-IUSE=""
+DESCRIPTION="tdefile plugins from the tdenetwork provides a torrent file support."
diff --git a/trinity-base/tdetoys-doc/tdetoys-doc-9999.ebuild b/trinity-base/tdetoys-doc/tdetoys-doc-9999.ebuild
index e7497b8f..b71f0de3 100644
--- a/trinity-base/tdetoys-doc/tdetoys-doc-9999.ebuild
+++ b/trinity-base/tdetoys-doc/tdetoys-doc-9999.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdetoys"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Documentaion for tdetoys-derived packages"
-KEYWORDS=
-IUSE=""
+
RDEPEND="
- >=trinity-base/khelpcenter-${PV}:${SLOT}"
+ =trinity-base/khelpcenter-${PV}"
pkg_setup() {
- # we should reduce MAKEOPTS -j parametr to no more than 4
+ # Issue some warning if MAKEOPTS -j parameter is higher than 4
local makeopts_j
makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
- export MAKEOPTS="${MAKEOPTS//"${makeopts_j}"/-j4}"
ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
- ewarn "mode so it can chew it all. MAKEOPTS are reduced to \"$MAKEOPTS\"."
+ ewarn "mode so it can chew it all. Please change your MAKEOPTS if building fails."
fi
- trinity-meta_pkg_setup
+ trinity-meta-2_pkg_setup
}
diff --git a/trinity-base/tdetoys-meta/tdetoys-meta-9999.ebuild b/trinity-base/tdetoys-meta/tdetoys-meta-9999.ebuild
index 3dc2abc9..037ec903 100644
--- a/trinity-base/tdetoys-meta/tdetoys-meta-9999.ebuild
+++ b/trinity-base/tdetoys-meta/tdetoys-meta-9999.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
-inherit trinity-functions
+inherit trinity-functions-2
set-trinityver
-DESCRIPTION="kdetoys metapackage - merge this to pull in all kdetoys-derived packages"
+DESCRIPTION="tdetoys metapackage - merge this to pull in all tdetoys-derived packages"
HOMEPAGE="http://www.trinitydesktop.org/"
-LICENSE="GPL-2 LGPL-2"
+LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="$TRINITY_VER"
-IUSE=""
-KEYWORDS=
RDEPEND="
- >=trinity-base/amor-${PV}:${SLOT}
- >=trinity-base/eyesapplet-${PV}:${SLOT}
- >=trinity-base/fifteenapplet-${PV}:${SLOT}
- >=trinity-base/tdetoys-doc-${PV}:${SLOT}
- >=trinity-base/kmoon-${PV}:${SLOT}
- >=trinity-base/kodo-${PV}:${SLOT}
- >=trinity-base/kteatime-${PV}:${SLOT}
- >=trinity-base/ktux-${PV}:${SLOT}
- >=trinity-base/kweather-${PV}:${SLOT}
- >=trinity-base/kworldclock-${PV}:${SLOT}"
+ >=trinity-base/amor-${PV}
+ >=trinity-base/eyesapplet-${PV}
+ >=trinity-base/fifteenapplet-${PV}
+ >=trinity-base/tdetoys-doc-${PV}
+ >=trinity-base/kmoon-${PV}
+ >=trinity-base/kodo-${PV}
+ >=trinity-base/kteatime-${PV}
+ >=trinity-base/ktux-${PV}
+ >=trinity-base/kweather-${PV}
+ >=trinity-base/kworldclock-${PV}"