summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-25 23:48:35 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-26 23:40:44 +0000
commit5fdae56beb244aa6f01def404ce2ec938126755f (patch)
tree443a775c81f83a6121100f6f5bf2c15d24b2081a
parent5a52291bbe4408c45ec0f668cf6ab24751b3adf7 (diff)
downloadtde-packaging-gentoo-5fdae56beb244aa6f01def404ce2ec938126755f.tar.gz
tde-packaging-gentoo-5fdae56beb244aa6f01def404ce2ec938126755f.zip
Live ebuilds: Fix sudo support for Konsole.
Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--trinity-base/konsole/konsole-9999.ebuild4
-rw-r--r--trinity-base/tdesu/tdesu-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/trinity-base/konsole/konsole-9999.ebuild b/trinity-base/konsole/konsole-9999.ebuild
index a5acc6f0..c017f04d 100644
--- a/trinity-base/konsole/konsole-9999.ebuild
+++ b/trinity-base/konsole/konsole-9999.ebuild
@@ -9,16 +9,20 @@ inherit trinity-meta-2
DESCRIPTION="X terminal for use with Trinity."
+IUSE="sudo"
+
DEPEND="x11-libs/libX11
x11-libs/libXrender"
RDEPEND="${DEPEND}
+ sudo? ( app-admin/sudo )
x11-apps/bdftopcf
=trinity-base/kcontrol-${PV}"
src_configure() {
mycmakeargs=(
-DWITH_XRENDER=ON
+ -DWITH_SUDO_KONSOLE_SUPER_USER_COMMAND="$(usex sudo)"
)
trinity-meta-2_src_configure
diff --git a/trinity-base/tdesu/tdesu-9999.ebuild b/trinity-base/tdesu/tdesu-9999.ebuild
index 8efeccc6..72426edc 100644
--- a/trinity-base/tdesu/tdesu-9999.ebuild
+++ b/trinity-base/tdesu/tdesu-9999.ebuild
@@ -16,6 +16,7 @@ RDEPEND="${DEPEND}"
src_configure () {
mycmakeargs=(
-DWITH_SUDO_TDESU_BACKEND="$(usex sudo)"
+ -DWITH_SUDO_KONSOLE_SUPER_USER_COMMAND="$(usex sudo)"
)
trinity-meta-2_src_configure
@@ -27,8 +28,7 @@ pkg_postinst () {
einfo "It can be overriden on a user-level by adding:"
einfo " [super-user-command]"
einfo " super-user-command=su"
- einfo "to the kdeglobal config file which is should be usually"
+ einfo "to the kdeglobals config file which is should be usually"
einfo "located in the ~/.trinity/share/config/ directory."
-
fi
}