summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-25 00:48:46 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-25 23:35:00 +0000
commitd5af9e21780456f0e6a60f657ef5805d20318e8d (patch)
treefef337619b3b7ce14618f53a0536a4254e6e64a1
parent7ad022ff6a329d2d2ae29110cd8a8b01b013167d (diff)
downloadtde-packaging-gentoo-d5af9e21780456f0e6a60f657ef5805d20318e8d.tar.gz
tde-packaging-gentoo-d5af9e21780456f0e6a60f657ef5805d20318e8d.zip
Trinity-*-2.eclass: Fix handbook and arts support.
- Handle 'en' as main docs too. - Filter out noise from docs. - Sync with eclass changes in working branch. - Live ebuilds: Fix arts in tdelibs ebuild. - Sync typo fix about sudo support. Signed-off-by: Chris <xchrisx@uber.space>
-rw-r--r--eclass/trinity-base-2.eclass16
-rw-r--r--trinity-base/tdelibs/tdelibs-9999.ebuild3
2 files changed, 11 insertions, 8 deletions
diff --git a/eclass/trinity-base-2.eclass b/eclass/trinity-base-2.eclass
index d79889f7..5b8451e3 100644
--- a/eclass/trinity-base-2.eclass
+++ b/eclass/trinity-base-2.eclass
@@ -229,8 +229,12 @@ trinity-base-2_src_prepare() {
for dir in $(find ${TEG_DOC_DIR} -mindepth 1 -maxdepth 1 -type d ); do
lang="$(basename "$dir")"
if [[ "$lang" == "${PN}" || \
+ "$lang" == "en" || \
+ "$lang" == "man" || \
+ "$lang" == "doxy" || \
+ "$lang" == "online" || \
"$lang" == "${TRINITY_MODULE_NAME}" ]] ; then
- echo -n; # do nothing it's main documentation
+ echo -n; # do nothing it's main documentation or not related
elif ! has "$lang" ${TRINITY_LANGS}; then
eerror "Documentation translated to language $lang seems to present in the package but is not supported by the ebuild"
elif ! has $lang ${LINGUAS}; then
@@ -261,12 +265,14 @@ trinity-base-2_src_configure() {
eg_cmakeargs=( -DBUILD_TRANSLATIONS=ON "${eg_cmakeargs[@]}" )
fi
if [[ "${TRINITY_HANDBOOK}" == optional ]]; then
- eg_cmakeargs=(
- -DWITH_DOC="$(usex handbook)"
- "${eg_cmakeargs[@]}" )
+ eg_cmakeargs=( -DBUILD_DOC="$(usex handbook)" "${eg_cmakeargs[@]}" )
fi
fi
+ if [[ "${TRINITY_NEED_ARTS}" == "optional" ]]; then
+ eg_cmakeargs=( -DWITH_ARTS="$(usex arts)" "${eg_cmakeargs[@]}" )
+ fi
+
mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}${TDEDIR}"
-DCMAKE_INSTALL_RPATH="${EPREFIX}${TDEDIR}"
@@ -274,8 +280,6 @@ trinity-base-2_src_configure() {
"${mycmakeargs[@]}"
)
-# $([[ "${TRINITY_NEED_ARTS}" == "optional" ]] && (-DWITH_ARTS="$(usex arts)"))
-
cmake-utils_src_configure
}
diff --git a/trinity-base/tdelibs/tdelibs-9999.ebuild b/trinity-base/tdelibs/tdelibs-9999.ebuild
index cd7f0705..b70a4f89 100644
--- a/trinity-base/tdelibs/tdelibs-9999.ebuild
+++ b/trinity-base/tdelibs/tdelibs-9999.ebuild
@@ -71,7 +71,6 @@ src_configure() {
-DWITH_PKCS=OFF
-DWITH_TDEHWLIB=ON
-DWITH_TDEHWLIB_DAEMONS=ON
- -DWITH_ARTS=OFF
-DWITH_ALSA="$(usex alsa)"
-DWITH_AVAHI="$(usex avahi)"
-DWITH_CRYPTSETUP="$(usex cryptsetup)"
@@ -140,7 +139,7 @@ pkg_postinst () {
einfo "It can be overriden on a user-level by adding:"
einfo " [super-user-command]"
einfo " super-user-command=su"
- einfo "to the kdeglobal config file which is should be usually"
+ einfo "to the kdeglobals config file which is should be usually"
einfo "located in the ~/.trinity/share/config/ directory."
fi
}