summaryrefslogtreecommitdiffstats
path: root/trinity-base/tdegames-doc
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/tdegames-doc')
-rw-r--r--trinity-base/tdegames-doc/tdegames-doc-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/trinity-base/tdegames-doc/tdegames-doc-9999.ebuild b/trinity-base/tdegames-doc/tdegames-doc-9999.ebuild
index 36295dd4..453278e6 100644
--- a/trinity-base/tdegames-doc/tdegames-doc-9999.ebuild
+++ b/trinity-base/tdegames-doc/tdegames-doc-9999.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2016 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="7"
TRINITY_MODULE_NAME="tdegames"
-inherit trinity-meta
+inherit trinity-meta-2
DESCRIPTION="Documentaion for tdegames-derived packages"
-KEYWORDS=""
-IUSE+=""
+
RDEPEND="
- >=trinity-base/khelpcenter-${PV}:${SLOT}"
+ =trinity-base/khelpcenter-${PV}"
pkg_setup() {
- # we should reduce MAKEOPTS -j parametr to no more than 4
+ # Issue some warning if MAKEOPTS -j parameter is higher than 4
local makeopts_j
makeopts_j="$(echo "$MAKEOPTS" | sed -n 's/\(^\|.*\s\)\(-j\s*[0-9]\+\)\(\s.*\|$\)/\2/p')"
if [ -n "$makeopts_j" -a "$makeopts_j" > 4 ]; then
- export MAKEOPTS="${MAKEOPTS//"${makeopts_j}"/-j4}"
ewarn "This ebuild needs huge amoumt of memmory to compile in highly parallel"
- ewarn "mode so it can chew it all. MAKEOPTS are reduced to \"$MAKEOPTS\"."
+ ewarn "mode so it can chew it all. Please change your MAKEOPTS if building fails."
fi
- trinity-meta_pkg_setup
+ trinity-meta-2_pkg_setup
}