summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFran├žois Andriot <albator78@libertysurf.fr>2021-03-02 19:50:55 +0100
committerFran├žois Andriot <albator78@libertysurf.fr>2021-03-02 19:51:08 +0100
commit8d16bbb07d30d547ab56232e8428b9356f2aa3d7 (patch)
tree377172acbb10af50b9e1304751f43856126fbdf0
parent38c37cbf97b6d42da0b0ea81f49a2351fb07c232 (diff)
downloadtde-packaging-8d16bbb07d30d547ab56232e8428b9356f2aa3d7.tar.gz
tde-packaging-8d16bbb07d30d547ab56232e8428b9356f2aa3d7.zip
RPM: add support for Mageia 8
-rw-r--r--redhat/Makefile6
-rw-r--r--redhat/applications/amarok/amarok.spec14
-rw-r--r--redhat/applications/koffice/koffice.spec2
-rw-r--r--redhat/applications/konversation/konversation.spec2
-rw-r--r--redhat/applications/tde-guidance/tde-guidance.spec4
-rw-r--r--redhat/applications/tdenetworkmanager/tdenetworkmanager.spec7
-rw-r--r--redhat/applications/tellico/tellico.spec14
-rw-r--r--redhat/applications/wlassistant/wlassistant.spec2
-rw-r--r--redhat/dependencies/python-tqt/python-tqt.spec2
-rw-r--r--redhat/dependencies/sip4-tqt/sip4-tqt.spec2
-rw-r--r--redhat/docker/mga8/Dockerfile.i68651
-rw-r--r--redhat/docker/mga8/Dockerfile.x86_6451
-rw-r--r--redhat/docker/mga8/packages.i686254
-rw-r--r--redhat/docker/mga8/packages.x86_64257
-rw-r--r--redhat/docker/mga8/rpmmacros7
-rw-r--r--redhat/extras/trinity-desktop/trinity-desktop.spec2
-rw-r--r--redhat/libraries/libksquirrel/libksquirrel.spec2
-rw-r--r--redhat/libraries/pytdeextensions/pytdeextensions.spec4
-rw-r--r--redhat/libraries/python-trinity/python-trinity.spec4
-rw-r--r--redhat/main/tdeaddons/tdeaddons.spec11
-rw-r--r--redhat/main/tdebase/pamd.kcheckpass-trinity.mga85
-rw-r--r--redhat/main/tdebase/pamd.kdm-trinity-np.mga811
-rw-r--r--redhat/main/tdebase/pamd.kdm-trinity.mga815
-rw-r--r--redhat/main/tdebase/pamd.kscreensaver-trinity.mga85
-rw-r--r--redhat/main/tdebase/tdebase.spec4
-rw-r--r--redhat/main/tdebase/tdm.service.mga812
-rw-r--r--redhat/main/tdebindings/tdebindings.spec4
-rw-r--r--redhat/main/tdeedu/tdeedu.spec4
-rw-r--r--redhat/main/tdegames/tdegames.spec2
-rw-r--r--redhat/main/tdelibs/tdelibs.spec2
-rw-r--r--redhat/main/tdesdk/tdesdk.spec4
-rw-r--r--redhat/main/tdevelop/tdevelop.spec15
32 files changed, 747 insertions, 34 deletions
diff --git a/redhat/Makefile b/redhat/Makefile
index 6b270f1ee..1b6b6f0bd 100644
--- a/redhat/Makefile
+++ b/redhat/Makefile
@@ -140,12 +140,12 @@ ifneq (,$(filter $(DIST), .oss151 .oss152 .osstw ))
endif
esound:
-ifneq (,$(filter $(DIST), .el8 .mga6 .mga7 .oss151 .oss152 .osstw ))
+ifneq (,$(filter $(DIST), .el8 .mga6 .mga7 .mga8 .oss151 .oss152 .osstw ))
$(call buildpkg,3rdparty/esound)
endif
htdig:
-ifneq (,$(filter $(DIST), .el7 .el8 .mga6 .mga7 ))
+ifneq (,$(filter $(DIST), .el7 .el8 .mga6 .mga7 .mga8 ))
$(call buildpkg,extras/htdig)
endif
@@ -155,7 +155,7 @@ ifneq (,$(filter $(DIST), .mga6 .mga7 .oss151 .osstw ))
endif
lcms:
-ifneq (,$(filter $(DIST), .el7 .el8 .mga7 .oss151 .oss152 .osstw ))
+ifneq (,$(filter $(DIST), .el7 .el8 .mga7 .mga8 .oss151 .oss152 .osstw ))
$(call buildpkg,3rdparty/lcms)
endif
diff --git a/redhat/applications/amarok/amarok.spec b/redhat/applications/amarok/amarok.spec
index 7eaac61d6..99e8e731d 100644
--- a/redhat/applications/amarok/amarok.spec
+++ b/redhat/applications/amarok/amarok.spec
@@ -251,6 +251,18 @@ BuildRequires: ruby-devel
BuildRequires: rubypick
%endif
+# PYTHON support
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
+%global python python2
+%global __python %__python2
+%global python_sitearch %{python2_sitearch}
+%else
+%global python python
+%endif
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+BuildRequires: %{python}
+BuildRequires: %{python}-devel
+
# To open the selected browser, works with Patch2
Requires: xdg-utils
Requires(post): xdg-utils
@@ -428,7 +440,7 @@ if ! ruby -rrbconfig -e "puts Config.expand( Config::MAKEFILE_CONFIG['MAJOR'] )"
-e "s|Config\.|RbConfig\.|g"
fi
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
%__sed -i "amarok/src/scripts/common/Publisher.py" \
"amarok/src/scripts/common/Zeroconf.py" \
"amarok/src/scripts/playlist2html/Playlist.py" \
diff --git a/redhat/applications/koffice/koffice.spec b/redhat/applications/koffice/koffice.spec
index 4648de818..a9d246641 100644
--- a/redhat/applications/koffice/koffice.spec
+++ b/redhat/applications/koffice/koffice.spec
@@ -113,7 +113,7 @@ BuildRequires: libexif-devel
BuildRequires: readline-devel
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
%global python python2
%global __python %__python2
%global python_sitearch %{python2_sitearch}
diff --git a/redhat/applications/konversation/konversation.spec b/redhat/applications/konversation/konversation.spec
index 4535da857..cb80acee6 100644
--- a/redhat/applications/konversation/konversation.spec
+++ b/redhat/applications/konversation/konversation.spec
@@ -176,7 +176,7 @@ and experienced users alike will appreciate its many features:
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
%__sed -i "konversation/scripts/media" \
"konversation/scripts/weather" \
-e "s|/usr/bin/env python|/usr/bin/env python2|"
diff --git a/redhat/applications/tde-guidance/tde-guidance.spec b/redhat/applications/tde-guidance/tde-guidance.spec
index ebe3ae374..8a27e3bd4 100644
--- a/redhat/applications/tde-guidance/tde-guidance.spec
+++ b/redhat/applications/tde-guidance/tde-guidance.spec
@@ -140,7 +140,7 @@ BuildRequires: xscreensaver-gl
%endif
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
%global python python2
%global __python %__python2
%global python_sitearch %{python2_sitearch}
@@ -431,7 +431,7 @@ chmod 0755 %{buildroot}%{python_sitearch}/%{name}/gpmhelper.py
# Replace all '#!' calls to python with /usr/bin/python
# and make them executable
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
%define python /usr/bin/python2
%else
%define python /usr/bin/python
diff --git a/redhat/applications/tdenetworkmanager/tdenetworkmanager.spec b/redhat/applications/tdenetworkmanager/tdenetworkmanager.spec
index 8c413b282..ec951f116 100644
--- a/redhat/applications/tdenetworkmanager/tdenetworkmanager.spec
+++ b/redhat/applications/tdenetworkmanager/tdenetworkmanager.spec
@@ -96,7 +96,12 @@ Requires: NetworkManager-gnome
%if 0%{?mdkversion} || 0%{?mgaversion}
Requires: networkmanager
%endif
-%if 0%{?rhel} || 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion}
+%if 0%{?mgaversion} || 0%{?mdkversion}
+%if 0%{?mgaversion} != 8
+BuildRequires: %{_lib}nm-util-devel
+%endif
+%endif
+%if 0%{?rhel} || 0%{?fedora} || 0%{?mdkversion}
%if 0%{?pclinuxos} == 0
%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
BuildRequires: NetworkManager-libnm-devel
diff --git a/redhat/applications/tellico/tellico.spec b/redhat/applications/tellico/tellico.spec
index 93db82616..894a74be8 100644
--- a/redhat/applications/tellico/tellico.spec
+++ b/redhat/applications/tellico/tellico.spec
@@ -153,6 +153,18 @@ BuildRequires: libacl-devel
# ATTR support
BuildRequires: libattr-devel
+# PYTHON support
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
+%global python python2
+%global __python %__python2
+%global python_sitearch %{python2_sitearch}
+%else
+%global python python
+%endif
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+BuildRequires: %{python}
+BuildRequires: %{python}-devel
+
Requires: %{name}-data = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: %{name}-scripts = %{?epoch:%{epoch}:}%{version}-%{release}
@@ -272,7 +284,7 @@ if [ -r /usr/include/libv4l1-videodev.h ]; then
%__sed -i "src/barcode/barcode_v4l.h" -e "s|linux/videodev.h|libv4l1.h|"
fi
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
%__sed -i "src/fetch/scripts/dark_horse_comics.py" \
"src/fetch/scripts/ministerio_de_cultura.py" \
"src/fetch/scripts/fr.allocine.py" \
diff --git a/redhat/applications/wlassistant/wlassistant.spec b/redhat/applications/wlassistant/wlassistant.spec
index e6d3dd43e..9aeca6cf9 100644
--- a/redhat/applications/wlassistant/wlassistant.spec
+++ b/redhat/applications/wlassistant/wlassistant.spec
@@ -101,7 +101,7 @@ BuildRequires: gamin-devel
%endif
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
%global python python2
%global __python %__python2
%global python_sitearch %{python2_sitearch}
diff --git a/redhat/dependencies/python-tqt/python-tqt.spec b/redhat/dependencies/python-tqt/python-tqt.spec
index 2f57100bb..16ced1e89 100644
--- a/redhat/dependencies/python-tqt/python-tqt.spec
+++ b/redhat/dependencies/python-tqt/python-tqt.spec
@@ -71,7 +71,7 @@ BuildRequires: libtqscintilla-devel >= %{?epoch:%{epoch}:}1.7.1
BuildRequires: gcc-c++
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
%global python python2
%global __python %__python2
%global python_sitearch %{python2_sitearch}
diff --git a/redhat/dependencies/sip4-tqt/sip4-tqt.spec b/redhat/dependencies/sip4-tqt/sip4-tqt.spec
index e8c0fb016..2693049ad 100644
--- a/redhat/dependencies/sip4-tqt/sip4-tqt.spec
+++ b/redhat/dependencies/sip4-tqt/sip4-tqt.spec
@@ -71,7 +71,7 @@ BuildRequires: trinity-filesystem >= %{tde_version}
BuildRequires: gcc-c++
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
%global python python2
%global __python %__python2
%global python_sitearch %{python2_sitearch}
diff --git a/redhat/docker/mga8/Dockerfile.i686 b/redhat/docker/mga8/Dockerfile.i686
new file mode 100644
index 000000000..e39ba47d2
--- /dev/null
+++ b/redhat/docker/mga8/Dockerfile.i686
@@ -0,0 +1,51 @@
+FROM mageia32:8
+
+ARG TDE_VERSION=14.0.9
+ARG ARCH=i686
+
+# Reset URPMI repositories to default
+# Enable more URPMI repositories
+RUN urpmi.removemedia -a \
+ && urpmi.addmedia --distrib http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/8/i586/ \
+ && sed -i "/etc/urpmi/urpmi.cfg" -e "/Tainted\\\ Release {/{p;N;d}" -e "/Tainted\\\ Updates {/{p;N;d}"
+
+# Enable english locales
+RUN urpmi --replacepkgs glibc \
+ && localedef -v -c -i en_US -f UTF-8 en_US.UTF-8 || :
+
+# Update distribution
+# Install Trinity build dependencies
+COPY packages.${ARCH} /packages
+RUN urpmi.update -a \
+ && urpmi --auto-select --auto \
+ && urpmi --auto $(</packages)
+
+# Enable ccache
+RUN sed -i "/etc/sysconfig/ccache" -e "s|USE_CCACHE_DEFAULT=.*|USE_CCACHE_DEFAULT=\"yes\"|"
+
+# Fix utempter detection
+RUN chmod a+r /usr/libexec/utempter/utempter
+
+# Fix poppler support
+RUN sed -i "/usr/include/poppler/poppler-config.h" -e "/define HAVE_SPLASH/ s|^|//|"
+
+# Add non-root user to build packages
+RUN rm -rf /home/trinity \
+ && useradd -m -s /bin/bash -u 1000 trinity \
+ && echo "trinity ALL=(ALL) NOPASSWD: ALL" >>"/etc/sudoers"
+
+# Configure user trinity
+USER trinity
+COPY rpmmacros /home/trinity/.rpmmacros
+
+# Add rpmbuild repositories
+RUN mkdir -p ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/${ARCH} \
+ && genhdlist2 --allow-empty-media --clean ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/${ARCH} \
+ && sudo urpmi.addmedia rpmbuild.${ARCH} ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/${ARCH} \
+ && mkdir -p ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/noarch \
+ && genhdlist2 --allow-empty-media --clean ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/noarch \
+ && sudo urpmi.addmedia rpmbuild.noarch ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/noarch
+
+# Build development packages that are missing
+RUN setarch ${ARCH} rpmbuild --rebuild http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/8/SRPMS/core/release/perl-PAR-Packer-1.51.0-2.mga8.src.rpm \
+ && sudo rpm -Uvh --force "${HOME}/rpmbuild/RPMS/"*"/perl-PAR-Packer-"*".rpm"
diff --git a/redhat/docker/mga8/Dockerfile.x86_64 b/redhat/docker/mga8/Dockerfile.x86_64
new file mode 100644
index 000000000..f2385a34f
--- /dev/null
+++ b/redhat/docker/mga8/Dockerfile.x86_64
@@ -0,0 +1,51 @@
+FROM mageia:8
+
+ARG TDE_VERSION=14.0.9
+ARG ARCH=x86_64
+
+# Reset URPMI repositories to default
+# Enable more URPMI repositories
+RUN urpmi.removemedia -a \
+ && urpmi.addmedia --distrib http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/8/x86_64/ \
+ && sed -i "/etc/urpmi/urpmi.cfg" -e "/Tainted\\\ Release {/{p;N;d}" -e "/Tainted\\\ Updates {/{p;N;d}"
+
+# Enable english locales
+RUN urpmi --replacepkgs glibc \
+ && localedef -v -c -i en_US -f UTF-8 en_US.UTF-8 || :
+
+# Update distribution
+# Install Trinity build dependencies
+COPY packages.${ARCH} /packages
+RUN urpmi.update -a \
+ && urpmi --auto-select --auto \
+ && urpmi --auto $(</packages)
+
+# Enable ccache
+RUN sed -i "/etc/sysconfig/ccache" -e "s|USE_CCACHE_DEFAULT=.*|USE_CCACHE_DEFAULT=\"yes\"|"
+
+# Fix utempter detection
+RUN chmod a+r /usr/libexec/utempter/utempter
+
+# Fix poppler support
+RUN sed -i "/usr/include/poppler/poppler-config.h" -e "/define HAVE_SPLASH/ s|^|//|"
+
+# Add non-root user to build packages
+RUN rm -rf /home/trinity \
+ && useradd -m -s /bin/bash -u 1000 trinity \
+ && echo "trinity ALL=(ALL) NOPASSWD: ALL" >>"/etc/sudoers"
+
+# Configure user trinity
+USER trinity
+COPY rpmmacros /home/trinity/.rpmmacros
+
+# Add rpmbuild repositories
+RUN mkdir -p ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/${ARCH} \
+ && genhdlist2 --allow-empty-media --clean ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/${ARCH} \
+ && sudo urpmi.addmedia rpmbuild.${ARCH} ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/${ARCH} \
+ && mkdir -p ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/noarch \
+ && genhdlist2 --allow-empty-media --clean ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/noarch \
+ && sudo urpmi.addmedia rpmbuild.noarch ${HOME}/rpmbuild/RPMS.tde-${TDE_VERSION}/noarch
+
+# Build development packages that are missing
+RUN setarch ${ARCH} rpmbuild --rebuild http://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/8/SRPMS/core/release/perl-PAR-Packer-1.51.0-2.mga8.src.rpm \
+ && sudo rpm -Uvh --force "${HOME}/rpmbuild/RPMS/"*"/perl-PAR-Packer-"*".rpm"
diff --git a/redhat/docker/mga8/packages.i686 b/redhat/docker/mga8/packages.i686
new file mode 100644
index 000000000..af6c6feb7
--- /dev/null
+++ b/redhat/docker/mga8/packages.i686
@@ -0,0 +1,254 @@
+advancecomp
+alsa-lib-devel
+aspell
+aspell-devel
+aspell-en
+audiofile-devel
+bind-devel
+bison
+boost-devel
+bzip2-devel
+ccache
+cdparanoia
+chmlib-devel
+chrpath
+clamav
+clamav-devel
+cmake
+ctags
+cups-devel
+curl-devel
+db5-devel
+dbus-devel
+dbus-glib
+dbus-glib-devel
+djvulibre
+docbook2x
+docbook-dtd412-xml
+docbook-style-xsl
+docbook-utils
+doxygen
+drakconf
+dssi-devel
+exempi-devel
+expat-devel
+fdupes
+fftw-devel
+firebird-devel
+flex
+fontconfig-devel
+freetype2-devel
+freetype-devel
+fribidi-devel
+gamin-devel
+gettext-devel
+glib2-devel
+glibc-i18ndata
+gmime-devel
+gnokii-devel
+gperf
+gpgme-devel
+gphoto2-devel
+GraphicsMagick-devel
+gsl-devel
+gtk2-devel
+gtk+3.0-devel
+gtk-doc
+hspell-devel
+hunspell-en
+iceauth
+ImageMagick-devel
+imake
+imlib2-devel
+intltool
+java-1.8.0-openjdk
+java-1.8.0-openjdk-devel
+java-devel
+karma-sharp
+kde-dev-scripts
+libapr-devel
+libapr-util-devel
+libart_lgpl-devel
+libattr-devel
+libavformat58
+libbinutils-devel
+libblkid-devel
+libcdda-devel
+libcln-devel
+libclucene-devel
+libclucene-devel
+libcommoncpp-devel
+libcommoncpp-devel
+libconfig-devel
+libcryptsetup-devel
+libcurl-devel
+libcurl-devel
+libdvdread-devel
+libdvdread-devel
+libecpg13_6
+libexiv2-devel
+libext2fs-devel
+libfbclient-devel
+libffmpeg-devel
+libflac++-devel
+libflac-devel
+libflac-devel
+libfontenc-devel
+libgadu-devel
+libgeoip-devel
+libgmime2.6-devel
+libgpod-devel
+libgsf-devel
+libgstreamer1.0-devel
+libgstreamer-plugins-base1.0-devel
+libhd-devel
+libical-devel
+libice-devel
+libidn-devel
+libifp-devel
+libinotifytools-devel
+libiodbc-devel
+libiw-devel
+libjack-devel
+libjasper-devel
+libjasper-devel
+libjpeg-devel
+libkarma-devel
+liblo-devel
+liblrdf-devel
+liblua-devel
+libmad-devel
+libmad-devel
+libmng-devel
+libmp3lame-devel
+libmp4v2-devel
+libmpcdec-devel
+libmtp-devel
+libmusicbrainz-devel
+libnjb-devel
+libnpth-devel
+libofx-devel
+libotr-devel
+libpaper-devel
+libpaper-devel
+libpkcs11-helper-devel
+libpoppler-devel
+libpulseaudio-devel
+libpx-devel
+libqalculate-devel
+libraw1394-devel
+librsvg
+libsane1-devel
+libsmbclient-devel
+libsm-devel
+libsndfile-devel
+libt1lib-devel
+libt1lib-devel
+libtheora-devel
+libtiff-devel
+libtwolame-devel
+libudev-devel
+libungif-devel
+libusb1.0-devel
+libutempter
+libutempter0
+libutempter-devel
+libv4l-devel
+libvisual-devel
+libvorbis-devel
+libwmf-devel
+libwpd-devel
+libx11-devel
+libxaw-devel
+libxcursor-devel
+libxdg-basedir-devel
+libxext-devel
+libxft-devel
+libxi-devel
+libxi-devel
+libxine1.2-devel
+libxinerama-devel
+libxkbfile-devel
+libxmu-devel
+libxrandr-devel
+libxrender-devel
+libxscrnsaver-devel
+libxslt-devel
+libxtst-devel
+libxv-devel
+libxxf86dga-devel
+libxxf86dga-devel
+libyaz-devel
+libyaz-devel
+lilo
+lirc-devel
+lm_sensors-devel
+mesaglu-devel
+mysql-devel
+nas-devel
+neon-devel
+netpbm
+net-snmp-devel
+notification-daemon
+ocaml
+ocaml-facile-devel
+OpenEXR-devel
+openldap-devel
+openldap-servers-devel
+opensc
+openslp-devel
+opensp-devel
+openssh-clients
+optipng
+pam-devel
+pciutils-devel
+perl-devel
+perl-ExtUtils-MakeMaker
+perl(IPC::Run3)
+perl(PAR::Packer)
+perl-pcsc-perl
+perl(XML::Parser)
+pilot-link-devel
+pinentry-gtk2
+pkgconfig(audiofile)
+pkgconfig(libpng16)
+polkit-agent-none
+postgresql13
+postgresql13-devel
+ppp
+python-devel
+python-sip
+qt4-devel
+readline-devel
+recode
+rpcgen
+rpm-build
+rpm-devel
+ruby-devel
+scons
+SDL-devel
+speex-devel
+sqlite3-devel
+sqlite-devel
+sshfs-fuse
+subversion-devel
+sudo
+swig
+sword-devel
+taglib-devel
+torsocks
+transfig
+udisks2-devel
+unixODBC-devel
+usbutils
+valgrind
+wv2-devel
+x11-font-util
+xbase-devel
+xmlto
+xscreensaver
+xscreensaver-base
+xscreensaver-extrusion
+xscreensaver-gl
+yaz
+zlib-devel
diff --git a/redhat/docker/mga8/packages.x86_64 b/redhat/docker/mga8/packages.x86_64
new file mode 100644
index 000000000..ad8802b2c
--- /dev/null
+++ b/redhat/docker/mga8/packages.x86_64
@@ -0,0 +1,257 @@
+advancecomp
+alsa-lib-devel
+aspell
+aspell-devel
+aspell-en
+audiofile-devel
+bind-devel
+bison
+boost-devel
+bzip2-devel
+ccache
+cdparanoia
+chmlib-devel
+chrpath
+clamav
+clamav-devel
+cmake
+ctags
+cups-devel
+curl-devel
+db5-devel
+dbus-devel
+dbus-glib
+dbus-glib-devel
+djvulibre
+docbook2x
+docbook-dtd412-xml
+docbook-style-xsl
+docbook-utils
+doxygen
+drakconf
+dssi-devel
+exempi-devel
+expat-devel
+fdupes
+fftw-devel
+firebird-devel
+flex
+fontconfig-devel
+freetype2-devel
+freetype-devel
+fribidi-devel
+gamin-devel
+gettext-devel
+glib2-devel
+glibc-i18ndata
+gmime-devel
+gnokii-devel
+gperf
+gpgme-devel
+gphoto2-devel
+GraphicsMagick-devel
+gsl-devel
+gtk2-devel
+gtk+3.0-devel
+gtk-doc
+hspell-devel
+hunspell-en
+iceauth
+ImageMagick-devel
+imake
+imlib2-devel
+intltool
+java-1.8.0-openjdk
+java-1.8.0-openjdk-devel
+java-devel
+karma-sharp
+kde-dev-scripts
+lib64apr-devel
+lib64apr-util-devel
+lib64avformat58
+lib64binutils-devel
+lib64boost_python3-devel
+lib64cln-devel
+lib64clucene-devel
+lib64commoncpp-devel
+lib64cryptsetup-devel
+lib64curl-devel
+lib64dvdread-devel
+lib64ecpg13_6
+lib64exiv2-devel
+lib64ext2fs-devel
+lib64fbclient-devel
+lib64ffmpeg-devel
+lib64flac++-devel
+lib64flac-devel
+lib64fontenc-devel
+lib64geoip-devel
+lib64gmime2.6-devel
+lib64gstreamer1.0-devel
+lib64gstreamer-plugins-base1.0-devel
+lib64inotifytools-devel
+lib64jasper-devel
+lib64jpeg-devel
+lib64lua-devel
+lib64mad-devel
+lib64mp3lame-devel
+lib64npth-devel
+lib64paper-devel
+lib64pkcs11-helper-devel
+lib64poppler-devel
+lib64pulseaudio-devel
+lib64sane1-devel
+lib64t1lib-devel
+lib64tiff-devel
+lib64twolame-devel
+lib64udev-devel
+lib64usb1.0-devel
+lib64utempter0
+lib64utempter-devel
+lib64v4l-devel
+lib64xaw-devel
+lib64xdg-basedir-devel
+lib64xi-devel
+lib64xine1.2-devel
+lib64xscrnsaver-devel
+lib64xtst-devel
+lib64xxf86dga-devel
+lib64yaz-devel
+libart_lgpl-devel
+libattr-devel
+libblkid-devel
+libcdda-devel
+libclucene-devel
+libcommoncpp-devel
+libconfig-devel
+libcurl-devel
+libdvdread-devel
+libffmpeg-devel
+libflac++-devel
+libflac-devel
+libgadu-devel
+libgpod-devel
+libgsf-devel
+libhd-devel
+libical-devel
+libice-devel
+libidn-devel
+libifp-devel
+libiodbc-devel
+libiw-devel
+libjack-devel
+libjasper-devel
+libkarma-devel
+liblo-devel
+liblrdf-devel
+libmad-devel
+libmng-devel
+libmp4v2-devel
+libmpcdec-devel
+libmtp-devel
+libmusicbrainz-devel
+libnjb-devel
+libofx-devel
+libotr-devel
+libpaper-devel
+libpx-devel
+libqalculate-devel
+libraw1394-devel
+librsvg
+libsmbclient-devel
+libsm-devel
+libsndfile-devel
+libt1lib-devel
+libtheora-devel
+libungif-devel
+libutempter
+libvisual-devel
+libvorbis-devel
+libwmf-devel
+libwpd-devel
+libx11-devel
+libxcursor-devel
+libxext-devel
+libxft-devel
+libxi-devel
+libxinerama-devel
+libxkbfile-devel
+libxmu-devel
+libxrandr-devel
+libxrender-devel
+libxslt-devel
+libxv-devel
+libxxf86dga-devel
+libyaz-devel
+lilo
+lirc-devel
+lm_sensors-devel
+mesaglu-devel
+mysql-devel
+nas-devel
+neon-devel
+netpbm
+net-snmp-devel
+notification-daemon
+ocaml
+ocaml-facile-devel
+OpenEXR-devel
+openldap-devel
+openldap-servers-devel
+opensc
+openslp-devel
+opensp-devel
+openssh-clients
+optipng
+pam-devel
+pciutils-devel
+perl-devel
+perl-ExtUtils-MakeMaker
+perl(IPC::Run3)
+perl(PAR::Packer)
+perl-pcsc-perl
+perl(XML::Parser)
+pilot-link-devel
+pinentry-gtk2
+pkgconfig(audiofile)
+pkgconfig(libpng16)
+polkit-agent-none
+postgresql13
+postgresql13-devel
+ppp
+python-devel
+python-sip
+qt4-devel
+readline-devel
+recode
+rpcgen
+rpm-build
+rpm-devel
+ruby-devel
+scons
+SDL-devel
+speex-devel
+sqlite3-devel
+sqlite-devel
+sshfs-fuse
+subversion-devel
+sudo
+swig
+sword-devel
+taglib-devel
+torsocks
+transfig
+udisks2-devel
+unixODBC-devel
+usbutils
+valgrind
+wv2-devel
+x11-font-util
+xbase-devel
+xmlto
+xscreensaver
+xscreensaver-base
+xscreensaver-extrusion
+xscreensaver-gl
+yaz
+zlib-devel
diff --git a/redhat/docker/mga8/rpmmacros b/redhat/docker/mga8/rpmmacros
new file mode 100644
index 000000000..44756ee5a
--- /dev/null
+++ b/redhat/docker/mga8/rpmmacros
@@ -0,0 +1,7 @@
+%dist .mga8
+%_smp_mflags -j8
+%jobs 8
+%_program_prefix ""
+%_debugsource_packages %nil
+%_debugsource_template %nil
+%_vpath_builddir .
diff --git a/redhat/extras/trinity-desktop/trinity-desktop.spec b/redhat/extras/trinity-desktop/trinity-desktop.spec
index ab7f643a8..c2c9889df 100644
--- a/redhat/extras/trinity-desktop/trinity-desktop.spec
+++ b/redhat/extras/trinity-desktop/trinity-desktop.spec
@@ -159,7 +159,7 @@ Requires: trinity-kooldock
Requires: trinity-kopete-otr
Requires: trinity-kpicosim
Requires: trinity-kpilot
-Requires: trinity-kplayer
+#Requires: trinity-kplayer
Requires: trinity-krecipes
Requires: trinity-krename
Requires: trinity-krusader
diff --git a/redhat/libraries/libksquirrel/libksquirrel.spec b/redhat/libraries/libksquirrel/libksquirrel.spec
index 8918cb9f1..4fe2672bd 100644
--- a/redhat/libraries/libksquirrel/libksquirrel.spec
+++ b/redhat/libraries/libksquirrel/libksquirrel.spec
@@ -534,7 +534,7 @@ fi
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
-%if 0%{?suse_version} >= 1550
+%if 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
CXXFLAGS="${CXXFLAGS} -std=c++11"
%endif
diff --git a/redhat/libraries/pytdeextensions/pytdeextensions.spec b/redhat/libraries/pytdeextensions/pytdeextensions.spec
index 73c6a1ecd..cf67a4b48 100644
--- a/redhat/libraries/pytdeextensions/pytdeextensions.spec
+++ b/redhat/libraries/pytdeextensions/pytdeextensions.spec
@@ -75,7 +75,7 @@ BuildRequires: sip4-tqt-devel >= 4.10.5
Requires: sip4-tqt >= 4.10.5
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
%global python python2
%global __python %__python2
%global python_sitearch %{python2_sitearch}
@@ -195,7 +195,7 @@ fi
%__sed -i "src/pythonize."* -e "s|const char \*object|char \*object|g"
%endif
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
%__sed -i "app_templates/kcontrol_module/setup.py" \
"app_templates/kcontrol_module/src/kcontrol_module.py" \
"app_templates/kdeapp/setup.py" \
diff --git a/redhat/libraries/python-trinity/python-trinity.spec b/redhat/libraries/python-trinity/python-trinity.spec
index 2b807b207..36621f7a6 100644
--- a/redhat/libraries/python-trinity/python-trinity.spec
+++ b/redhat/libraries/python-trinity/python-trinity.spec
@@ -63,7 +63,7 @@ BuildRequires: autoconf automake libtool m4
BuildRequires: gcc-c++
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
%global python python2
%global __python %__python2
%global python_sitearch %{python2_sitearch}
@@ -147,7 +147,7 @@ tips and working code you can use to learn from.
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
%__sed -i "contrib/tdepyuic" -e "s|/usr/bin/env python|/usr/bin/env python2|"
%endif
diff --git a/redhat/main/tdeaddons/tdeaddons.spec b/redhat/main/tdeaddons/tdeaddons.spec
index 79e25bfa8..60086f993 100644
--- a/redhat/main/tdeaddons/tdeaddons.spec
+++ b/redhat/main/tdeaddons/tdeaddons.spec
@@ -137,11 +137,10 @@ BuildRequires: db4-devel
#BuildRequires: xmms-devel
#%endif
-# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 30
-%define python python3
-%else
-%define python python
+# PYTHON2 support
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 30 || 0%{?mgaversion} >= 8
+%global python %python2
+%global __python %__python2
%endif
Requires: trinity-atlantikdesigner = %{version}-%{release}
@@ -667,7 +666,7 @@ of user interfaces, playlists and visualisation plugins.
%prep
%setup -q -n %{name}-%{version}%{?preversion:~%{preversion}}
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
# Fix shebangs
sed -i "knewsticker-scripts/sportscores.py" \
"konq-plugins/imagerotation/orient.py" \
diff --git a/redhat/main/tdebase/pamd.kcheckpass-trinity.mga8 b/redhat/main/tdebase/pamd.kcheckpass-trinity.mga8
new file mode 100644
index 000000000..0a37e6e13
--- /dev/null
+++ b/redhat/main/tdebase/pamd.kcheckpass-trinity.mga8
@@ -0,0 +1,5 @@
+#%PAM-1.0
+auth include system-auth
+account include system-auth
+password include system-auth
+session include system-auth
diff --git a/redhat/main/tdebase/pamd.kdm-trinity-np.mga8 b/redhat/main/tdebase/pamd.kdm-trinity-np.mga8
new file mode 100644
index 000000000..f884c1de6
--- /dev/null
+++ b/redhat/main/tdebase/pamd.kdm-trinity-np.mga8
@@ -0,0 +1,11 @@
+#%PAM-1.0
+auth required pam_env.so
+auth required pam_permit.so
+account required pam_nologin.so
+account include system-auth
+password include system-auth
+session required pam_loginuid.so
+session optional pam_console.so
+session optional pam_keyinit.so force revoke
+session required pam_namespace.so
+session include system-auth
diff --git a/redhat/main/tdebase/pamd.kdm-trinity.mga8 b/redhat/main/tdebase/pamd.kdm-trinity.mga8
new file mode 100644
index 000000000..cb0982c9a
--- /dev/null
+++ b/redhat/main/tdebase/pamd.kdm-trinity.mga8
@@ -0,0 +1,15 @@
+#%PAM-1.0
+auth required pam_env.so
+auth required pam_succeed_if.so
+auth sufficient pam_succeed_if.so user ingroup nopasswdlogin
+auth substack system-auth
+-auth optional pam_kwallet.so
+account required pam_nologin.so
+account include system-auth
+password include system-auth
+session required pam_loginuid.so
+session optional pam_console.so
+session optional pam_keyinit.so force revoke
+session required pam_namespace.so
+session include system-auth
+-session optional pam_kwallet.so
diff --git a/redhat/main/tdebase/pamd.kscreensaver-trinity.mga8 b/redhat/main/tdebase/pamd.kscreensaver-trinity.mga8
new file mode 100644
index 000000000..0a37e6e13
--- /dev/null
+++ b/redhat/main/tdebase/pamd.kscreensaver-trinity.mga8
@@ -0,0 +1,5 @@
+#%PAM-1.0
+auth include system-auth
+account include system-auth
+password include system-auth
+session include system-auth
diff --git a/redhat/main/tdebase/tdebase.spec b/redhat/main/tdebase/tdebase.spec
index 0d5139fbb..67d78d852 100644
--- a/redhat/main/tdebase/tdebase.spec
+++ b/redhat/main/tdebase/tdebase.spec
@@ -780,7 +780,7 @@ BuildRequires: libr-devel >= 0.6.0
%endif
# RPC support
-%if 0%{?fedora} >= 28 || 0%{?suse_version} >= 1500
+%if 0%{?fedora} >= 28 || 0%{?suse_version} >= 1500 || 0%{?mgaversion} >= 8
BuildRequires: libtirpc-devel
BuildRequires: rpcgen
%if 0%{?fedora}
@@ -1491,7 +1491,9 @@ TDE applications, particularly those in the TDE base module.
%{tde_libdir}/libtdeinit_kxkb.la
%{tde_libdir}/libtdeinit_kxkb.so
%{tde_libdir}/libkhotkeys_shared.so.*
+%if "%{?tde_version}" != "14.0.9"
%{tde_tdeappdir}/kdcop.desktop
+%endif
%{tde_tdeappdir}/keyboard.desktop
%{tde_tdeappdir}/keyboard_layout.desktop
%{tde_tdeappdir}/khotkeys.desktop
diff --git a/redhat/main/tdebase/tdm.service.mga8 b/redhat/main/tdebase/tdm.service.mga8
new file mode 100644
index 000000000..eda2906e2
--- /dev/null
+++ b/redhat/main/tdebase/tdm.service.mga8
@@ -0,0 +1,12 @@
+[Unit]
+Description=Trinity Display Manager
+Documentation=man:tdm(1)
+Conflicts=getty@tty1.service
+After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service systemd-logind.service
+
+[Service]
+ExecStart=/opt/trinity/bin/tdm
+Restart=always
+
+[Install]
+Alias=display-manager.service
diff --git a/redhat/main/tdebindings/tdebindings.spec b/redhat/main/tdebindings/tdebindings.spec
index 81783c492..f5d4b33c5 100644
--- a/redhat/main/tdebindings/tdebindings.spec
+++ b/redhat/main/tdebindings/tdebindings.spec
@@ -169,12 +169,10 @@ BuildRequires: Mesa-libGLU-devel
%endif
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
%global python python2
%global __python %__python2
%global python_sitearch %{python2_sitearch}
-%else
-%global python python
%endif
%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
BuildRequires: %{python}
diff --git a/redhat/main/tdeedu/tdeedu.spec b/redhat/main/tdeedu/tdeedu.spec
index 042811997..735435573 100644
--- a/redhat/main/tdeedu/tdeedu.spec
+++ b/redhat/main/tdeedu/tdeedu.spec
@@ -98,7 +98,7 @@ BuildRequires: libusb-devel
%endif
# PYTHON3 support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?sle_version} >= 150100
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?sle_version} >= 150100 || 0%{?mgaversion} >= 8
%global python python3
%global __python %__python3
%global python_sitearch %{python3_sitearch}
@@ -1137,7 +1137,7 @@ This package contains the development files for tdeedu.
%prep
%setup -q -n %{name}-%{version}%{?preversion:~%{preversion}}
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
# Fix shebangs
sed -i "kig/pykig/pykig.py" \
-e "s|env python|env %{python}|"
diff --git a/redhat/main/tdegames/tdegames.spec b/redhat/main/tdegames/tdegames.spec
index 77a00fd4a..e16e57b8e 100644
--- a/redhat/main/tdegames/tdegames.spec
+++ b/redhat/main/tdegames/tdegames.spec
@@ -191,7 +191,6 @@ TDE desktop.
%defattr(-,root,root,-)
%{tde_datadir}/cmake/libtdegames.cmake
%{tde_libdir}/pkgconfig/libtdegames.pc
-%{tde_mandir}/man*/atlantik.*
##########
@@ -279,6 +278,7 @@ This package is part of Trinity, and a component of the TDE games module.
%{tde_datadir}/icons/hicolor/*/apps/atlantik.png
%{tde_datadir}/apps/atlantik/
%{tde_tdedocdir}/HTML/en/atlantik/
+%{tde_mandir}/man*/atlantik.*
##########
diff --git a/redhat/main/tdelibs/tdelibs.spec b/redhat/main/tdelibs/tdelibs.spec
index 502ae9fe6..a3614b501 100644
--- a/redhat/main/tdelibs/tdelibs.spec
+++ b/redhat/main/tdelibs/tdelibs.spec
@@ -335,8 +335,10 @@ BuildRequires: file-devel
%if 0%{?mgaversion} || 0%{?mdkversion} || 0%{?rhel} >= 6 || 0%{?fedora} || 0%{?suse_version}
%define with_nm 1
%if 0%{?mgaversion} || 0%{?mdkversion}
+%if 0%{?mgaversion} != 8
BuildRequires: %{_lib}nm-util-devel
%endif
+%endif
%if 0%{?rhel} >= 6 || 0%{?fedora}
%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
BuildRequires: NetworkManager-libnm-devel
diff --git a/redhat/main/tdesdk/tdesdk.spec b/redhat/main/tdesdk/tdesdk.spec
index 0cea687d0..eeb166d8e 100644
--- a/redhat/main/tdesdk/tdesdk.spec
+++ b/redhat/main/tdesdk/tdesdk.spec
@@ -133,7 +133,7 @@ BuildRequires: perl-podlators
BuildRequires: openssl-devel
# PYTHON support
-%if 0%{?rhel} >= 8 || 0%{?fedora} >= 30
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 30 || 0%{?mgaversion} >= 8
%define python python3
%else
%define python python
@@ -1020,7 +1020,7 @@ This package contains the development files for tdesdk.
%prep
%setup -q -n %{name}-%{version}%{?preversion:~%{preversion}}
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
# Fix shebangs
sed -i "scripts/kdelnk2desktop.py" \
"scripts/zonetab2pot.py" \
diff --git a/redhat/main/tdevelop/tdevelop.spec b/redhat/main/tdevelop/tdevelop.spec
index 2f2705d5c..41071bd12 100644
--- a/redhat/main/tdevelop/tdevelop.spec
+++ b/redhat/main/tdevelop/tdevelop.spec
@@ -114,9 +114,15 @@ BuildRequires: libdb-devel
%else
# DB4 support
+%if 0%{?mgaversion} || 0%{?mdkversion}
+#BuildRequires: %{_lib}db4.8-devel
+%endif
%if 0%{?rhel} || 0%{?fedora}
BuildRequires: db4-devel
%endif
+%if 0%{?suse_version}
+BuildRequires: libdb-4_8-devel
+%endif
%endif
# FLEX support
@@ -148,6 +154,14 @@ BuildRequires: libacl-devel
# OPENSSL support
BuildRequires: openssl-devel
+# PYTHON support
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 30 || 0%{?mgaversion} >= 8
+%global python python2
+%global __python python2
+%else
+%global __python python2
+%endif
+
%description
The TDevelop Integrated Development Environment provides many features
@@ -598,6 +612,7 @@ This package contains the libraries needed for the tdevelop programs.
%setup -q -n %{name}-%{version}%{?preversion:~%{preversion}}
+
%build
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"