summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/games/knights/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-07-05 00:28:13 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-07-05 00:28:13 +0900
commit0cf700f49d6437ea21867ae6300c7056eadfbd97 (patch)
treedec8bff7ef4366370de0ad280d6395c363ce1f3f /debian/_base/applications/games/knights/debian/rules
parente52d0aefda74071dece63a038079503cdc2cc905 (diff)
downloadtde-packaging-0cf700f49d6437ea21867ae6300c7056eadfbd97.tar.gz
tde-packaging-0cf700f49d6437ea21867ae6300c7056eadfbd97.zip
Rearranged applications folder into sub categories.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'debian/_base/applications/games/knights/debian/rules')
-rwxr-xr-xdebian/_base/applications/games/knights/debian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/_base/applications/games/knights/debian/rules b/debian/_base/applications/games/knights/debian/rules
new file mode 100755
index 000000000..a6797f19a
--- /dev/null
+++ b/debian/_base/applications/games/knights/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"