summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/gtk-qt-engine
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 11:45:52 +0800
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 12:39:23 +0800
commitf3d5de18f2bdf89d5923d560420ae23cac051cb8 (patch)
tree50995b4f6bde0b3a83b0575195cc0dace287ee00 /debian/_base/applications/gtk-qt-engine
parent62b2ab9301211a2dab70e2eeda385fd15371ea3d (diff)
downloadtde-packaging-f3d5de18f2bdf89d5923d560420ae23cac051cb8.tar.gz
tde-packaging-f3d5de18f2bdf89d5923d560420ae23cac051cb8.zip
DEB: added cmake directive to create compilation database 'compile_commands.json' at build time.
This can be used to provide linting, autocompletion, hovering info, go-to-definition and in general other LSP functionality in development environments. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit eb16e7c7281e182297581fa8d565561869c81bca)
Diffstat (limited to 'debian/_base/applications/gtk-qt-engine')
-rwxr-xr-xdebian/_base/applications/gtk-qt-engine/debian/rules15
1 files changed, 13 insertions, 2 deletions
diff --git a/debian/_base/applications/gtk-qt-engine/debian/rules b/debian/_base/applications/gtk-qt-engine/debian/rules
index 7c03d82c4..23c51fe19 100755
--- a/debian/_base/applications/gtk-qt-engine/debian/rules
+++ b/debian/_base/applications/gtk-qt-engine/debian/rules
@@ -22,8 +22,19 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-DEB_CMAKE_EXTRA_FLAGS := -DLIB_SUFFIX="" -DCMAKE_INSTALL_PREFIX="/opt/trinity" -DCONFIG_INSTALL_DIR="/etc/trinity" -DSYSCONF_INSTALL_DIR="/etc/trinity" -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" -DCMAKE_INCLUDE_PATH="/opt/trinity/include/tde" -DAUTODETECT_QT_DIRS="ON" -DCMAKE_VERBOSE_MAKEFILE="ON" -DBUILD_ALL="ON" -DCMAKE_SKIP_RPATH="OFF" \
--DCMAKE_BUILD_TYPE=RelWithDebInfo
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DLIB_SUFFIX="" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" \
+ -DCMAKE_INCLUDE_PATH="/opt/trinity/include/tde" \
+ -DAUTODETECT_QT_DIRS="ON" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DBUILD_ALL="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)