summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/gwenview/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-04-03 18:05:50 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-04-03 18:05:50 +0200
commitaf5c905ec49085b7c396caf2c5166f0c34cbeb3f (patch)
tree56463d31ace48f127ed61169fdc2b4b8aedfcc56 /debian/_base/applications/gwenview/debian/rules
parente43172a6e74706afc06ff8d11cbfa769bc949cc1 (diff)
downloadtde-packaging-af5c905ec49085b7c396caf2c5166f0c34cbeb3f.tar.gz
tde-packaging-af5c905ec49085b7c396caf2c5166f0c34cbeb3f.zip
DEB: use _base folder for a distro instead of specific distros (squeeze and maverick).
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/_base/applications/gwenview/debian/rules')
-rwxr-xr-xdebian/_base/applications/gwenview/debian/rules44
1 files changed, 44 insertions, 0 deletions
diff --git a/debian/_base/applications/gwenview/debian/rules b/debian/_base/applications/gwenview/debian/rules
new file mode 100755
index 000000000..11548ae60
--- /dev/null
+++ b/debian/_base/applications/gwenview/debian/rules
@@ -0,0 +1,44 @@
+#! /usr/bin/make -f
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --enable-kipi --enable-final --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+DEB_INSTALL_DOCS_ALL :=
+DEB_INSTALL_CHANGELOGS_ALL := NEWS
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = debian/gwenview-trinity/opt/trinity/lib
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+install/gwenview-trinity::
+ install -p -D -m644 debian/gwenview.xpm debian/$(cdbs_curpkg)/opt/trinity/share/pixmaps/gwenview.xpm
+ install -p -D -m644 debian/gwenview.lintian debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg)
+
+ cd $(CURDIR)/debian/$(cdbs_curpkg)/opt/trinity/share/doc/tde/HTML/en/gwenview; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/gwenview/index.docbook