summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/internet/konversation/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-11 21:27:29 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-11 21:27:29 +0200
commit5195a57d4919924c7e7970506b1994e83fdebbbb (patch)
tree0939379ca3d176975efd109ea2cd66fb9f1f11d9 /debian/_base/applications/internet/konversation/debian/rules
parentcb277da52ac1a12d1b8f855fca48cd013948f4dc (diff)
downloadtde-packaging-5195a57d4919924c7e7970506b1994e83fdebbbb.tar.gz
tde-packaging-5195a57d4919924c7e7970506b1994e83fdebbbb.zip
DEB: Rearranged applications folder into sub categories.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/_base/applications/internet/konversation/debian/rules')
-rwxr-xr-xdebian/_base/applications/internet/konversation/debian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/_base/applications/internet/konversation/debian/rules b/debian/_base/applications/internet/konversation/debian/rules
new file mode 100755
index 000000000..b0ed413fd
--- /dev/null
+++ b/debian/_base/applications/internet/konversation/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_DH_STRIP_ARGS := --dbg-package=konversation-trinity-dbg
+DEB_INSTALL_DOCS_ALL =
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
+
+### Manpages
+XP = xsltproc --nonet --output debian/man/
+DB2MAN = /usr/share/xml/docbook/stylesheet/nwalsh/manpages/docbook.xsl
+
+%.1 : %.1.docbook
+ $(XP) $(DB2MAN) $<
+
+GENERATED_MANPAGES := $(patsubst %.docbook,%,$(wildcard debian/man/*.docbook))
+build/konversation:: $(GENERATED_MANPAGES)
+clean::
+ -rm -f $(GENERATED_MANPAGES)
+ -rm -f po/*/konversation.gmo
+
+### Extra file installation
+install/konversation-trinity::
+ install -D -m 644 konversation/scripts/README \
+ debian/konversation-trinity/opt/trinity/share/doc/konversation/README.scripts