summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kcmldapmanager/debian/cdbs/debian-tde.mk
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-06-02 04:22:54 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-06-02 04:22:57 +0200
commite42afbc338f404e13bf480a4f92dc251835c91da (patch)
treecb8803978d0120cddb8660207ae0d82890eda805 /debian/_base/applications/kcmldapmanager/debian/cdbs/debian-tde.mk
parent91d018159b9bf808a7bf1366f1ec67b454550dcf (diff)
downloadtde-packaging-e42afbc338f404e13bf480a4f92dc251835c91da.tar.gz
tde-packaging-e42afbc338f404e13bf480a4f92dc251835c91da.zip
DEB: Added support for using the $(DEB_HOST_MULTIARCH) variable
in the install and links files to the debian-tde.mk common rules. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 7abdfa3a6ff766651598f0c4c1363c9a0f29860d)
Diffstat (limited to 'debian/_base/applications/kcmldapmanager/debian/cdbs/debian-tde.mk')
-rw-r--r--debian/_base/applications/kcmldapmanager/debian/cdbs/debian-tde.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/_base/applications/kcmldapmanager/debian/cdbs/debian-tde.mk b/debian/_base/applications/kcmldapmanager/debian/cdbs/debian-tde.mk
index fb8c1b6c3..7c67fc9ca 100644
--- a/debian/_base/applications/kcmldapmanager/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/kcmldapmanager/debian/cdbs/debian-tde.mk
@@ -140,12 +140,22 @@ common-binary-arch::
cat $$tmpf >>debian/$$p.substvars; \
done; \
rm -f $$tmpf )
+ # update multi-arch path in install files
+ for a in debian/*install debian/*links; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
clean::
rm -rf debian/man/out
-rmdir debian/man
rm -f debian/stamp-man-pages
rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ for a in debian/*install debian/*links; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi