summaryrefslogtreecommitdiffstats
path: root/debian/_base/dependencies/avahi-tqt/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 11:45:52 +0800
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 12:39:23 +0800
commitf3d5de18f2bdf89d5923d560420ae23cac051cb8 (patch)
tree50995b4f6bde0b3a83b0575195cc0dace287ee00 /debian/_base/dependencies/avahi-tqt/debian/rules
parent62b2ab9301211a2dab70e2eeda385fd15371ea3d (diff)
downloadtde-packaging-f3d5de18f2bdf89d5923d560420ae23cac051cb8.tar.gz
tde-packaging-f3d5de18f2bdf89d5923d560420ae23cac051cb8.zip
DEB: added cmake directive to create compilation database 'compile_commands.json' at build time.
This can be used to provide linting, autocompletion, hovering info, go-to-definition and in general other LSP functionality in development environments. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit eb16e7c7281e182297581fa8d565561869c81bca)
Diffstat (limited to 'debian/_base/dependencies/avahi-tqt/debian/rules')
-rwxr-xr-xdebian/_base/dependencies/avahi-tqt/debian/rules1
1 files changed, 1 insertions, 0 deletions
diff --git a/debian/_base/dependencies/avahi-tqt/debian/rules b/debian/_base/dependencies/avahi-tqt/debian/rules
index 32d30901d..89f073b9f 100755
--- a/debian/_base/dependencies/avahi-tqt/debian/rules
+++ b/debian/_base/dependencies/avahi-tqt/debian/rules
@@ -9,6 +9,7 @@ export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,-z,defs -Wl,-O1
# Build options
DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_SKIP_RPATH="OFF" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \