summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/katapult/debian
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-03 14:44:58 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-03 14:44:58 -0500
commit0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6 (patch)
treec0d0d652fef20159e78fa20b2567661bd7db8e41 /debian/lenny/applications/katapult/debian
parent6b027437fd51e7874aaffed9e395ddf7913c3ab4 (diff)
downloadtde-packaging-0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6.tar.gz
tde-packaging-0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6.zip
Add initial Debian Lenny/Squeeze packaging as well as symlink Lucid to Maverick
Diffstat (limited to 'debian/lenny/applications/katapult/debian')
-rw-r--r--debian/lenny/applications/katapult/debian/cdbs/buildvars.mk86
-rw-r--r--debian/lenny/applications/katapult/debian/cdbs/debian-qt-kde.mk109
-rw-r--r--debian/lenny/applications/katapult/debian/cdbs/kde.mk97
-rw-r--r--debian/lenny/applications/katapult/debian/cdbs/team-members16
-rw-r--r--debian/lenny/applications/katapult/debian/cdbs/uploaders.mk29
-rw-r--r--debian/lenny/applications/katapult/debian/cdbs/versions.pl19
-rw-r--r--debian/lenny/applications/katapult/debian/changelog270
-rw-r--r--debian/lenny/applications/katapult/debian/compat1
-rw-r--r--debian/lenny/applications/katapult/debian/control19
-rw-r--r--debian/lenny/applications/katapult/debian/copyright35
-rw-r--r--debian/lenny/applications/katapult/debian/docs3
-rw-r--r--debian/lenny/applications/katapult/debian/katapult.1.docbook112
-rw-r--r--debian/lenny/applications/katapult/debian/lintian8
-rw-r--r--debian/lenny/applications/katapult/debian/menu3
-rw-r--r--debian/lenny/applications/katapult/debian/patches/.gitignore0
-rwxr-xr-xdebian/lenny/applications/katapult/debian/rules42
16 files changed, 849 insertions, 0 deletions
diff --git a/debian/lenny/applications/katapult/debian/cdbs/buildvars.mk b/debian/lenny/applications/katapult/debian/cdbs/buildvars.mk
new file mode 100644
index 000000000..23d4709dc
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/cdbs/buildvars.mk
@@ -0,0 +1,86 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2002,2003 Colin Walters <walters@debian.org>
+# Description: Defines some useful variables, but no rules
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_rules_buildvars
+_cdbs_rules_buildvars = 1
+
+CDBS_VERSION = something
+
+# Common useful variables
+DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
+
+# Split into arch/indep packages
+ifneq ($(DEB_INDEP_PACKAGES),cdbs)
+DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
+DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
+endif
+# Split into normal and udeb packages
+ifeq ($(DEB_UDEB_PACKAGES),)
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+else
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+endif
+# Too much bother for now. If someone complains we'll fix it.
+#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
+#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
+# A handy list of every package, udeb or not
+DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
+DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
+DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
+
+DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+
+# Some support for srcdir != builddir builds.
+# These are relative to the root of the package
+DEB_SRCDIR ?= .
+DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
+
+# Miscellaneous bits
+DEB_ARCH = $(shell dpkg --print-architecture)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
+DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
+DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
+DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
+
+ifeq ($(words $(DEB_ALL_PACKAGES)),1)
+ DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
+else
+ DEB_DESTDIR = $(CURDIR)/debian/tmp/
+endif
+
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
+
+endif
diff --git a/debian/lenny/applications/katapult/debian/cdbs/debian-qt-kde.mk b/debian/lenny/applications/katapult/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..47e83ef4a
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,109 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+include debian/cdbs/uploaders.mk
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/lenny/applications/katapult/debian/cdbs/kde.mk b/debian/lenny/applications/katapult/debian/cdbs/kde.mk
new file mode 100644
index 000000000..5b6508f8c
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/cdbs/kde.mk
@@ -0,0 +1,97 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/kde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/kde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-prehook-impl::
+ mkdir -p po
+ -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
+ -for file in po/*pot; do \
+ sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
+ done
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+ rm -rf po/*.pot
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/lenny/applications/katapult/debian/cdbs/team-members b/debian/lenny/applications/katapult/debian/cdbs/team-members
new file mode 100644
index 000000000..05761af6e
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/cdbs/team-members
@@ -0,0 +1,16 @@
+Sune Vuorela <debian@pusling.com>
+Ana Beatriz Guerrero Lopez <ana@debian.org>
+Fathi Boudra <fboudra@free.fr>
+Modestas Vainius <geromanas@mailas.com>
+Josh Metzler <joshdeb@metzlers.org>
+Isaac Clerencia <isaac@debian.org>
+Adeodato Simó <dato@net.com.org.es>
+Adeodato Simo <dato@net.com.org.es>
+Christopher Martin <chrsmrtn@debian.org>
+Daniel Schepler <schepler@debian.org>
+Sarah Hobbs <hobbsee@ubuntu.com>
+Nacho Barrientos Arias <nacho@debian.org>
+Ricardo Javier Cardenes Medina <rcardenes@debian.org>
+Ricardo Cardenes <rcardenes@debian.org>
+Armin Berres <trigger+debian@space-based.de>
+Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/debian/lenny/applications/katapult/debian/cdbs/uploaders.mk b/debian/lenny/applications/katapult/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders
diff --git a/debian/lenny/applications/katapult/debian/cdbs/versions.pl b/debian/lenny/applications/katapult/debian/cdbs/versions.pl
new file mode 100644
index 000000000..9ce11d8a3
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/-[^-]+$//;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/debian/lenny/applications/katapult/debian/changelog b/debian/lenny/applications/katapult/debian/changelog
new file mode 100644
index 000000000..bec1d29b8
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/changelog
@@ -0,0 +1,270 @@
+katapult-trinity (0.3.2.1~0ubuntu3) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 July 2009 16:08:00 -0600
+
+katapult-trinity (0.3.2.1~0ubuntu2) intrepid; urgency=low
+
+ * Moved KDE3 to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 05 March 2009 01:11:00 -0600
+
+katapult-trinity (0.3.2.1~0ubuntu1) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 11 Dec 2008 16:43:00 -0600
+
+katapult (0.3.2.1-3) unstable; urgency=low
+
+ * Updated Slovak Translation .po (Closes: #441628)
+ * Added patch to make katapult link against QT
+ * Updated Rules for ability to build with dash (Closes: #459167)
+ * Bumped Standards Version
+ * Added Patch to fix issues with MySQL 5 BC Breaks
+
+ -- Martin Meredith <mez@ubuntu.com> Mon, 10 Mar 2008 16:41:04 +0000
+
+katapult (0.3.2.1-2) unstable; urgency=low
+
+ * Merged in ubuntu Changes (outline below)
+
+ -- Martin Meredith <mez@ubuntu.com> Mon, 23 Jul 2007 08:22:14 +0100
+
+katapult (0.3.2.1-1ubuntu2) gutsy; urgency=low
+
+ * Fix Fix ftbfs, bad version uploaded
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Thu, 19 Jul 2007 20:36:32 +0200
+
+katapult (0.3.2.1-1ubuntu1) gutsy; urgency=low
+
+ * Dont install the autostart desktop file. Causes katapult to show at
+ every boot, so well use ksmserver instead for silent startup.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Thu, 19 Jul 2007 10:23:35 +0200
+
+katapult (0.3.2.1-1) unstable; urgency=low
+
+ * New Upstream Release
+
+ -- Martin Meredith <mez@ubuntu.com> Sun, 01 Jul 2007 22:12:51 +0100
+
+katapult (0.3.2.1-0ubuntu1) gutsy; urgency=low
+
+ * New Upstream Release
+
+ -- Martin Meredith <mez@ubuntu.com> Sun, 01 Jul 2007 22:12:35 +0100
+
+katapult (0.3.2-1) unstable; urgency=low
+
+ * New Upstream Release
+ * Fixed Localisation Issues (Closes: #352681)
+
+ -- Martin Meredith <mez@ubuntu.com> Sun, 01 Jul 2007 21:30:09 +0100
+
+katapult (0.3.2-0ubuntu1) gutsy; urgency=low
+
+ * New Upstream Release
+
+ -- Martin Meredith <mez@ubuntu.com> Sun, 01 Jul 2007 21:29:57 +0100
+
+katapult (0.3.1.4-0ubuntu6) gutsy; urgency=low
+
+ * Add kubuntu_01_clean_SQL.patch
+ Fixes LP: #120575
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Fri, 29 Jun 2007 17:25:09 +0200
+
+katapult (0.3.1.4-0ubuntu5) feisty; urgency=low
+
+ * Switch back to ksmserver autostart, since/usr/bin/autostart
+ let katapult appear on screen at every boot.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sat, 20 Jan 2007 08:42:27 +0100
+
+katapult (0.3.1.4-0ubuntu4) feisty; urgency=low
+
+ * Changed debian/rules, install autostart file in
+ /usr/share/autostart
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sat, 20 Jan 2007 01:27:32 +0100
+
+katapult (0.3.1.4-0ubuntu3) feisty; urgency=low
+
+ * debian/control: Update upstream URL.
+ * debian/copyright: Correct misspelling of upstream authors.
+
+ -- Daniel T Chen <crimsun@ubuntu.com> Mon, 15 Jan 2007 12:54:56 -0500
+
+katapult (0.3.1.4-0ubuntu2) feisty; urgency=low
+
+ * Fixed source package diff.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 7 Nov 2006 10:39:26 -0800
+
+katapult (0.3.1.4-0ubuntu1) feisty; urgency=low
+
+ * New upstream release
+ * Removed all obsolete patches
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 6 Nov 2006 14:06:26 -0800
+
+katapult (0.3.1.3-0ubuntu5) edgy; urgency=low
+
+ * Add kubuntu_06_amarok_14.diff closes 60136
+ * Add kubuntu_07_work_with_non_english.diff closes 48103
+ * Add build-dep on sharutils
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Sun, 22 Oct 2006 14:51:54 +0100
+
+katapult (0.3.1.3-0ubuntu4) edgy; urgency=low
+
+ * Set .pot name in debian/rules
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Sun, 1 Oct 2006 13:02:12 +0100
+
+katapult (0.3.1.3-0ubuntu3) edgy; urgency=low
+
+ * Add kubuntu_05_fix_doublebackspace.diff, fixes Malone
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Wed, 27 Sep 2006 22:03:02 +0200
+
+katapult (0.3.1.3-0ubuntu2) edgy; urgency=low
+
+ * Add kubuntu_03_spellingcatalog.diff.uu and kubuntu_04_spellingcatalog_default.diff
+ to add back missing spelling catalogue
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 18 Sep 2006 13:53:26 +0100
+
+katapult (0.3.1.3-0ubuntu1) edgy; urgency=low
+
+ * New upstream release (closing #58178 and #56918)
+ * Tarball rebuilt for modern "admin" folder since buildprep is used
+ due to Makefile.am addition by patch kubuntu_01_o2display.diff and
+ current admin folder is uncompatible with autoconf 2.60
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 30 Aug 2006 13:20:02 +0200
+
+katapult (0.3.1.2svn20060711-0ubuntu2) edgy; urgency=low
+
+ * Add kubuntu_01_o2display.diff with new look by Ken Wimer
+ * Add kubuntu_02_text_colours.diff with new text colours by Ken Wimer
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Tue, 29 Aug 2006 18:26:02 +0100
+
+katapult (0.3.1.2svn20060711-0ubuntu1) edgy; urgency=low
+
+ * New snapshot
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Tue, 11 Jul 2006 15:36:09 +0000
+
+katapult (0.3.1.2-0ubuntu4) dapper; urgency=low
+
+ * Rebuild to use dh_iconcache.
+
+ -- Daniel Holbach <daniel.holbach@ubuntu.com> Thu, 18 May 2006 15:08:05 +0200
+
+katapult (0.3.1.2-0ubuntu3) dapper; urgency=low
+
+ [ Martin Meredith ]
+ * Add patch kubuntu_01_amarok_mysql.diff
+ allows Amarok plugin to work when Amarok is using mysql
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Sat, 13 May 2006 13:25:57 +0300
+
+katapult (0.3.1.2-0ubuntu2) dapper; urgency=low
+
+ * Updated Control to list correct homepage
+
+ -- Martin Meredith <mez@ubuntu.com> Fri, 10 Mar 2006 13:45:03 +0000
+
+katapult (0.3.1.2-0ubuntu1) dapper; urgency=low
+
+ * New Upstream Version
+
+ -- Martin Meredith <mez@ubuntu.com> Mon, 6 Mar 2006 19:37:07 +0000
+
+katapult (0.3.1.1-1) unstable; urgency=low
+
+ * New Upstream Version
+ * Removed patches - incorporated into upstream
+
+ -- Martin Meredith <mez@ubuntu.com> Fri, 10 Mar 2006 13:43:49 +0000
+
+katapult (0.3.1-1) unstable; urgency=low
+
+ * Initial upload to Debian. (Closes: #344787: ITP: katapult -- KDE Launcher
+ Application - Debian Bug report logs)
+
+ -- Martin Meredith <mez@ubuntu.com> Tue, 17 Jan 2006 15:59:50 +0000
+
+katapult (0.3.baz20051226-1) unstable; urgency=low
+
+ * Removed automake/autotools B-D - not needed
+ * removed /doc folder - not needed
+ * Removed patchutils references - no patches - incorporated into upstream
+
+ -- Martin Meredith <mez@ubuntu.com> Wed, 28 Dec 2005 15:57:17 +0000
+
+katapult (0.3.baz20051226-0ubuntu1) dapper; urgency=low
+
+ * Updated Source to Latest Baz Branch
+ * Incorporated patches into katapult
+ * Changed Maintainer: Field in control
+
+ -- Martin Meredith <mez@ubuntu.com> Mon, 26 Dec 2005 06:16:32 +0000
+
+katapult (0.3-0ubuntu3) dapper; urgency=low
+
+ * Add back updated kubuntu_02_fix_desktop_file.diff to
+ make it not show in menu
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 15 Dec 2005 19:55:46 +0000
+
+katapult (0.3-0ubuntu2) dapper; urgency=low
+
+ * Add automake1.9 to build-dep
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Fri, 9 Dec 2005 00:02:28 +0000
+
+katapult (0.3-0ubuntu1) dapper; urgency=low
+
+ * New Upstream Version
+ * Removed all patches - In upstream
+ * Added Calculator and Amarok Plugins
+ * Add kubuntu_01_kdepot.diff for .pot generation
+ * Add kubuntu_02_default_catalogues.diff turn on calculator
+ and amarok plugins by default
+ * Add kubuntu_03_icon.diff use k-menu icon
+ * Sponsored upload for Martin Meredith <mez@ubuntu.com>
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 8 Dec 2005 17:58:36 +0000
+
+katapult (0.2-0ubuntu3) breezy; urgency=low
+
+ * Add fixes from SVN:
+ - kubuntu_03_crash.diff prevent crash when it can't find an item
+ - kubuntu_04_systray_optional.diff turn off systray icon
+ - kubuntu_05_configure_shortcut.diff add keyboard shortcut for configure
+ - kubuntu_06_noautoexec.diff don't automatically start an item
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 15 Sep 2005 18:27:05 +0100
+
+katapult (0.2-0ubuntu2) breezy; urgency=low
+
+ * Add libxi-dev build-depend
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 11 Jul 2005 09:21:12 +0000
+
+katapult (0.2-0ubuntu1) breezy; urgency=low
+
+ * Initial Release.
+ * Fixed katapult.desktop file to be KDE standard complient (patch number 02).
+ * Fixed katapult/Makefile.am for desktop file directory (patch number 01).
+ * Added a manpage (from docbook source).
+ * Sponsored upload for Jean-Remy Falleri <jr.falleri@laposte.net>
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 7 Jul 2005 16:00:00 +0000
diff --git a/debian/lenny/applications/katapult/debian/compat b/debian/lenny/applications/katapult/debian/compat
new file mode 100644
index 000000000..7ed6ff82d
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/lenny/applications/katapult/debian/control b/debian/lenny/applications/katapult/debian/control
new file mode 100644
index 000000000..b43c2565e
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/control
@@ -0,0 +1,19 @@
+Source: katapult-trinity
+Section: kde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: cdbs (>= 0.4.46ubuntu5), debhelper (>= 5.0.0), kdelibs4-trinity-dev, docbook2x, libxi-dev, sharutils, automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+
+Package: katapult-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: item launcher for KDE [Trinity]
+ Katapult is an application, which analyses text-based queries
+ to launch items, such as bookmarks, directories or programs.
+ .
+ The application is currently in an early stage of development but
+ the launchable item list can be extended by a plugin system, and
+ the look and feel can be skinned.
+ .
+ Homepage: http://katapult.kde.org/
diff --git a/debian/lenny/applications/katapult/debian/copyright b/debian/lenny/applications/katapult/debian/copyright
new file mode 100644
index 000000000..fa75bbec3
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/copyright
@@ -0,0 +1,35 @@
+This package was debianized by Jean-Remy Falleri <jr.falleri@laposte.net> on
+Mon, 9 May 2005 17:41:21 +0200.
+
+It was downloaded from: http://sourceforge.net/projects/katapult/
+
+Upstream Authors:
+ Martin Meredith <martin@sourceguru.net>
+ Bastian Holst <bastianholst@gmx.de>
+ Tobi Vollebregt <tobivollebregt@gmail.com>
+ Lee Olson <clearbeast@gmail.com>
+ Jean-Remi Falleri <jr.falleri@gmail.com>
+ Johnathan Riddell <jriddell@ubuntu.com>
+ Joe Ferris <jferris@optimistictech.com>
+
+Copyright: (c) 2005-2007 Martin Meredith, Bastian Holst, Tobi Vollebregt,
+ Lee Olson, Jean-Remi Falleri, Jonathan Riddell,
+ and Joe Ferris
+
+Packaging: (c) 2005-2007 Martin Meredith, Jean-Remy
+
+
+All the software & packaging is GPL:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ On Debian GNU/Linux systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/lenny/applications/katapult/debian/docs b/debian/lenny/applications/katapult/debian/docs
new file mode 100644
index 000000000..022850854
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/docs
@@ -0,0 +1,3 @@
+AUTHORS
+TODO
+
diff --git a/debian/lenny/applications/katapult/debian/katapult.1.docbook b/debian/lenny/applications/katapult/debian/katapult.1.docbook
new file mode 100644
index 000000000..718ff8707
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/katapult.1.docbook
@@ -0,0 +1,112 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+]>
+<refentry>
+ <refentryinfo>
+ <author>
+ <firstname>Falleri</firstname>
+ <surname>Jean-Remy</surname>
+ <email>jr.falleri@laposte.net</email>
+ </author>
+ <copyright>
+ <year>2005</year>
+ <holder>Jean-Remy Falleri</holder>
+ </copyright>
+ <!-- XXX IMPORTANT XXX -->
+ <!-- Keep this date up to date: -->
+ <date>2005-05-10</date>
+ <!-- ^^^^^^^^^^ -->
+ </refentryinfo>
+ <refmeta>
+ <refentrytitle>katapult</refentrytitle>
+ <manvolnum>1</manvolnum>
+ </refmeta>
+ <refnamediv>
+ <refname>katapult</refname>
+ <refpurpose>A KDE laucher</refpurpose>
+ </refnamediv>
+ <refsynopsisdiv>
+ <cmdsynopsis>
+ <command>katapult</command>
+ <arg choice="opt">
+ <option><replaceable>Qt-options</replaceable></option>
+ </arg>
+ <arg choice="opt">
+ <option><replaceable>KDE-options</replaceable></option>
+ </arg>
+ </cmdsynopsis>
+ </refsynopsisdiv>
+ <refsect1>
+ <title>DESCRIPTION</title>
+ <para>
+ Katapult is a KDE laucher.
+ </para>
+ <para>
+ It uses text-based queries to launch a program, a bookmark or a directory.
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>OPTIONS</title>
+ <para>
+ All <productname>KDE</productname> and <productname>Qt</productname>
+ programs accept a some common command-line options. Katapult has no
+ application-specific options.
+ </para>
+ <para>
+ <variablelist>
+ <title>Generic options:</title>
+ <varlistentry>
+ <term> <option>--help</option> </term>
+ <listitem> <para>Show help about options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-qt</option> </term>
+ <listitem> <para>Show Qt specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-kde</option> </term>
+ <listitem> <para>Show KDE specific options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--help-all</option> </term>
+ <listitem> <para>Show all options</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--author</option> </term>
+ <listitem> <para>Show author information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>-v</option>, <option>--version</option> </term>
+ <listitem> <para>Show version information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--license</option> </term>
+ <listitem> <para>Show license information</para> </listitem>
+ </varlistentry>
+ <varlistentry>
+ <term> <option>--</option> </term>
+ <listitem> <para>Indicates end of options</para> </listitem>
+ </varlistentry>
+ </variablelist>
+ <!-- TODO * add all the rest of the options, but maybe find an automated
+ way to keep it up to date -->
+ </para>
+ </refsect1>
+ <refsect1>
+ <title>COPYRIGHT</title>
+ <para>
+ This manual page was written by Jean-Remy Falleri
+ <email>jr.falleri@laposte.net</email> for the
+ <productname>Ubuntu</productname> system (but may be used by others).
+ Permission is granted to copy, distribute and/or modify this document
+ under the terms of the <acronym>GNU</acronym> General Public License,
+ Version 2 or any later version published by the Free Software Foundation.
+ </para>
+ <para>
+ On Debian systems, the complete text of the GNU General Public
+ License can be found in
+ <filename>/usr/share/common-licenses/GPL</filename>.
+ </para>
+ </refsect1>
+</refentry>
diff --git a/debian/lenny/applications/katapult/debian/lintian b/debian/lenny/applications/katapult/debian/lintian
new file mode 100644
index 000000000..af70e7550
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/lintian
@@ -0,0 +1,8 @@
+katapult-trinity: desktop-file-in-wrong-dir usr/share/servicetypes/katapultdisplay.desktop
+katapult-trinity: desktop-file-in-wrong-dir usr/share/servicetypes/katapultcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir usr/share/services/katapult_programcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir usr/share/services/katapult_bookmarkcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir usr/share/services/katapult_documentcatalog.desktop
+katapult-trinity: desktop-file-in-wrong-dir usr/share/services/katapult_glassdisplay.desktop
+katapult-trinity binary: package-name-doesnt-match-sonames libkatapultdisplay0 libkatapultcatalog0 libkatapult0
+
diff --git a/debian/lenny/applications/katapult/debian/menu b/debian/lenny/applications/katapult/debian/menu
new file mode 100644
index 000000000..a76f261ac
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/menu
@@ -0,0 +1,3 @@
+?package(katapult):needs="X11" section="Apps/Tools"\
+ title="Katapult" command="katapult"
+
diff --git a/debian/lenny/applications/katapult/debian/patches/.gitignore b/debian/lenny/applications/katapult/debian/patches/.gitignore
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/patches/.gitignore
diff --git a/debian/lenny/applications/katapult/debian/rules b/debian/lenny/applications/katapult/debian/rules
new file mode 100755
index 000000000..f29a6a564
--- /dev/null
+++ b/debian/lenny/applications/katapult/debian/rules
@@ -0,0 +1,42 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+export KUBUNTU_DESKTOP_POT=extragear-utils_katapult
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+cleanbuilddir/katapult-trinity::
+ rm -f katapult.1
+
+build/katapult-trinity::
+ docbook2x-man debian/katapult.1.docbook
+
+DEB_INSTALL_MANPAGES_katapult-trinity = katapult.1
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+install/katapult-trinity::
+ rm -f $(CURDIR)/debian/katapult-trinity/opt/trinity/lib/libkatapult*.so
+ rm -f $(CURDIR)/debian/katapult-trinity/opt/trinity/lib/libkatapult*.la
+ dh_install $(DEB_SRCDIR)/debian/lintian opt/trinity/share/lintian/overrides/katapult
+# dh_install $(DEB_SRCDIR)/katapult/katapult/katapult.desktop opt/trinity/share/autostart
+# echo 'X-KDE-autostart-condition=katapultrc:General:Autostart:true' >> $(DEB_DESTDIR)/opt/trinity/share/autostart/katapult.desktop