summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/kmymoney/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-03 14:44:58 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-03 14:44:58 -0500
commit0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6 (patch)
treec0d0d652fef20159e78fa20b2567661bd7db8e41 /debian/lenny/applications/kmymoney/debian/rules
parent6b027437fd51e7874aaffed9e395ddf7913c3ab4 (diff)
downloadtde-packaging-0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6.tar.gz
tde-packaging-0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6.zip
Add initial Debian Lenny/Squeeze packaging as well as symlink Lucid to Maverick
Diffstat (limited to 'debian/lenny/applications/kmymoney/debian/rules')
-rwxr-xr-xdebian/lenny/applications/kmymoney/debian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/lenny/applications/kmymoney/debian/rules b/debian/lenny/applications/kmymoney/debian/rules
new file mode 100755
index 000000000..efb7a96ea
--- /dev/null
+++ b/debian/lenny/applications/kmymoney/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde --disable-sqlite3
+
+LDFLAGS += -Wl,--as-needed
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+clean::
+ rm -f po/*.gmo