summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/knetload/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-08-07 15:31:57 +0200
committerSlávek Banko <slavek.banko@axis.cz>2016-08-07 15:31:57 +0200
commit169a62ee172b2e200c14f91512181c22bb1bd9fb (patch)
treede39d59e71b7afc310ff549a308b85b2a3805bd1 /debian/lenny/applications/knetload/debian/rules
parentbd06c0aa4bfa9fff706427864bd8a53c23d1d2bf (diff)
downloadtde-packaging-169a62ee172b2e200c14f91512181c22bb1bd9fb.tar.gz
tde-packaging-169a62ee172b2e200c14f91512181c22bb1bd9fb.zip
Use common build rules for knetload on Debian and Ubuntu
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/lenny/applications/knetload/debian/rules')
-rwxr-xr-xdebian/lenny/applications/knetload/debian/rules203
1 files changed, 8 insertions, 195 deletions
diff --git a/debian/lenny/applications/knetload/debian/rules b/debian/lenny/applications/knetload/debian/rules
index 43c44fbe2..2e9187a31 100755
--- a/debian/lenny/applications/knetload/debian/rules
+++ b/debian/lenny/applications/knetload/debian/rules
@@ -1,204 +1,17 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
-
-# This has to be exported to make some magic below work.
-export DH_OPTIONS
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-INSTALL_DIR = install -p -d -o root -g root -m 755
-INSTALL_FILE = install -p -o root -g root -m 644
-
-objdir = $(CURDIR)/obj-$(DEB_BUILD_GNU_TYPE)
-
-tmp = debian/knetload-trinity
-
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -g
-endif
-
-ifeq ($(DEB_BUILD_GNU_TYPE),i386-linux)
- # Uncomment the following 2 lines to enable i686 optimziation
- # You may want to tweak the settings to your likings
- #export CFLAGS=-O3 -march=i686 -ffast-math -finline-functions
- #export CXXFLAGS=-O3 -march=i686 -ffast-math -finline-functions
-endif
-
--include debian/debiandirs
-
-debian/debiandirs: admin/debianrules
- perl -w admin/debianrules echodirs > debian/debiandirs
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
-
- # Apply Debian specific patches
- if test ! -f patch-stamp; then \
- for patch in $(CURDIR)/debian/patches/*.diff ;\
- do \
- echo APPLYING PATCH\: $${patch##*/};\
- patch -p1 < $$patch ;\
- done ;\
- touch patch-stamp ;\
- fi
-
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- # make build directory
- mkdir $(objdir)
-
- # run configure with build tree $(objdir)
- cd $(objdir) && \
- ../configure $(configkde) --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
-
- touch configure-stamp
-
-build: build-stamp
-build-stamp: configure-stamp
- dh_testdir
-
- cd $(objdir) && \
- $(MAKE)
-
- touch build-stamp
-
-debian-clean:
- dh_testdir
- dh_testroot
-
- dh_clean
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp debian/debiandirs
-
- # Remove Debian specific patches
- if test -f patch-stamp; then \
- for patch in $(CURDIR)/debian/patches/*.diff ;\
- do \
- echo REMOVING PATCH\: $${patch##*/};\
- patch -p1 -R < $$patch ;\
- done ;\
- rm -f patch-stamp ;\
- fi
-
- # Remove build tree
- rm -rf $(objdir)
-
- # if Makefile exists run distclean
- if test -f Makefile; then \
- $(MAKE) distclean; \
- fi
-
- if test -d CVS; then \
- $(MAKE) -f admin/Makefile.common cvs-clean ;\
- fi
-
- # Auto-update config.{guess,sub}
- -test -r /usr/share/misc/config.guess && \
- cp -f /usr/share/misc/config.guess admin/config.guess
- -test -r /usr/share/misc/config.sub && \
- cp -f /usr/share/misc/config.sub admin/config.sub
-
- dh_clean
-
-install: DH_OPTIONS=
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- cd $(objdir) && \
- $(MAKE) install DESTDIR=$(CURDIR)/debian/knetload-trinity
-
- # Install additional files beyond the standard install.
- dh_install
-
- # Generate HTML docs.
-# for i in `find $(tmp) -name "index.docbook"`; do \
-# ( cd `dirname $$i`; meinproc `basename $$i` ); \
-# done
-
- # Install standard documentation links.
- for pkg in `dh_listpackages`; do \
- if test -d debian/$$pkg/opt/trinity/share/doc/tde/HTML/en/$$pkg; then \
- dh_link -p$$pkg opt/trinity/share/doc/tde/HTML/en/$$pkg \
- opt/trinity/share/doc/$$pkg/html; \
- fi; \
- done
-
-# This single target is used to build all the packages, all at once, or
-# one at a time. So keep in mind: any options passed to commands here will
-# affect _all_ packages. Anything you want to only affect one package
-# should be put in another target, such as the install target.
-binary-common:
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_installman
- mv debian/knetload-trinity/usr/share/man debian/knetload-trinity/opt/trinity/share/
- dh_installmenu
- dh_installmime
- dh_strip
- dh_link
- dh_compress -X.docbook -X.css -X-license -X.dcl -X.bz2
- dh_fixperms
- dh_makeshlibs -V
- dh_installdeb
- dh_perl
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
-
-# Build architecture independant packages using the common target.
-binary-indep: build install
- # We have nothing to do by default.
-
-# Build architecture dependant packages using the common target.
-binary-arch: build install
- $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
-
-# Any other binary targets build just one binary package at a time.
-binary-%: build install
- $(MAKE) -f debian/rules binary-common DH_OPTIONS=-p$*
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary-install/knetload-trinity::
+ mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/