summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/kpowersave/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2014-01-23 14:38:02 +0100
committerSlávek Banko <slavek.banko@axis.cz>2014-01-23 14:38:02 +0100
commitb65f962ae74bd6650c3aedde69a32d6118ab2dfc (patch)
treec250167154bce857f76737aa4bec71ec345566a1 /debian/lenny/applications/kpowersave/debian/rules
parent0d3289022732c774be0f50747fa498001e25a778 (diff)
downloadtde-packaging-b65f962ae74bd6650c3aedde69a32d6118ab2dfc.tar.gz
tde-packaging-b65f962ae74bd6650c3aedde69a32d6118ab2dfc.zip
Switch kpowersave to cmake on Debian and Ubuntu
Diffstat (limited to 'debian/lenny/applications/kpowersave/debian/rules')
-rwxr-xr-xdebian/lenny/applications/kpowersave/debian/rules15
1 files changed, 13 insertions, 2 deletions
diff --git a/debian/lenny/applications/kpowersave/debian/rules b/debian/lenny/applications/kpowersave/debian/rules
index fb0e95a07..6a43028a3 100755
--- a/debian/lenny/applications/kpowersave/debian/rules
+++ b/debian/lenny/applications/kpowersave/debian/rules
@@ -1,10 +1,11 @@
#!/usr/bin/make -f
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/kde.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
@@ -12,11 +13,21 @@ DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
DEB_INSTALL_DOCS_ALL := AUTHORS NEWS
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON"
+
post-patches:: debian/stamp-bootstrap
debian/stamp-bootstrap: