summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/kshutdown/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-07-29 00:59:49 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-07-29 01:00:13 +0200
commit31853390244b190be4e984e5c97356bf37395233 (patch)
treef7ed2f2fd9885f9cf786eb6e573756b1c54fbcd6 /debian/lenny/applications/kshutdown/debian/rules
parentc95456d379e84e0beb512ac41360fcba204585bf (diff)
downloadtde-packaging-31853390244b190be4e984e5c97356bf37395233.tar.gz
tde-packaging-31853390244b190be4e984e5c97356bf37395233.zip
Add kshutdown packaging files for Debian and Ubuntu
Diffstat (limited to 'debian/lenny/applications/kshutdown/debian/rules')
-rwxr-xr-xdebian/lenny/applications/kshutdown/debian/rules37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/lenny/applications/kshutdown/debian/rules b/debian/lenny/applications/kshutdown/debian/rules
new file mode 100755
index 000000000..78ead2287
--- /dev/null
+++ b/debian/lenny/applications/kshutdown/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+binary-install/kshutdown-trinity::
+ dh_testdir
+ mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
+
+clean::
+ dh_testdir
+ rm -f debian/stamp-bootstrap