summaryrefslogtreecommitdiffstats
path: root/debian/lenny
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-16 16:59:37 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-16 16:59:37 +0100
commit086a459876d77498428592462fc9e2b6c5bc2acc (patch)
treecc3b9b0f41fb32d27473ba92f8a9fadc13594bf8 /debian/lenny
parent5b58ede56969785946045c8516bb8298e3ce9d1d (diff)
downloadtde-packaging-086a459876d77498428592462fc9e2b6c5bc2acc.tar.gz
tde-packaging-086a459876d77498428592462fc9e2b6c5bc2acc.zip
DEB kplayer: Switch to cmake.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/lenny')
-rw-r--r--debian/lenny/applications/kplayer/debian/control2
-rwxr-xr-xdebian/lenny/applications/kplayer/debian/rules20
2 files changed, 14 insertions, 8 deletions
diff --git a/debian/lenny/applications/kplayer/debian/control b/debian/lenny/applications/kplayer/debian/control
index eb9e60cec..70819c71e 100644
--- a/debian/lenny/applications/kplayer/debian/control
+++ b/debian/lenny/applications/kplayer/debian/control
@@ -2,7 +2,7 @@ Source: kplayer-trinity
Section: tde
Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
-Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, automake, libtool, tdelibs-trinity-dev
+Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, cmake, tdelibs-trinity-dev
Standards-Version: 3.8.4
Homepage: http://kplayer.sourceforge.net/
#Vcs-Git: git://anonscm.debian.org/collab-maint/kplayer-trinity.git
diff --git a/debian/lenny/applications/kplayer/debian/rules b/debian/lenny/applications/kplayer/debian/rules
index c9d7823f9..d8d772064 100755
--- a/debian/lenny/applications/kplayer/debian/rules
+++ b/debian/lenny/applications/kplayer/debian/rules
@@ -1,14 +1,20 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
include debian/cdbs/debian-qt-kde.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"