summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications/kcmldapcontroller/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-11-27 00:16:17 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-11-27 00:16:17 -0600
commit5a14f3594994dc15286a27cae9f5e8ee431c32cb (patch)
tree13f836ae609b333bd1b0e632ad2b605871323e3c /debian/squeeze/applications/kcmldapcontroller/debian/rules
parent7637e96423c2728568aa17fe358709df36a0495d (diff)
downloadtde-packaging-5a14f3594994dc15286a27cae9f5e8ee431c32cb.tar.gz
tde-packaging-5a14f3594994dc15286a27cae9f5e8ee431c32cb.zip
Add ldap module packaging files to Debian and Ubuntu
Diffstat (limited to 'debian/squeeze/applications/kcmldapcontroller/debian/rules')
-rw-r--r--debian/squeeze/applications/kcmldapcontroller/debian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/squeeze/applications/kcmldapcontroller/debian/rules b/debian/squeeze/applications/kcmldapcontroller/debian/rules
new file mode 100644
index 000000000..242fb2c84
--- /dev/null
+++ b/debian/squeeze/applications/kcmldapcontroller/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap