summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications/kdesvn/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-26 20:41:48 -0600
committerSlávek Banko <slavek.banko@axis.cz>2017-07-17 23:19:31 +0200
commit363393a1df11d4a3ad3ac9666bd30a6d4824cbab (patch)
treea142d811b5c6ad0511c258456deade1aa1130d2f /debian/squeeze/applications/kdesvn/debian/rules
parentdb78c1d8f3744e224bc747b0c534438739bd06d7 (diff)
downloadtde-packaging-363393a1df11d4a3ad3ac9666bd30a6d4824cbab.tar.gz
tde-packaging-363393a1df11d4a3ad3ac9666bd30a6d4824cbab.zip
Use standard build system for tdesvn on Debian and Ubuntu
(cherry picked from commit 1b03583b3c6545e21a13a75f63647de2b6aa12d4)
Diffstat (limited to 'debian/squeeze/applications/kdesvn/debian/rules')
-rwxr-xr-xdebian/squeeze/applications/kdesvn/debian/rules30
1 files changed, 16 insertions, 14 deletions
diff --git a/debian/squeeze/applications/kdesvn/debian/rules b/debian/squeeze/applications/kdesvn/debian/rules
index f49bca49b..d85c8bf6a 100755
--- a/debian/squeeze/applications/kdesvn/debian/rules
+++ b/debian/squeeze/applications/kdesvn/debian/rules
@@ -1,18 +1,23 @@
#!/usr/bin/make -f
-PATH := /opt/trinity/bin:$(PATH)
-
+# Set LD_LIBRARY_PATH to the installed library directory to allow dh_shlibdeps to function
+# Also include the main Trinity path
+ifeq ("$(LD_LIBRARY_PATH)", "")
+LD_LIBRARY_PATH=debian/tmp/opt/trinity/lib
+else
+LD_LIBRARY_PATH += :debian/tmp/opt/trinity/lib
+endif
+export LD_LIBRARY_PATH
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
include /usr/share/cdbs/1/rules/utils.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+DEB_KDE_APIDOX := yes
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+CXXFLAGS := -DSMB_CTX_FLAG_USE_KERBEROS -DSMB_CTX_FLAG_FALLBACK_AFTER_KERBEROS -g -Wall $(DEB_OPT_FLAG)
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_INSTALL_PREFIX="/opt/trinity" \
@@ -27,12 +32,9 @@ DEB_CMAKE_EXTRA_FLAGS := \
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-DEB_COMPRESS_EXCLUDE := .dcl .docbook -license .tag .sty .el
-
-DEB_DH_MAKESHLIBS_ARGS_libsvnqt4 := -V
-
-# Tell dh_shlibdeps where to find our own libs.
-DEB_SHLIBDEPS_INCLUDE := debian/tmp/opt/trinity/lib
+# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
+# never build in parallel, regardless of DEB_BUILD_OPTIONS.
+DEB_BUILD_PARALLEL = true
binary-install/kdesvn-trinity::
mv debian/kdesvn-trinity/usr/share/man debian/kdesvn-trinity/opt/trinity/share/