summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications/kerberostray/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-11-07 19:52:22 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-11-07 19:52:22 -0600
commita80a4af1d2bd8d3d986597cf1ecc21e806131bec (patch)
tree39842cd89d0d4a54e60b2e79cde85ef2f0e3c94b /debian/squeeze/applications/kerberostray/debian/rules
parent3949ac7f7a2a0b669e511a326949562dfa1ea67b (diff)
downloadtde-packaging-a80a4af1d2bd8d3d986597cf1ecc21e806131bec.tar.gz
tde-packaging-a80a4af1d2bd8d3d986597cf1ecc21e806131bec.zip
Add kerberostray packaging to Debian and Ubuntu
Diffstat (limited to 'debian/squeeze/applications/kerberostray/debian/rules')
-rwxr-xr-xdebian/squeeze/applications/kerberostray/debian/rules24
1 files changed, 24 insertions, 0 deletions
diff --git a/debian/squeeze/applications/kerberostray/debian/rules b/debian/squeeze/applications/kerberostray/debian/rules
new file mode 100755
index 000000000..242fb2c84
--- /dev/null
+++ b/debian/squeeze/applications/kerberostray/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap