summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications/koffice-i18n/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-02-28 02:18:58 +0100
committerSlávek Banko <slavek.banko@axis.cz>2016-02-28 02:18:58 +0100
commit639c18e5e10b68f5dea1b68665ba08b2e25f08e5 (patch)
treef2decf15060995babefc7a7cf2b0d9ee1530e612 /debian/squeeze/applications/koffice-i18n/debian/rules
parenta02d02a9479da792b2196de5e84811b012e95b05 (diff)
downloadtde-packaging-639c18e5e10b68f5dea1b68665ba08b2e25f08e5.tar.gz
tde-packaging-639c18e5e10b68f5dea1b68665ba08b2e25f08e5.zip
Allow parallel make for i18n packages on Debian and Ubuntu
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/squeeze/applications/koffice-i18n/debian/rules')
-rwxr-xr-xdebian/squeeze/applications/koffice-i18n/debian/rules9
1 files changed, 7 insertions, 2 deletions
diff --git a/debian/squeeze/applications/koffice-i18n/debian/rules b/debian/squeeze/applications/koffice-i18n/debian/rules
index 82e0c4c13..00a275f9e 100755
--- a/debian/squeeze/applications/koffice-i18n/debian/rules
+++ b/debian/squeeze/applications/koffice-i18n/debian/rules
@@ -3,6 +3,11 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ DEB_PARALLEL_JOBS ?= $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+endif
+DEB_MAKE_PARALLEL ?= $(and $(DEB_BUILD_PARALLEL),$(DEB_PARALLEL_JOBS),-j$(DEB_PARALLEL_JOBS))
+
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
@@ -28,7 +33,7 @@ endif
cd $$i && \
autoreconf && automake -f && $(MAKE) -f ../admin/Makefile.common && \
./configure $(configkde); \
- $(MAKE); \
+ $(MAKE) $(DEB_MAKE_PARALLEL); \
cd ..; \
done
@@ -54,7 +59,7 @@ binary-indep: build
( \
cd $$i && \
echo $$(install_dir) && \
- $(MAKE) install DESTDIR=`pwd`/../debian/$$i-trinity; \
+ $(MAKE) install DESTDIR=`pwd`/../debian/$$i-trinity $(DEB_MAKE_PARALLEL); \
cd .. \
) \
done