summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications/tdeio-sword/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-09-23 01:30:23 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-09-23 01:30:23 +0200
commitdf4a92a96695137c875545a47fc24a4b707ab14b (patch)
treeff32fb96c8a49b00850a33d94162e70ae42173aa /debian/squeeze/applications/tdeio-sword/debian/rules
parentd6c955d12d14fdba4db7a8522c519355991fa5f7 (diff)
downloadtde-packaging-df4a92a96695137c875545a47fc24a4b707ab14b.tar.gz
tde-packaging-df4a92a96695137c875545a47fc24a4b707ab14b.zip
Add packaging files for tdeio-sword on Debian and Ubuntu
Diffstat (limited to 'debian/squeeze/applications/tdeio-sword/debian/rules')
-rwxr-xr-xdebian/squeeze/applications/tdeio-sword/debian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/squeeze/applications/tdeio-sword/debian/rules b/debian/squeeze/applications/tdeio-sword/debian/rules
new file mode 100755
index 000000000..c2ff1658d
--- /dev/null
+++ b/debian/squeeze/applications/tdeio-sword/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+clean::
+ dh_testdir
+ rm -f debian/stamp-bootstrap