summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications/tork
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-07-27 18:56:21 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-07-27 18:56:21 +0200
commit4a6297b52b5b7631e78d1959b40741deda96ec3c (patch)
treecc1f89a874457e61bda3f9d452028f4f523e4f11 /debian/squeeze/applications/tork
parentfffefae7ab25729d53eb7e5e714648ede81322b9 (diff)
downloadtde-packaging-4a6297b52b5b7631e78d1959b40741deda96ec3c.tar.gz
tde-packaging-4a6297b52b5b7631e78d1959b40741deda96ec3c.zip
Add tork packaging files for Debian and Ubuntu
Diffstat (limited to 'debian/squeeze/applications/tork')
-rw-r--r--debian/squeeze/applications/tork/debian/cdbs/buildvars.mk86
-rw-r--r--debian/squeeze/applications/tork/debian/cdbs/debian-qt-kde.mk109
-rw-r--r--debian/squeeze/applications/tork/debian/cdbs/kde.mk97
-rw-r--r--debian/squeeze/applications/tork/debian/cdbs/uploaders.mk29
-rw-r--r--debian/squeeze/applications/tork/debian/cdbs/versions.pl19
-rw-r--r--debian/squeeze/applications/tork/debian/changelog146
-rw-r--r--debian/squeeze/applications/tork/debian/compat1
-rw-r--r--debian/squeeze/applications/tork/debian/control38
-rw-r--r--debian/squeeze/applications/tork/debian/copyright209
-rwxr-xr-xdebian/squeeze/applications/tork/debian/rules38
-rw-r--r--debian/squeeze/applications/tork/debian/source/format1
-rw-r--r--debian/squeeze/applications/tork/debian/source/options6
-rw-r--r--debian/squeeze/applications/tork/debian/tork-data-trinity.install4
-rw-r--r--debian/squeeze/applications/tork/debian/tork-trinity.install7
-rw-r--r--debian/squeeze/applications/tork/debian/tork-trinity.postinst9
-rw-r--r--debian/squeeze/applications/tork/debian/tork-trinity.postrm9
-rw-r--r--debian/squeeze/applications/tork/debian/watch2
17 files changed, 810 insertions, 0 deletions
diff --git a/debian/squeeze/applications/tork/debian/cdbs/buildvars.mk b/debian/squeeze/applications/tork/debian/cdbs/buildvars.mk
new file mode 100644
index 000000000..23d4709dc
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/cdbs/buildvars.mk
@@ -0,0 +1,86 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2002,2003 Colin Walters <walters@debian.org>
+# Description: Defines some useful variables, but no rules
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_rules_buildvars
+_cdbs_rules_buildvars = 1
+
+CDBS_VERSION = something
+
+# Common useful variables
+DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
+
+# Split into arch/indep packages
+ifneq ($(DEB_INDEP_PACKAGES),cdbs)
+DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
+DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
+endif
+# Split into normal and udeb packages
+ifeq ($(DEB_UDEB_PACKAGES),)
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+else
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+endif
+# Too much bother for now. If someone complains we'll fix it.
+#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
+#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
+# A handy list of every package, udeb or not
+DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
+DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
+DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
+
+DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+
+# Some support for srcdir != builddir builds.
+# These are relative to the root of the package
+DEB_SRCDIR ?= .
+DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
+
+# Miscellaneous bits
+DEB_ARCH = $(shell dpkg --print-architecture)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
+DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
+DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
+DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
+
+ifeq ($(words $(DEB_ALL_PACKAGES)),1)
+ DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
+else
+ DEB_DESTDIR = $(CURDIR)/debian/tmp/
+endif
+
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
+
+endif
diff --git a/debian/squeeze/applications/tork/debian/cdbs/debian-qt-kde.mk b/debian/squeeze/applications/tork/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..ba002080b
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,109 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+#include debian/cdbs/uploaders.mk
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/squeeze/applications/tork/debian/cdbs/kde.mk b/debian/squeeze/applications/tork/debian/cdbs/kde.mk
new file mode 100644
index 000000000..765560c89
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/cdbs/kde.mk
@@ -0,0 +1,97 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-prehook-impl::
+ mkdir -p po
+ -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
+ -for file in po/*pot; do \
+ sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
+ done
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+ rm -rf po/*.pot
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/squeeze/applications/tork/debian/cdbs/uploaders.mk b/debian/squeeze/applications/tork/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders
diff --git a/debian/squeeze/applications/tork/debian/cdbs/versions.pl b/debian/squeeze/applications/tork/debian/cdbs/versions.pl
new file mode 100644
index 000000000..75c9add4b
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/debian/squeeze/applications/tork/debian/changelog b/debian/squeeze/applications/tork/debian/changelog
new file mode 100644
index 000000000..3b95e00b3
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/changelog
@@ -0,0 +1,146 @@
+tork-trinity (0.33-1) unstable; urgency=low
+
+ * Initial Release for TDE
+
+ -- Slávek Banko <slavek.banko@axis.cz> Sat, 27 Jul 2013 17:16:15 +0200
+
+tork (0.33-1) unstable; urgency=low
+
+ * New upstream release.
+ * Bump Standards-Version to 3.9.1 (no changes needed).
+
+ -- Patrick Matthäi <pmatthaei@debian.org> Sun, 15 Aug 2010 11:44:13 +0200
+
+tork (0.32~pre1-1) unstable; urgency=medium
+
+ * New upstream pre-release.
+ - Detect GnuTLS about pkg-config now, also adding pkg-config as build
+ dependency.
+ Closes: #529908
+ - Adjust debian/tork.install.
+ * Fix typo in get-orig-source target.
+ * Merge 0.31-1~bpo50+1 changelog.
+ * Bump Standards-Version to 3.8.3 (no changes needed).
+ * Wrap build dependency line.
+ * Depend and Build-Depend on torsocks, also build tork with the external
+ torsocks option. This fixes a FTBFS with the current autofoo scripts.
+ * Convert package to 3.0 (quilt).
+ * Remove tsocks from depends, we are using now torsocks.
+
+ -- Patrick Matthäi <pmatthaei@debian.org> Fri, 20 Nov 2009 08:16:58 +0100
+
+tork (0.31-2) unstable; urgency=low
+
+ * Bump Standards-Version to 3.8.1 (no changes needed).
+ * Change my email address.
+ * Remove DM-Upload-Allowed control field.
+ * Add upstreams changelog to the packages.
+ * Refer in debian/copyright to the GPL-2 file instead of GPL.
+ This fixes the lintian warning copyright-refers-to-symlink-license.
+
+ -- Patrick Matthäi <pmatthaei@debian.org> Thu, 23 Apr 2009 13:42:39 +0200
+
+tork (0.31-1~bpo50+1) lenny-backports; urgency=low
+
+ * Rebuild for lenny-backports.
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Tue, 17 Feb 2009 18:28:26 +0200
+
+tork (0.31-1) unstable; urgency=low
+
+ * New upstream release.
+ * Add get-orig-source target.
+ * Fix copyright-with-old-dh-make-debian-copyright.
+ * Fix binary-control-field-duplicates-source.
+ * Add my own Debian packaging copyright.
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Wed, 4 Feb 2009 12:42:02 +0200
+
+tork (0.30-2) unstable; urgency=low
+
+ * Removed icedove-torbutton from the suggests, it has been removed from the
+ archive.
+ * Add missing ${misc:Depends}. Thanks lintian.
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Wed, 24 Dec 2008 11:20:45 +0200
+
+tork (0.30-1) unstable; urgency=low
+
+ * New upstream release.
+ Closes: #502155
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Wed, 22 Oct 2008 20:18:57 +0200
+
+tork (0.29.2-2) unstable; urgency=low
+
+ * Uploading to unstable.
+ * Set the -e flag in the maintainer scripts.
+ Thanks lintian.
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Tue, 7 Oct 2008 11:08:22 +0200
+
+tork (0.29.2-1) experimental; urgency=low
+
+ * New upstream release.
+ Uploading to experimental because Lenny is frozen.
+ * Downgrade konqueror recommending to suggesting.
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Sun, 27 Jul 2008 16:00:21 +0200
+
+tork (0.29.1-2) unstable; urgency=low
+
+ * Remove the indefinite article "an" from the short description.
+ Closes: #490050
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Thu, 17 Jul 2008 17:28:30 +0200
+
+tork (0.29.1-1) unstable; urgency=low
+
+ * New upstream release.
+ - Patch has been merged in upstream.
+ - Drop dpatch.
+ - Drop README.source.
+ * Some little debian/rules modifications.
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Sun, 6 Jul 2008 09:52:00 +0200
+
+tork (0.29-1) unstable; urgency=low
+
+ * New upstream release.
+ - Included dpatch again and add 01-gcc43-ftbfs-fix.dpatch.
+ * Reorder odd dh_installdeb call and do not permit dh_makeshlibs to modify
+ the maintainer scripts.
+ Thanks lintian.
+ * Added DM-Upload-Allowed control field.
+ * Bumped Standards-Version to 3.8.0.
+ - Added README.source.
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Sat, 14 Jun 2008 11:18:00 +0100
+
+tork (0.28-1) unstable; urgency=low
+
+ * New upstream release.
+ - Removed 01-fix-gcc4.3-ftbfs.dpatch, it is merged in upstream.
+ - Removed now useless dpatch.
+ * Fixed grammar error in copyright.
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Mon, 14 Apr 2008 15:10:22 +0100
+
+tork (0.27-2) unstable; urgency=low
+
+ * Included dpatch and added 01-fix-gcc4.3-ftbfs.dpatch. There were some
+ #include <cstdlib> missing for the getenv function.
+ * Added icedove-torbutton and iceweasel-torbutton as Suggests for tork.
+ * If the previous build failed at configure, it could happen, that the
+ config.log won't be deleted. Now it will be deleted in the clean target.
+ * Lowered down compatibility level from 6 to 5. The packaging is now tested
+ with debhelper >= 5 versions and it also fixes an lintian warning.
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Thu, 3 Apr 2008 22:08:55 +0100
+
+tork (0.27-1) unstable; urgency=low
+
+ * Initial release.
+ Closes: #444329
+
+ -- Patrick Matthäi <patrick.matthaei@web.de> Sun, 16 Mar 2008 11:59:21 +0100
diff --git a/debian/squeeze/applications/tork/debian/compat b/debian/squeeze/applications/tork/debian/compat
new file mode 100644
index 000000000..7ed6ff82d
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/squeeze/applications/tork/debian/control b/debian/squeeze/applications/tork/debian/control
new file mode 100644
index 000000000..accc58192
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/control
@@ -0,0 +1,38 @@
+Source: tork-trinity
+Section: tde
+Priority: optional
+Homepage: http://tork.sourceforge.net/
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Build-Depends: debhelper (>= 5), cdbs, automake, libtool,
+ tdelibs-trinity-dev, libgeoip-dev, libgnutls-dev,
+ libjpeg-dev, libpng-dev, zlib1g-dev,
+ pkg-config, torsocks
+Standards-Version: 3.9.1
+
+Package: tork-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, tork-data-trinity (= ${source:Version}),
+ geoip-bin, torsocks
+Recommends: tor, privoxy
+Suggests: konqueror-trinity, iceweasel-torbutton
+Description: anonymity manager for TDE
+ TorK is an anonymity manager for the TDE desktop.
+ Browse anonymously on Konqueror, Iceweasel or Opera.
+ Send anonymous email via the MixMinion network.
+ Use ssh, IRC and IM anonymously. Control and monitor
+ your anonymous traffic and non-anonymous traffic on
+ the Tor network.
+
+Package: tork-data-trinity
+Architecture: all
+Depends: ${misc:Depends}
+Recommends: tork-trinity
+Description: anonymity manager for TDE (data files)
+ TorK is an anonymity manager for the TDE desktop.
+ Browse anonymously on Konqueror, Iceweasel or Opera.
+ Send anonymous email via the MixMinion network.
+ Use ssh, IRC and IM anonymously. Control and monitor
+ your anonymous traffic and non-anonymous traffic on
+ the Tor network.
+ .
+ This package contains the data files for tork-trinity.
diff --git a/debian/squeeze/applications/tork/debian/copyright b/debian/squeeze/applications/tork/debian/copyright
new file mode 100644
index 000000000..898d738e9
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/copyright
@@ -0,0 +1,209 @@
+This package was debianized by Patrick Matthäi <patrick.matthaei@web.de> on
+Sun, 16 Mar 2008 11:59:21 +0100.
+
+It was downloaded from <http://tork.sourceforge.net/>.
+
+
+The directory "src/arkollon" provides Arkollon.
+
+Upstream Author: David Sansome <me@davidsansome.com>
+
+Copyright: 2004 by David Sansome <me@davidsansome.com>
+
+License:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL-2 file.
+
+
+The directory "src/GeoIP-1.4.0" contains the GeoIP library.
+
+Upstream Author: T.J. Mather <tjmather@maxmind.com>
+
+Copyright: 2007 MaxMind LLC
+
+License:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL-2 file.
+
+
+The directory "src/tsocks" provides a wrapper library for transparent SOCKS.
+
+Upstream Author: Shaun Clowes
+
+Copyright: 2000 Shaun Clowes
+
+License:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL-2 file.
+
+
+The directory "src/upnp" provides a library for UPNP support.
+
+Upstream Author: Joris Guisson <joris.guisson@gmail.com>
+
+Copyright: 2005 Joris Guisson <joris.guisson@gmail.com>
+
+License:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL-2 file.
+
+
+The directory "src/privoxytemplates" contains templates for privoxy.
+
+Upstream Author: Jonathan Foster
+
+Copyright: 2001 the SourceForge Privoxy team. http://www.privoxy.org/
+
+License:
+
+ This program is free software; you can redistribute it
+ and/or modify it under the terms of the GNU General
+ Public License as published by the Free Software
+ Foundation; either version 2 of the License, or (at
+ your option) any later version.
+
+ This program is distributed in the hope that it will
+ be useful, but WITHOUT ANY WARRANTY; without even the
+ implied warranty of MERCHANTABILITY or FITNESS FOR A
+ PARTICULAR PURPOSE. See the GNU General Public
+ License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL-2 file.
+
+
+The rest of the source has the following license.
+
+Upstream Author: Robert Hogan <robert@roberthogan.net>
+
+Copyright: 2006 - 2007 by Robert Hogan <robert@roberthogan.net>
+
+License:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in /usr/share/common-licenses/GPL-2 file.
+
+
+These files in the "src" directory also have additional Copyright holders:
+
+chart.cpp, chart.h:
+ Copyright © 2005 by Hugo Parente Lima
+
+crypto.cpp, crypto.h:
+ Copyright (c) 2001 Matej Pfajfar
+ Copyright (c) 2001-2004, Roger Dingledine
+ Copyright (c) 2004-2006, Roger Dingledine, Nick Mathewson
+ Copyright © 2007, Matt Edman, Justin Hipple
+
+hitwidget.cpp, hitwidget.h:
+ Copyright © 2005 Novell, Inc.
+
+kerrylabel.cpp, kerrylabel.h:
+ Copyright © 1998 Kurt Granroth <granroth@kde.org>
+ Copyright © 2000 Peter Putzer <putzer@kde.org>
+ Copyright © 2005 Jaroslaw Staniek <js@iidea.pl>
+
+kwidgetlistbox.cpp, kwidgetlistbox.h:
+ Copyright © 2005 Petri Damsten <petri.damsten@iki.fi>
+
+likeback.cpp, likeback.h, likeback_private.h:
+ Copyright © 2006 by Sebastien Laout
+
+newstreamosd.cpp, newstreamosd.h:
+ Copyright © 2005 Sebastian Trueg <trueg@k3b.org>
+ Copyright © 1998-2005 Sebastian Trueg <trueg@k3b.org>
+
+crashhandler.cpp, crashhandler.h, overlayWidget.cpp, overlayWidget.h,
+popupMessage.cpp, popupMessage.h:
+ Copyright © 2005 by Max Howell <max.howell@methylblue.com>
+
+torclient.h:
+ Copyright © 1992-2000 Trolltech AS. All rights reserved.
+
+trayhoverpopup.cpp, trayhoverpopup.h, functions.cpp, functions.h, constants.h:
+ Copyright © 2005 by Joris Guisson
+
+trayicon.h:
+ Copyright © 2005 by <joris.guisson@gmail.com>
+ Copyright © 2005 by Ivan Vasic <ivasic@gmail.com>
+
+The Debian packaging is © 2009, Patrick Matthäi <pmatthaei@debian.org> and
+is licensed under the GPL, see above.
diff --git a/debian/squeeze/applications/tork/debian/rules b/debian/squeeze/applications/tork/debian/rules
new file mode 100755
index 000000000..38a29895e
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+install/tork-trinity::
+ mkdir -p debian/tmp/usr/share/menu
+ sed "s|package(tork)|package(tork-trinity)|" \
+ <debian/tmp/opt/trinity/share/menu/tork \
+ >debian/tmp/usr/share/menu/tork-trinity
+
+clean::
+ dh_testdir
+ rm -f debian/stamp-bootstrap
diff --git a/debian/squeeze/applications/tork/debian/source/format b/debian/squeeze/applications/tork/debian/source/format
new file mode 100644
index 000000000..89ae9db8f
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/squeeze/applications/tork/debian/source/options b/debian/squeeze/applications/tork/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/squeeze/applications/tork/debian/tork-data-trinity.install b/debian/squeeze/applications/tork/debian/tork-data-trinity.install
new file mode 100644
index 000000000..cde21cb0e
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/tork-data-trinity.install
@@ -0,0 +1,4 @@
+debian/tmp/opt/trinity/share/apps/tork/*
+debian/tmp/opt/trinity/share/doc/*
+debian/tmp/opt/trinity/share/locale/*
+debian/tmp/opt/trinity/share/config.kcfg/*
diff --git a/debian/squeeze/applications/tork/debian/tork-trinity.install b/debian/squeeze/applications/tork/debian/tork-trinity.install
new file mode 100644
index 000000000..3a69b5a76
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/tork-trinity.install
@@ -0,0 +1,7 @@
+debian/tmp/opt/trinity/bin/*
+debian/tmp/usr/share/menu/tork-trinity
+debian/tmp/opt/trinity/share/pixmaps/tork.xpm
+debian/tmp/opt/trinity/share/man/*
+debian/tmp/opt/trinity/share/apps/tork/icons/hicolor/48x48/apps/tork.png
+debian/tmp/opt/trinity/share/applications/*
+debian/tmp/opt/trinity/share/apps/konqueror/*
diff --git a/debian/squeeze/applications/tork/debian/tork-trinity.postinst b/debian/squeeze/applications/tork/debian/tork-trinity.postinst
new file mode 100644
index 000000000..f2b7c5c96
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/tork-trinity.postinst
@@ -0,0 +1,9 @@
+#! /bin/sh
+
+set -e
+
+if [ -x /usr/bin/update-menus ] ; then update-menus ; fi
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/squeeze/applications/tork/debian/tork-trinity.postrm b/debian/squeeze/applications/tork/debian/tork-trinity.postrm
new file mode 100644
index 000000000..f2b7c5c96
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/tork-trinity.postrm
@@ -0,0 +1,9 @@
+#! /bin/sh
+
+set -e
+
+if [ -x /usr/bin/update-menus ] ; then update-menus ; fi
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/squeeze/applications/tork/debian/watch b/debian/squeeze/applications/tork/debian/watch
new file mode 100644
index 000000000..94d0d842f
--- /dev/null
+++ b/debian/squeeze/applications/tork/debian/watch
@@ -0,0 +1,2 @@
+version=3
+http://sf.net/tork/tork-(.*)\.tar\.gz