summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2016-04-11 01:42:04 +0200
committerSlávek Banko <slavek.banko@axis.cz>2016-04-11 01:42:04 +0200
commitb790788c923e357cc31a4fb4feb25d58b478af51 (patch)
tree250cd79ce1f1796e78cadc6fb209a0b228403e0a /debian/squeeze/applications
parentdb58dbc6a7af96ad806caf377366f0dd4225fcef (diff)
downloadtde-packaging-b790788c923e357cc31a4fb4feb25d58b478af51.tar.gz
tde-packaging-b790788c923e357cc31a4fb4feb25d58b478af51.zip
Add tastymenu packaging files for Debian and Ubuntu
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/squeeze/applications')
-rw-r--r--debian/squeeze/applications/tastymenu/debian/cdbs/debian-qt-kde.mk120
-rw-r--r--debian/squeeze/applications/tastymenu/debian/cdbs/kde.mk99
-rw-r--r--debian/squeeze/applications/tastymenu/debian/cdbs/versions.pl19
-rw-r--r--debian/squeeze/applications/tastymenu/debian/changelog107
-rw-r--r--debian/squeeze/applications/tastymenu/debian/compat1
-rw-r--r--debian/squeeze/applications/tastymenu/debian/control13
-rw-r--r--debian/squeeze/applications/tastymenu/debian/copyright17
-rw-r--r--debian/squeeze/applications/tastymenu/debian/patches/series1
-rwxr-xr-xdebian/squeeze/applications/tastymenu/debian/rules14
-rw-r--r--debian/squeeze/applications/tastymenu/debian/source/format1
-rw-r--r--debian/squeeze/applications/tastymenu/debian/source/options6
11 files changed, 398 insertions, 0 deletions
diff --git a/debian/squeeze/applications/tastymenu/debian/cdbs/debian-qt-kde.mk b/debian/squeeze/applications/tastymenu/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..32ba4acfb
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,120 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+#include debian/cdbs/uploaders.mk
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/squeeze/applications/tastymenu/debian/cdbs/kde.mk b/debian/squeeze/applications/tastymenu/debian/cdbs/kde.mk
new file mode 100644
index 000000000..023886fc8
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/cdbs/kde.mk
@@ -0,0 +1,99 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-prehook-impl::
+ mkdir -p po
+ -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
+ -for file in po/*pot; do \
+ sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
+ done
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+ rm -rf po/*.pot
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/squeeze/applications/tastymenu/debian/cdbs/versions.pl b/debian/squeeze/applications/tastymenu/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/squeeze/applications/tastymenu/debian/changelog b/debian/squeeze/applications/tastymenu/debian/changelog
new file mode 100644
index 000000000..4696b9372
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/changelog
@@ -0,0 +1,107 @@
+tastymenu-trinity (1.0.8-0debian7.0.0+0) wheezy; urgency=low
+
+ * Initial Release for TDE
+
+ -- Slávek Banko <slavek.banko@axis.cz> Sun, 10 Apr 2016 03:32:32 +0200
+
+tastymenu (1.0.7) unstable; urgency=low
+
+ *Fixed a typo in the config dialog
+
+ -- Marco Martin <notmart@gmail.com> Wed, 6 Feb 2008 12:53:00 +0100
+
+tastymenu (1.0.6) unstable; urgency=low
+
+ *Now all the applications should be displayed again
+ *Brazillian portoguese translation by Ewerton de A. Dutra
+
+ -- Marco Martin <notmart@gmail.com> Thu, 13 Dec 2007 17:30:00 +0100
+
+tastymenu (1.0.5) unstable; urgency=low
+
+ *fixed the about box
+ *some fixes in packaging
+ *now it's installed in the right directory (for example in /usr/lib/kde3 instead of /usr/lib)
+
+ -- Marco Martin <notmart@gmail.com> Thu, 22 Nov 2007 15:40:00 +0100
+
+tastymenu (1.0.4) unstable; urgency=low
+
+ *updated French translation
+ *updated Slovenian translation
+ *fixed a crash on lright mouse button click on search field
+ *the old memory leak should be somewhat mitigated
+
+ -- Marco Martin <notmart@gmail.com> Sat, 17 Nov 2007 13:30:00 +0100
+
+tastymenu (1.0.3) unstable; urgency=low
+
+ * Fixed a bug that occurred when clicking on the search result if the menu mode was "recent/most used applications"
+ * Polish translation by Tomasz Argasiński
+ * Some fixes in the Slovenian translation
+ * description text shouldn't become too little
+
+ -- Marco Martin <notmart@gmail.com> Wed, 24 Oct 2007 14:00:00 +0100
+
+tastymenu (1.0.2) unstable; urgency=low
+
+ * Slovenian translation by Matija Šuklje
+ * Fixed a little build problem
+
+ -- Marco Martin <notmart@gmail.com> Wed, 17 Oct 2007 21:00:00 +0100
+
+tastymenu (1.0.1) unstable; urgency=low
+
+ * Menu and tooltip no longer steals mouse and keyboard input
+ * Better management of the tooltip
+ * No separators when the list is in alphabetical order
+ * Finnish translations by Tommi Nieminen
+
+ -- Marco Martin <notmart@gmail.com> Thu, 11 Oct 2007 17:25:00 +0100
+
+tastymenu (1.0) unstable; urgency=low
+
+ * Not having particular problems, released it as 1.0
+ * French translation by Laurent Hilsz
+
+ -- Marco Martin <notmart@gmail.com> Wed, 19 Sep 2007 15:16:00 +0100
+
+tastymenu (1.0rc2) unstable; urgency=low
+
+ * Rearranging the items of the left column by drag and drop works again
+ * The layout should be a little bit more polished
+ * Updated Ukrainian translation
+
+ -- Marco Martin <notmart@gmail.com> Sun, 09 Sep 2007 17:04:00 +0100
+
+tastymenu (1.0rc1) unstable; urgency=low
+
+ * Search field should be a lot faster
+ * Only strings with at least three characters are being searched (necessary for the speedup)
+ * Corrected a bug that prevented to search into application descriptions
+
+ -- Marco Martin <notmart@gmail.com> Wed, 22 Aug 2007 12:40:00 +0100
+
+tastymenu (0.9.1) unstable; urgency=low
+
+ * Ukrainian translation by Motsyo Vitaliy
+
+ -- Marco Martin <notmart@gmail.com> Tue, 21 Aug 2007 19:58:00 +0100
+
+tastymenu (0.9) unstable; urgency=low
+
+ * Add to desktop option in menuitems
+ * Drag and drop from menu to desktop
+ * Option to set different icons sizes in the three columns
+ * the button text label should always be of a visible color
+ * most used/recently used applications list updates in realtime
+ * clear most used/recently used applications list
+ * updated russian and german translations
+
+ -- Marco Martin <notmart@gmail.com> Sat, 04 Aug 2007 14:00:00 +0100
+
+tastymenu (0.8.2) unstable; urgency=low
+
+ * First Debian Release
+
+ -- Marco Martin <notmart@gmail.com> Sun, 20 May 2007 18:35:00 +0100 \ No newline at end of file
diff --git a/debian/squeeze/applications/tastymenu/debian/compat b/debian/squeeze/applications/tastymenu/debian/compat
new file mode 100644
index 000000000..1e8b31496
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/compat
@@ -0,0 +1 @@
+6
diff --git a/debian/squeeze/applications/tastymenu/debian/control b/debian/squeeze/applications/tastymenu/debian/control
new file mode 100644
index 000000000..e26dcc126
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/control
@@ -0,0 +1,13 @@
+Source: tastymenu-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+X-Original-Maintainer: Marco Martin <notmart@gmail.com>
+Build-Depends: cdbs, debhelper (>= 6), quilt, automake, libtool, tdelibs-trinity-dev, libxau-dev
+Standards-Version: 3.8.0
+
+Package: tastymenu-trinity
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Replacement for TMenu
+ Tasty Menu is a TMenu replacement aiming to provide the maximum usability and flexibility.
diff --git a/debian/squeeze/applications/tastymenu/debian/copyright b/debian/squeeze/applications/tastymenu/debian/copyright
new file mode 100644
index 000000000..30b510eae
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/copyright
@@ -0,0 +1,17 @@
+Copyright:
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU Lesser General Public License as published by
+ the Free Software Foundation; version 2 dated June, 1991.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ 02111-1307, USA.
+
+ On Debian GNU/Linux systems, the complete text of the GNU Lesser General
+ Public License can be found in `/usr/share/common-licenses/LGPL'.
diff --git a/debian/squeeze/applications/tastymenu/debian/patches/series b/debian/squeeze/applications/tastymenu/debian/patches/series
new file mode 100644
index 000000000..8b1378917
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/patches/series
@@ -0,0 +1 @@
+
diff --git a/debian/squeeze/applications/tastymenu/debian/rules b/debian/squeeze/applications/tastymenu/debian/rules
new file mode 100755
index 000000000..c9d7823f9
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
diff --git a/debian/squeeze/applications/tastymenu/debian/source/format b/debian/squeeze/applications/tastymenu/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/squeeze/applications/tastymenu/debian/source/options b/debian/squeeze/applications/tastymenu/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/squeeze/applications/tastymenu/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*