summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/applications
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2015-02-16 20:00:34 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2015-02-16 20:00:34 -0600
commitcba497dfe2cd1bf56ce6baf0d207d54c83154a1a (patch)
tree1c7ea668acee11cf8e62d32f056b09e1a29f1ae1 /debian/squeeze/applications
parentf6acdd64bf5690a2aeed03a4eb7211115cb0394e (diff)
downloadtde-packaging-cba497dfe2cd1bf56ce6baf0d207d54c83154a1a.tar.gz
tde-packaging-cba497dfe2cd1bf56ce6baf0d207d54c83154a1a.zip
Update keximdb packaging files on Debian and Ubuntu
Diffstat (limited to 'debian/squeeze/applications')
-rw-r--r--debian/squeeze/applications/keximdb/debian/cdbs/buildvars.mk86
-rw-r--r--debian/squeeze/applications/keximdb/debian/cdbs/debian-qt-kde.mk111
-rw-r--r--debian/squeeze/applications/keximdb/debian/cdbs/kde.mk97
-rw-r--r--debian/squeeze/applications/keximdb/debian/cdbs/uploaders.mk29
-rw-r--r--debian/squeeze/applications/keximdb/debian/cdbs/versions.pl19
-rw-r--r--debian/squeeze/applications/keximdb/debian/changelog28
-rw-r--r--debian/squeeze/applications/keximdb/debian/compat1
-rw-r--r--debian/squeeze/applications/keximdb/debian/control20
-rw-r--r--debian/squeeze/applications/keximdb/debian/copyright33
-rw-r--r--debian/squeeze/applications/keximdb/debian/docs1
-rwxr-xr-xdebian/squeeze/applications/keximdb/debian/rules93
11 files changed, 518 insertions, 0 deletions
diff --git a/debian/squeeze/applications/keximdb/debian/cdbs/buildvars.mk b/debian/squeeze/applications/keximdb/debian/cdbs/buildvars.mk
new file mode 100644
index 000000000..23d4709dc
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/cdbs/buildvars.mk
@@ -0,0 +1,86 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2002,2003 Colin Walters <walters@debian.org>
+# Description: Defines some useful variables, but no rules
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_rules_buildvars
+_cdbs_rules_buildvars = 1
+
+CDBS_VERSION = something
+
+# Common useful variables
+DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
+
+# Split into arch/indep packages
+ifneq ($(DEB_INDEP_PACKAGES),cdbs)
+DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
+DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
+endif
+# Split into normal and udeb packages
+ifeq ($(DEB_UDEB_PACKAGES),)
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+else
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+endif
+# Too much bother for now. If someone complains we'll fix it.
+#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
+#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
+# A handy list of every package, udeb or not
+DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
+DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
+DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
+
+DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+
+# Some support for srcdir != builddir builds.
+# These are relative to the root of the package
+DEB_SRCDIR ?= .
+DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
+
+# Miscellaneous bits
+DEB_ARCH = $(shell dpkg --print-architecture)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
+DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
+DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
+DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
+
+ifeq ($(words $(DEB_ALL_PACKAGES)),1)
+ DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
+else
+ DEB_DESTDIR = $(CURDIR)/debian/tmp/
+endif
+
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
+
+endif
diff --git a/debian/squeeze/applications/keximdb/debian/cdbs/debian-qt-kde.mk b/debian/squeeze/applications/keximdb/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..f72df2152
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,111 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+#include debian/cdbs/uploaders.mk
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/squeeze/applications/keximdb/debian/cdbs/kde.mk b/debian/squeeze/applications/keximdb/debian/cdbs/kde.mk
new file mode 100644
index 000000000..765560c89
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/cdbs/kde.mk
@@ -0,0 +1,97 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/tde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-prehook-impl::
+ mkdir -p po
+ -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
+ -for file in po/*pot; do \
+ sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
+ done
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+ rm -rf po/*.pot
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/squeeze/applications/keximdb/debian/cdbs/uploaders.mk b/debian/squeeze/applications/keximdb/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders
diff --git a/debian/squeeze/applications/keximdb/debian/cdbs/versions.pl b/debian/squeeze/applications/keximdb/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/squeeze/applications/keximdb/debian/changelog b/debian/squeeze/applications/keximdb/debian/changelog
new file mode 100644
index 000000000..eae5fc20f
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/changelog
@@ -0,0 +1,28 @@
+keximdb (1.1.0-1ubuntu1) jaunty; urgency=low
+
+ * debian/rules: added --without-arts parameter to configure script call to
+ rebuild without arts support (LP: #320915)
+
+ -- Fabrice Coutadeur <fabricesp@ubuntu.com> Fri, 17 Apr 2009 18:15:55 +0000
+
+keximdb (1.1.0-1) unstable; urgency=low
+
+ * Update for KOffice 1.6 packages.
+
+ -- Martin Ellis <martin.ellis@kdemail.net> Wed, 18 Oct 2006 21:22:27 +0100
+
+keximdb (1.0.2-1) unstable; urgency=low
+
+ * Update for KOffice 1.5 packages
+ * libkexi-dev is gone, using koffice-dev
+ * Update standards version to 3.7.2
+ * Update copyright: new description, and update FSF address
+
+ -- Martin Ellis <martin.ellis@kdemail.net> Fri, 14 Jul 2006 17:08:59 +0100
+
+keximdb (0.9-1) UNRELEASED; urgency=low
+
+ * Initial Release.
+
+ -- Martin Ellis <martin.ellis@kdemail.net> Mon, 30 May 2005 16:29:07 +0000
+
diff --git a/debian/squeeze/applications/keximdb/debian/compat b/debian/squeeze/applications/keximdb/debian/compat
new file mode 100644
index 000000000..b8626c4cf
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/squeeze/applications/keximdb/debian/control b/debian/squeeze/applications/keximdb/debian/control
new file mode 100644
index 000000000..351b6b748
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/control
@@ -0,0 +1,20 @@
+Source: keximdb
+Priority: optional
+Maintainer: Ubuntu MOTU Developers <ubuntu-motu@lists.ubuntu.com>
+XSBC-Original-Maintainer: Martin Ellis <martin.ellis@kdemail.net>
+Build-Depends: debhelper (>= 4.0.0), autotools-dev, koffice-trinity-dev, libglib2.0-dev
+Standards-Version: 3.7.2
+Section: tde
+
+Package: kexi-mdb-plugin-trinity
+Section: tde
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: MS Access (MDB) driver for Kexi [Trinity]
+ MDB migration driver for converting MS Access databases in MDB files
+ into KexiDB databases.
+ .
+ This driver allows Kexi, the KOffice database program, to convert MDB
+ database files to Kexi databases via the Tools->Migration->Import Database
+ menu option. Note that this package does not allow MDB files to be opened
+ directly - they must be converted to a Kexi database first.
diff --git a/debian/squeeze/applications/keximdb/debian/copyright b/debian/squeeze/applications/keximdb/debian/copyright
new file mode 100644
index 000000000..6a1376c24
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/copyright
@@ -0,0 +1,33 @@
+This package was debianized by Martin Ellis <martin.ellis@kdemail.net> on
+Mon, 30 May 2005 16:29:07 +0000.
+
+It was downloaded from
+svn://anonsvn.kde.org/home/kde/trunk/kdenonbeta/keximdb
+
+Copyright Holder: Martin Ellis <martin.ellis@kdemail.net>
+
+License:
+
+ keximdb - a Kexi plugin for importing Microsoft Access databases.
+ Copyright (C) 2005-2006 Martin Ellis <martin.ellis@kdemail.net>
+
+ This library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.
+
+ This library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.
+
+ You should have received a copy of the GNU Lesser General Public
+ License along with this library; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU Lesser General
+Public License can be found in `/usr/share/common-licenses/LGPL'.
+
+The Debian packaging is Copyright 2006 Martin Ellis <martin.ellis@kdemail.net>
+and is also licensed under the LGPL, see `/usr/share/common-licenses/LGPL'.
+
diff --git a/debian/squeeze/applications/keximdb/debian/docs b/debian/squeeze/applications/keximdb/debian/docs
new file mode 100644
index 000000000..e845566c0
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/debian/squeeze/applications/keximdb/debian/rules b/debian/squeeze/applications/keximdb/debian/rules
new file mode 100755
index 000000000..9890ae841
--- /dev/null
+++ b/debian/squeeze/applications/keximdb/debian/rules
@@ -0,0 +1,93 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# debian/rules for keximdb.
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+config.status: configure
+ dh_testdir
+ CFLAGS="$(CFLAGS)" ./configure \
+ --host=$(DEB_HOST_GNU_TYPE) \
+ --build=$(DEB_BUILD_GNU_TYPE) \
+ --disable-rpath \
+ --without-arts \
+ --prefix=/opt/trinity
+
+build: build-stamp
+build-stamp: config.status
+ dh_testdir
+ $(MAKE)
+ touch build-stamp
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/kexi-mdb-plugin
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs ChangeLog
+ dh_installdocs
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install